Jump to content

Archived

This topic is now archived and is closed to further replies.

emerge

Paypal drop down button not working

Recommended Posts

emerge

I am linking to a page I created to show the issue.  At first I called paypal, but they had me check their code in an HTML test bed and it worked fine.  So I am looking here for insight.  Basically the drop down button does not function as a dropdown button.

http://emergebirthservices.com/page-show-paypal-button/

Website URL: emergebirthservices.com
Framework Version: 2.4.5
WordPress Version:3.9.1
Plugins in Use:Gravity Forms
Server/Host:Blue Host
Screenshots: link to page showing issue
Details: described above.

Share this post


Link to post
Share on other sites
Simon

bit difficult to diagnose without seeing the HTML they supplied you with, but a guess would be you pasted it all into the WP editor right? In wich case the HTML code will now be full of line breaks, WP hates these and changes them all into <br /> which can break pasted html.

 

So can you paste your code into a pastebin so that we can test it too?

Share this post


Link to post
Share on other sites
emerge

Where is a pastebin? I would love for you to test it!

Share this post


Link to post
Share on other sites
batman

HI emerge

http://forum.pagelines.com/pst/

You can see above the title of the topic

;)


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
emerge

I am assuming I now copy the results here?
 

  1. <form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top">
  2. <input type="hidden" name="cmd" value="_s-xclick">
  3. <input type="hidden" name="hosted_button_id" value="353TY5LPLRXV6">
  4. <table>
  5. <tr><td><input type="hidden" name="on0" value="Month">Month</td></tr><tr><td><select name="os0">
  6.         <option value="June">June </option>
  7.         <option value="July">July </option>
  8.         <option value="August">August </option>
  9. </select> </td></tr>
  10. </table>
  11. <input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_buynow_SM.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!">
  12. <img alt="" border="0" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1">
  13. </form>

Share this post


Link to post
Share on other sites
Simon

The point of a pastebin is that huge blocks of code that do not render in a forum are kept somewhere where they are readable, so no lol

 

you paste your html into the pastebin then paste the url here.

Share this post


Link to post
Share on other sites
Simon

Yea that html works 100% when i tested it, it looks totally different on your test site tho: https://cloudup.com/ch38A6VOpZI

See how you have <select></seclect> for every option? thats whats making seperate dropdowns.

Share this post


Link to post
Share on other sites
emerge

SO I tried removing those from the code. I removed both the <select before the word "name" and the </select> at the end of each option.  That did not work.  Then I just removed the <select at the beginning. Then just the </select> at the end and none of these changes to the code is making it function properly.  Ideas?

Share this post


Link to post
Share on other sites
Simon

simply paste the code you put into the pastebin into your page.

 

The code on the page is not valid, it wont work.

Share this post


Link to post
Share on other sites
emerge

should i try manually entering the code rather than copy/paste.

Share this post


Link to post
Share on other sites
emerge

Thank you for your prompt replies. Your patience, and you sense of humor when I accidentally pasted all the code into the thread.  I will do that! :-)

Share this post


Link to post
Share on other sites
emerge

Okay, I'm sorry. I pasted the code from the pastebin into the text tab and it looks right when I am in the text tab, but the second I switch over to the visual tab, it looks wrong and when I switch back to the text tab the code is all wrong again.  Why is it reformatting the code?

Share this post


Link to post
Share on other sites
Danny

Do not switch between the Visual and Text editor in WordPress, otherwise you will get formatting issues. You need to use one or the other, never both.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
emerge

But even when I add the code straight into the text tab, and then view the page the code is still changed.

Share this post


Link to post
Share on other sites
Danny

If the code is changing then add it to a code editor first, make sure it is in the correct format and then copy and paste it into the Text editor in WordPress.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
emerge

You were right about toggling back and forth.  Bascially I just did all the formating on the text that I needed and then entered the code and didn't toggle back and forth. It worked.  Thank you.

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×