Jump to content

Archived

This topic is now archived and is closed to further replies.

andylemay

DMS pro tools breaks link and post pins

Recommended Posts

andylemay

Hi pagelines,

 

This is a continuation of a previous thread that was closed.

 

As requested I disabled all plugin's except DMS pro tools and post pins. Cleared all caches and still it causes the problems.  Problems are.

 

1. "Load more posts" in post pins news articles page just loads the same news items as it currently shown again.  Resulting in a duplicate set on the screen.

 

2. Links get broken in a weird way. I will try and explain.

  • You're on page A
  • You click a new link to page B
  • You see the link to page B in the browser bar and the page refreshes
  • But you see page A come up again.

Disabling DMS Pro tool fixes these problem.

 

Thanks

 

Andy

www.ewizz.co.za

Share this post


Link to post
Share on other sites
Danny

Hi,

 

I have viewed the site you linked above and that site has a cache plugin active, which from the description of your issue, sounds like it is the cause.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
andylemay

Hi Danny,

 

As I stated above, I deactivated ALL the plugins "except DMS pro tools and post pins only when I deactivated DMS Pro Tools did it stop.

 

Thanks

 

Andy

Share this post


Link to post
Share on other sites
andylemay

Hi Danny,

 

I've tested this now with DMS 2.1 and the post pins issue has gone but the links issues is still there.  

 

Thanks Andy

Share this post


Link to post
Share on other sites
Danny

I have just activated PostPins on my site that has DMS Pro Tools active, I have no such issue with either loading of Postpins or the page issue you described. Therefore, you likely have Section cache active in DMS Pro Tools or your cache plugin is causing the issue.

 

If the above suggestion doesn't resolve your issue, please contact our helpdesk with the following information.

 

A link to this topic

A link to the site in question

Provide your admin username and password

Make sure DMS debug mode is active

All plugins are disabled.

 

hello at pagelines dot com


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
andylemay

Hi Danny,

 

I disabled all the other plug ins in my testing so no idea where this caching might be.  My site is a live site so I will have to create a test site for you.

 

Thanks Andy

Share this post


Link to post
Share on other sites
Danny

Your live site still has W3 Total Cache active, you can see this by viewing your page source and scrolling to the bottom. The issue with Page A appearing on Page B sounds like its cache related. Also check to see if you do not have section cache enabled in the DMS Pro Tools plugin options.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
andylemay

Hi Danny,

 

Could you tell me where this option to turn off the "section cache" is in the DMS Pro Tools plugin.  There wis not option from the wordpress admin side.  Is it in DMS somewhere?

 

As I said, this is a live site so I have the W3TC caching enabled.  But again I turned it all off to do the testing.  This has been a constant problem for months now.

 

Thanks Andy

Share this post


Link to post
Share on other sites
andylemay

Hi Danny,

 

Ok I found it at the bottom,  why not put this under the pagelines menu option at the top!.  Cache was on will test now.

 

Thanks

 

Andy

Share this post


Link to post
Share on other sites
Danny

Did disabling Section cache resolve your issue ?

The option is off by default, yet for some unknown reason a large majority of DMS users enable this option instinctively without actually understanding that it is not for every server environment or what it does. I guess users really love the word cache ;)

 

Either, the decision has been made to remove the option as too many users appear to have strict hosting environments or hosting environments where this option appears to cause problems like the one you encountered.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
andylemay

Hi Danny,

 

Yes. I must have done this too when I first enabled the plug-in.  It does seem to have sorted out the link problem.  W3-cache however was causing serious formatting issues and needed to be emptied every time I made any change in DMS.  So I've disabled this too.  

 

Thanks

 

Andy

Share this post


Link to post
Share on other sites

  • Similar Content

    • mundocaco
      By mundocaco+
      Hello, inexplicably few signs have appeared at the beginning of each excerpts, removing the option these signs disappear, but appear when I activate it again. You know why happen this?.
       
      Yo can see online here: http://www.latitudestudio.eu/press-news/ 
       
       
    • dherries
      By dherries
      I am trying to add a widgetizer to my page/post and the system does not let it drag. The system creates  large Widgetizer logo and nothing will happen. What am I doing wrong?  I am using DSM 1.1.9.  Website is www.moveincache.com
    • mundocaco
      By mundocaco+
      Hello everyone. :)   Is possible set a selected Section Area to height of window browser with custom CSS, just like DMS2 presets? Someone knows some best practice?   I know how to set to fixed footer, but i think this case of study is different.   Thanks!
    • webmktco
      By webmktco
      Website URL: http://www.schrumpfdds.com/
      Framework Version: DMS 1.1.9
      WordPress Version: 4.1.1
       
      I noticed that the Font Awesome version in my theme is 3.2.1.
       
      Can you tell me how I can update the FA version? Or is that not possible?
    • pazyluz
      By pazyluz+
      I have pages that display on phones and pages for desktops/laptops.  The ipad displays the mobile/phone pages but would look far better if they displayed the desktop version.  How/Can I display the desktop version on ipad?  If I cannot do that, can you advise me as to the best course of action?  Thank you.
       
      http://peggygreen.net
×