Jump to content

Archived

This topic is now archived and is closed to further replies.

faustus501

Search results changing primary navigation

Recommended Posts

faustus501    0
faustus501

When I perform a search on my site I get titles of posts inserted into the primary navigation (in navi section)

 

What could be causing this? and how can I fix it.

 

Attached grabs should demonstrate problem, as you can see it is a real problem

 

 

Share this post


Link to post
Share on other sites
GetMeWebDesign+    115
GetMeWebDesign

Most likely to be a plugin. Have you disabled your plugins and been able to replicate the result? Post Types Order is one such plugin that causes this


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
faustus501    0
faustus501

Many thanks! Yep it was Post Types Order.

 

Do you know of any plugin similar to this that won't cause this problem?

 

Thanks Again! - was driving me nuts

Share this post


Link to post
Share on other sites
GetMeWebDesign+    115
GetMeWebDesign

This appears to work http://wordpress.org/plugins/anything-order/, with similar drag and drop functionality. Only briefly checked. Once you have dragged and dropped (you do this directly in 'all posts', you need to click "Apply" for the changed order to take effect.

 

If that doesnt work reply to this post and will look elsewhere


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
faustus501    0
faustus501

Thats Great!

 

While I haven't thoroughly tested it yet at first glance it works without breaking search menu and is actually better than Post Types Order in that it allows you to sort through posts on the All Posts list as a whole or when filtered rather than go into a separate reorder screen that shows everything without categories, date etc. only post names.

 

Thanks so much, really appreciate it!

 

Cheers

Share this post


Link to post
Share on other sites
GetMeWebDesign+    115
GetMeWebDesign

No problem


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
faustus501    0
faustus501

Hey, Just so you know Post Types Order plugin does work, the conflict is with the DMS Professional Tools plugin.

 

None of the other ordering plugins work like Post Types Order in that they only effect backend lists which isn't really what I am after.

 

Cheers

Share this post


Link to post
Share on other sites
GetMeWebDesign+    115
GetMeWebDesign

faustus501 Anything order works fine for me, being able to order appearance on front end. As you said before after trying ( i then started using it) I think it is superior to PTO


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
faustus501    0
faustus501

Thanks GetMeWebDesign, glad it is working well for you. Unfortunately in my instance it was going great in back-end but not corresponding to front. The site I've been working on is a bit of of a monster in that it has around 500 posts split across 20 categories and with an insane deadline so it's all about getting it to work "no matter what" for now. Hopefully I'll get a chance to properly finesse all the structural issues within a decent time period. Will end up being cloned 21 times for various industries so this structural stuff has to be right on. As it happens I bought the prem version of PTO and there is no conflict whatsoever, still not as good as Anything Order in terms of interface and usability.

 

Cheers,

 

J.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

What Navigation section are you using, as I am not able to recreate this bug. Are you sure this is related to the Post Order plugin and not something else ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • John Olsson
      By John Olsson+
      Hello, i'm working on a webshop, and got this code to really boost the search within WP. But when adding this code to functions.php the front end media library search flipped totally, and not working at all, any ideas what's the problem?
      function atom_search_where($where){ global $wpdb; if (is_search()) $where .= "OR (t.name LIKE '%".get_search_query()."%' AND {$wpdb->posts}.post_status = 'publish')"; return $where; } function atom_search_join($join){ global $wpdb; if (is_search()) $join .= "LEFT JOIN {$wpdb->term_relationships} tr ON {$wpdb->posts}.ID = tr.object_id INNER JOIN {$wpdb->term_taxonomy} tt ON tt.term_taxonomy_id=tr.term_taxonomy_id INNER JOIN {$wpdb->terms} t ON t.term_id = tt.term_id"; return $join; } function atom_search_groupby($groupby){ global $wpdb; // we need to group on post ID $groupby_id = "{$wpdb->posts}.ID"; if(!is_search() || strpos($groupby, $groupby_id) !== false) return $groupby; // groupby was empty, use ours if(!strlen(trim($groupby))) return $groupby_id; // wasn't empty, append ours return $groupby.", ".$groupby_id; } add_filter('posts_where','atom_search_where'); add_filter('posts_join', 'atom_search_join'); add_filter('posts_groupby', 'atom_search_groupby');  
    • Queue-it
      By Queue-it+
      HI,
      Search function doesn't seem to work. 
      When ever searching for something it redirect to the home page and add the search string to the url.
      For example searching for "cases" it would display https://queue-it.com/?s=cases
      Do you know how to solve that? 
    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • MissT
      By MissT+
      Would be great to have the ability to include a search option within menus and within Splashup - is this possible?
    • balfred1345
      By balfred1345
      null When I tested Search using the search field in Navi, it throws the error as shown in pastebin: http://pastebin.com/DJ079bmy
      Is there a fix for this? If there is no fix, can you please tell me how to disable search in Navi?
      Thanks,
      Bruce
×