Jump to content

Archived

This topic is now archived and is closed to further replies.

dominiclane

DMS2 CSS for pagelines divs?

Recommended Posts

dominiclane

Hi, have started using DMS2 this last week .. very cool

 

I'm using the pl-nextbox plugin from the pagelines site to add in php to activate a menu plugin I am using, 'Main Mega Menu' for wordrpess

 

I have made the menu sticky and put it in the header section with a dms drag and drop block/element

 

All works ok except now there is a big whitespace gap at the top of each page, approx 130px

 

When I add the pl-nextbox drag and dorp element in, it creates a blank space at the top of the page even though the menu displays above it

 

So I used css to position the #page-main div upwards by 140px and added some blank content rows using the 'Visual Composer' for wordpress plugin so the Title of pages was not quite so close to the menu/header in pages

 

But of course now I have noticed problems with changing the width of the page template/elements when you enable the layout view in dms and some buttons at the top of the page do not respond properly because they are overlapped by another div

 

For example ..

 

http://www.knoxfire.co.uk/latest/

 

On this page you can only hover the mouse over the very bottom of the buttons to click / select them because the div overlapping it. I know I could fix this by adding txt above the area like I have on this site with the same issue if it's useful

 

http://www.benrooney.co.uk/latest/

 

Also if you read individual posts it chops the title etc off the top

 

 

Any advice greatly appreciated on this ..

 

Can I just set an overlap in the css so that the page div sits on top of the pl-nextbox element or will that mess up the sticky function of the menu and if so what?

 

Or do I need to be clever with css to minimise the containing bit for the pl-nextbox causing the issue

 

Kind thanks

 

Dominic

Share this post


Link to post
Share on other sites
GetMeWebDesign

You have errors on Knoxfire

 

Failed to load resource: the server responded with a status of 404 (Not Found) http://www.knoxfire.co.uk/wp-content/uploads/pagelines/compiled-css-core-1401386362.css
Failed to load resource: the server responded with a status of 404 (Not Found) http://www.knoxfire.co.uk/wp-content/uploads/pagelines/compiled-css-sections-1401386362.css
 

Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
×