Jump to content

Archived

This topic is now archived and is closed to further replies.

ketri

Changes in one page template affect other templates

Recommended Posts

ketri

Hello!

I have a website http://malmgardsjundea.fi/
I've now updated it to DMS2 (locally).

I've made  the site by creating a full width section area that acts as a masonry.js container. And then I've created masonry-box section where I can have images, text etc. and it works masonry style
Now in DMS two if I have a page template (i.e. front page) and I edit another page (i.e. History-page), it takes some of the changes to the front page -template! I switch them back and forth and really don't know what to do. It's hard to put the broken version online for you to see because my client would now appreciate it of course.

How can the changes made to a section area affect some other section areas in other pages/other templates?

I've tried creating backups from the templates but they also break.

Share this post


Link to post
Share on other sites
ketri

Update: https://www.dropbox.com/s/rvtq2xw5y3t7b4y/Screenshot%202014-05-28%2018.51.38.png this code "   ukwltx  template scope" is the same in the sections. 
I'll try creating new sections and deleting the content from these ones...
Just to get clarification for the future:

Why do they have the same code?
What is this code?
How can it be the same on different sections on different pages? 

Thank you very much!

Share this post


Link to post
Share on other sites
greenfly

Is this a local install? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
ketri

Is this a local install? 

Yes. Does local development possibly affect this?
I seemed to have made it work by deleting all the  sections that have the same code (whatever it is) but it's still a bit unstable. 

 

Share this post


Link to post
Share on other sites
Danny

Where are you adding your custom template ?

 

If you're adding it to the Header, then this will considered a global section as it is in the Header which like the footer is a Global template area.

 

However, if you're adding your section to the Template area, then you will need to unlock/unlink the template so that you can make changes to that section without it effecting other templates.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
ketri

Ok! Now I see.

So if I take a template "Front page". Then go to another page and load the template "Front Page", and then save it as a new template it gets mixed up.
But I if I go to another page, load the template "Front Page", then unlock, then save it as a new template "Front Page 2", then it works.

It might be worthwhile to make sure that even if users go with the method 1 without unlocking (just saving a template with a new name) the section IDs (or whatever) would be updated then also!

Thank you

Share this post


Link to post
Share on other sites
Danny

No problem and thanks for the feedback.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×