Jump to content

Archived

This topic is now archived and is closed to further replies.

ketri

When user clicks the mobile menu open on an iPhone, the search form is automatically activated and keyboards pops up

Recommended Posts

ketri

When user clicks the mobile menu open on an iPhone, the search form is automatically activated and the browsers keyboards pops up making it very confusinh.

This is likely to happen on other mobile devices also. This of course is not a good experience since we have no idea if users is planning on using the search or not. 

Also, is there a way to disbale the search entirely from mobile navigation without a css-hack (display:none; etc)?

Thank you!

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Yeah this has already been brought to our attention and I have already added it to our tracker. Unfortunately, the mobile menu code isn't used inside a section, it is it's own separate file in the editor folder. The only way to remove the search functionality is to edit the file itself as far as I am aware and this isn't something we recommend nor support.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
ketri

Hi,

 

Yeah this has already been brought to our attention and I have already added it to our tracker. Unfortunately, the mobile menu code isn't used inside a section, it is it's own separate file in the editor folder. The only way to remove the search functionality is to edit the file itself as far as I am aware and this isn't something we recommend nor support.

Ok. Thanks for quick reply.
I think it would be really important to add a checkbox "disable mobile menu search" somewhere in DMS settings.

 

Share this post


Link to post
Share on other sites
Danny

Yeah, I already mentioned that in the issue I added to the tracker.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
    • MissT
      By MissT+
      I've set the Mobile / Default Menu setting in the Layout & Nav section of the Platform 5 Pagelines settings to Mobile menu - that is a menu I have created called Mobile that is different to my Main menu.
      When I go to a tablet (ipad) or mobile (android device) and click the hamburger menu icon the menu that appears is still the Main menu and not the one I created called Mobile - am I missing something? Do I need to set the mobile menu somewhere else too?
      WP Version - 4.8.1
      Platform 5 Version - 5.1.7
      MegaNav Section Version - 5.0.17
      Many thanks in advance.
       
    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • jdubdigi
      By jdubdigi+
      Onepage plugin is not working on an iphone. The page does not scroll properly and sections are partially missing, any ideas what the problem could be?
×