Jump to content

Archived

This topic is now archived and is closed to further replies.

Buishi

How to remove 'flicker' from initial "set to height of window" section?

Recommended Posts

Buishi
Hi Pagelines community,
 

I set up my first section to be 'set to height of window', but it loads at 0 height before it adjusts, causing a minor flicker, and activating some animations further down the page prematurely.

Can you give me an idea on how to fix this?

 

Framework Version: 2.1
WordPress Version: 3.9
 
Thanks!
 
-Julian

Share this post


Link to post
Share on other sites
Danny

Hi Julian,

 

As far as I can tell you have two issues, which are causing your problem.

 

1. Your image hasn't bene optimized as far as I can tell, you should try reducing your image file size to something less than 100kb, at the moment it is nearly 200kb. You can try the following:

 

https://kraken.io/

http://www.jpegmini.com/

 

2. You appear to be using Shared Hosting - https://cloudup.com/ce7cYYLD_QJ

 

As you can see when I perform a reverse ip check, you have 200+ other domains using the same server resources as your site. Shared hosting isn't known for it's performance as web host providers populate their shared server(s) with as many domains as they possibly can. Therefore, if I was you, I would try looking for a new host such as FlyWheel, who provide excellent performance.

 

http://getflywheel.com/


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Buishi

While valid points, even on the fastest internet connection, there would be a slight flicker as the javascript runs and the size of the section adjusts. I'll take down the image size a bit, hopefully that will help.

 

If you're interested in fixing this, here's the problem:

 

.pl-window-height .pl-area-wrap {
position: absolute;
width: 100%;
top: 50%;
}
The problem is that this makes the height zero, until the javascript kicks in and resizes it. Really, the position should be set to absolute in the javascript when the page loads, that way the height will be automatic until the javascript kicks in and resizes it.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×