Jump to content

Archived

This topic is now archived and is closed to further replies.

motionltd

Templates not working, come up as 'no name'

Recommended Posts

motionltd

I can't allocate a new template to a page, when I create a new one and name it correctly it just comes up as 'no name'. 

 

Also, I created 2 pages from 1 template, editied one page and those changes appeared on both changes and I hadn't selected update with this template. 

 

Very frustrating losing hours on these issues! Please help.


Ben

motionltd.com

Share this post


Link to post
Share on other sites
motionltd

My templates seem to be linked. I have 2 different pages each attached to 2 different templates, I make a change on one page and it appears on both pages which are attached to 2 different templates. This is driving me crazy!!!! What happened to global and local templates ffrom previous versions?


Ben

motionltd.com

Share this post


Link to post
Share on other sites
batman

Hi motionltd

Please, you can see if you are dragging and dropping a section in the "Header" or "Footer" area, this appears in all pages.


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
motionltd

Hi motionltd

Please, you can see if you are dragging and dropping a section in the "Header" or "Footer" area, this appears in all pages.

Its happening to content outside of the header and footer, content in the page content area gets put on all pages over multiple templates. Very strange.


Ben

motionltd.com

Share this post


Link to post
Share on other sites
greenfly

if you have the same template on multiple pages and you make a change to that template on another page it will affect all pages that use that template. Does this explain the situation?

 

If so, to prevent this, you can use the templates on multiple pages but if you want them to be unique on certain pages and not on others then unlock the template on the page you want the unique template. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
motionltd

if you have the same template on multiple pages and you make a change to that template on another page it will affect all pages that use that template. Does this explain the situation?

 

If so, to prevent this, you can use the templates on multiple pages but if you want them to be unique on certain pages and not on others then unlock the template on the page you want the unique template. 

Yes, I realise thats how the templates work. But this is what happens for me:

 

I created a template.

I added that to a page.

I created a 2nd template based on that page.

Added that 2nd template to a new page.

So now I have 2 identical pages and 2 identical templates. Page 1 has template 1 assigned, Page 2 has template 2 assigned. That fact that their content is exactly the same should not matter right? they are separate entities.

However, I make a change on page 1, (which is assigned to template 1) and that change also appears on page 2 (which is assigned to template 2).

 

I want 2 identical pages but with minor differences on each. They are very large pages so rebuilding then is not an option. I was trying to create 2 copies of 1 page and then edit each one independently.

 

By the way, I tried creating a new page and from template 1, then un attaching it to then make edits, but when I unattached it all the content disappeared. The frame work was still there, but no content. 

 

Either I'm missing something really obvious or there is a large bug in my system as I've no end of problems with this large page.

 

http://curiousartsfestival.com/programme/


Ben

motionltd.com

Share this post


Link to post
Share on other sites
greenfly

Could you take a screenshot of both pages showing both templates and the tops of the templates that show which page they are locked to for us please in place on the pages. 

 

Easiest way is to use a free tool like Jing http://www.techsmith.com/jing.html


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×