Jump to content

Archived

This topic is now archived and is closed to further replies.

pcorey

Missing DMS toolbar and WP toolbar on Homepage

Recommended Posts

pcorey
Website URL: http://coreyforhouse.com/

Framework Version: 2.0.7

WordPress Version: 3.9.1

Plugins in Use: Contact Form 7, DMS Professional Tools, Lazy Load, MailChimp for WordPress Lite, Official StatCounter Plugin, PageLines Updater, Really Simple CAPTCHA, W3 Total Cache, WordPress SEO

Server/Host: Host Gator

Details: The DMS toolbar and WP toolbar shows up on most pages, but not homepage when I’m logged.

Share this post


Link to post
Share on other sites
greenfly

Could you enable the debug in the Visual Editor > site Settings > Advanced and let us know when you have done this. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
pcorey

The interior pages are messed up now. They seem to have reverted to somewhere between what I had and DMS when I decided to switch from my child theme to DMS. The home page still retains the same formatting.

Share this post


Link to post
Share on other sites
pcorey

I just did the debug. I backed up site and DB on May 7 before a big upgrade. Would you suggest trying to reinstall?

Share this post


Link to post
Share on other sites
greenfly

Ok - first things first. 

 

The forum rules state the following 

 

PLEASE disable any cache plugins and purge any cached pages, we CANNOT help you if all we can see is a cached page.


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
pcorey

Ok, did it I believe.

Share this post


Link to post
Share on other sites
pcorey

The toolbars are there now. don you think it was the caching plugin?

Share this post


Link to post
Share on other sites
greenfly

You appear to be still working on your site. You do not need caching at all until your site is complete. 

 

Do not use caching if making changes - you are making changes to cached versions of your pages, 

 

Also please make sure you read the actual message on the forum before clicking that you accept the forum rules for posting ;) 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
pcorey
Will do. So, shut off any caching plugins when making changes and switch them back on after making updates?

Share this post


Link to post
Share on other sites
greenfly

NO - remove them totally - make sure read the documentation for the plugin and clear the cache properly. 

 

Ask yourself - do you even need the caching plugin? what are you using it for? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
pcorey

My pages were loading slowly so I read this article in Pagelines "DOCS"

"Optimizing Load Time"

http://docs.pagelines.com/advanced/optimize-load-time

Suggestion two was using "W3 Total Cache"

 

and 

 

Suggestion three was to use a CDN, W3 Total Cache works with MaxCDN 

Am I reading something old? 

Share this post


Link to post
Share on other sites
GetMeWebDesign

You might consider compressing some of you images. You can always test your sites speed on http://tools.pingdom.com/fpt/ or http://developers.google.com/speed/pagespeed/insights/. I tested compressing one of yours by 75% reduction and it looked fine going from nearly 500KB down to 140KB. Danny on here reckons trying to keep them to around 100KB.

 

Even having a plugin, like WPSmushit will help http://wordpress.org/plugins/wp-smushit/


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
greenfly

+1 for optimizing images and smush it to further reduce the size of the images 

 

Also check this out http://tools.pingdom.com/fpt/#!/bdZhWH/http://coreyforhouse.com/

 

A breakdown of items loading on your pages. 3,61mb is moderatley large and you can see the breakdown of each item. 

 

Have to agree with Danny & GetMeWebDesign - 100kb is a good size. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
greenfly

Here is a good post by Simon, one of our Dev's on the caching question 'To cache or not to cache...'

 

http://forum.pagelines.com/topic/35094-wp-super-cache-or-not-to-wp-super-cache/


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
pcorey

Thank you both for all of your help. I squished my images right down. Hope it helps.

Share this post


Link to post
Share on other sites
Danny

Your page load speed depends on a number of factors such as:

 

Your hosting environment, shared hosting for example isn't known for its performance, as hosts add as many domains as they possibly can.

Cache plugins are useful, but only really required if you have huge traffic. If your site has only 100 visits per month then there really isn't a need.

In my opinion, you should invest in a VPS, from either Linode or Digital Ocean, a VPS without any caching or performance tweaks will out perform standard hosting.

You should also look into a CDN such as MaxCDN, this will improve your performance.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×