Jump to content

Archived

This topic is now archived and is closed to further replies.

neilp

Fatal Error on Site

Recommended Posts

neilp

Hi, 

 

I am getting the following fatal error on www.greyfinn.co.uk:

 

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 30720 bytes) in /home/k03grey/public_html/wp-content/themes/dms/dms/dms/sections/postsinfo/section.php on line 39

 

I have checked line 39 if sections/postinfo/section.php it is: 'label' => __( 'Subtext', 'pagelines' ) )

 
I can view the site in the editor OK - the issue is on the live site or if I try to navigate to dashboard. 
 
I haven't added any new plugs ins and everything seemed fine prior to upgrade to DMS 2
 
Am I missing something/doing something stupid?
 
Thanks

Share this post


Link to post
Share on other sites
Danny

HI,

That error is related to your server, as it has ran out of memory. However, as far as I can tell that equates 128MB if my calculation is correct. Therefore, your issue is likely related plugins you have installed.

 

If possible, can you enable DMS debug mode please - DMS Toolbar > Settings > Advanced.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
neilp

OK I have enabled debug mode.

Share this post


Link to post
Share on other sites
Danny

You have two errors on your PageLines debug info, these seem to be related to the /wp-content/advanced-cache.php file, which isn't a core WordPress file and therefore, is most likely related to a plugin. However, there doesn't appear to be any cache related plugin active. Have you at any time installed and activated a cache plugin ?

 

Also you have a backup plugin active, please disable and see if this resolves the issue. In regards to your first issue which was related to memory, has this error now been resolved by disabling plugins ? How many did you have active ?

 

If the issue persists, then its likely you do not have the PHP memory which is printed on your debug info. Some hosts, say they give you X amount of memory when in fact they install some PHP scripts which allow them to set it to something completely different (usually much lower).


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
neilp

Hi, 

 

I have disabled the back up plugin as you requested.

 

This doesnt seem to have helped.

 

I did have a Cache plug in (W3 Total Cache) originally installed.

 

Thanks,

 

Neil 

Share this post


Link to post
Share on other sites
Danny

OK, well something has happened when you removed W3 Total Cache, as it is causing an error. Also, has your memory problem persisted even with with all these plugins now disabled ?

 

If so, then you will need to contact your web host provider and ask them why your server is using so much memory when DMS and WordPress do not use that much or ask them, do you really have 128MB of memory.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
neilp

Hi,

 

I contacted my hosting provider and the answer is 'yes' I do have 128MB of memory.

 

I am no longer getting a memory issue/error.

 

I have removed any trace of W3 Total Cache from wp-config.php

 

Any other ideas?

 

greyfinn.co.uk/wp-admin 

 

Thanks

Share this post


Link to post
Share on other sites
Simon

you have a white page now, enable WP_DEBUG in the config file to turn on wordpress debug mode.

Share this post


Link to post
Share on other sites
neilp

 Hi,

 

This is enabled:

 

 * For developers: WordPress debugging mode.
 *
 * Change this to true to enable the display of notices during development.
 * It is strongly recommended that plugin and theme developers use WP_DEBUG
 * in their development environments.
 */
define('WP_DEBUG', true);
 
/* That's all, stop editing! Happy blogging. */

Share this post


Link to post
Share on other sites
Simon

OK well your site is not working at all. Maybe you have a typo somewhere.

 

PM me wp login and ftp login and i'll fix it if you like.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×