Jump to content

Archived

This topic is now archived and is closed to further replies.

Fish-Owl-360

Lost content from my Pagelines DMS 2 site twice

Recommended Posts

Fish-Owl-360

The first time I lost content from my DMS2 site was after doing an update to DMS 2.0.7, and WOrdpress 3.9.1.  I'm new to both, so I'm not sure which update caused the problem, but please let me know how to preserve my site before doing future updates.  There were no warnings before clicking the update buttons for either (that I remember).

 

The 2nd, and more puzzling content loss issue happened this morning when I reported a non-related issue in the forum.  I was instructed to do a few things like turn on debug mode, and turn off all plugins etc.  In addition to that I cleared my Chrome browser cache, and then logged back into my site, and boom!  My site had reverted back to the default blog template.  I did see my saved FISH OWL 360 template still there, so I loaded it/activated it and an old version of my site came back.  Is it a good idea to save into / update the template to preserve site changes?

 

I am wondering if I'm having a MySQL database issue? 

Am I missing some PHP extensions (PHP 5.5)?

 

One thing I did was when I started learning Pagelines & Wordpress, is I created a site and did a lot of experimentation, then cloned it so I could have my site in a different directory.  Is cloning a Pagelines DMS2 site ok?  I cloned the old site to a new directory with a separate database, so I assume that is ok.

 

Here is the DMS2 Debug info:

DMS Debug Info

WordPress Version
3.9.1

WordPress Debug
Disabled

Multisite Enabled
No

Current Role
Administrator

Framework Path
/home/fishdust/public_html/fish-owl-360.com/google-business-view/wp-content/themes/dms/dms

Framework URI
http://www.fish-owl-360.com/google-business-view/wp-content/themes/dms/dms

Framework Version
2.0.7

PHP Version
5.5

WP_DEBUG
No

WP memory limit
96 MB

WP MAX memory limit
256 MB

PHP memory limit
256 B

Mysql version
5.5.32

WP Max Upload Size
2 MB

PHP POST Max Size
8 MB

PHP Max Execution Time
30s

PHP type
Cgi-fcgi

WebServer software
Apache mod_fcgid/2.3.10-dev

PHP User
Posix functions are disabled on this host. Not necessarily a problem, but if the user needs FTP/SFTP to install plugins/themes then creating CSS files might be an issue.

OS
Linux

 

 

Share this post


Link to post
Share on other sites
Fish-Owl-360

It's a shared server.  GoDaddy is my host, and I use cPanel.  I used the automated Wordpress install.

 

I remember seeing those warnings, but they don't say "Make a Backup because you will lose data if you don't".  Those warnings sound more precautionary than anything.  See the difference?

Share this post


Link to post
Share on other sites
Simon

The are a warning, not a threat or a promise ;) Needless to say you didnt make a backup. So if its cpanel I assume you have full database backups?

Share this post


Link to post
Share on other sites
Fish-Owl-360

You know I did take a look at the backup settings, and they were turned off.  I don't know if thats the default setting, or if I chose to leave them off after the Wordpress installation.

 

Hey, I'm new!  ;)  I didn't lose anything that can't be re-done, but I just need to know if what happened is abnormal, or if it was something I did wrong.  It sounds like the first instance was normal, but the second time I lost data was after all the updates were done, and all I did was clear my browser cache, and disable all plugins.  I did delete an old Wordpress installation which was the original I used to make a clone, but the Cloned copy had a new database.  Is it possible the clone could have been still linked to the old database?

 

When I was publishing my site I was checking to see if the changes were live in Internet Explorer, so I know they were saved at one point.  

 

If Support can't find anything wrong in the actual Site, I wonder if someone would be willing to join me in a Skype, or Google+ screen sharing session so I could show them my PHP settings, Wordpress Install, and other hosting settings?

Share this post


Link to post
Share on other sites
Simon

its possible i suppose that you had the database settings set to the wrong database.

 

If you have access to cpanel i would strongly suggest turning on backups ;)

 

Before updating any live site it should be standard practice to do a database dump, it only takes seconds. When things do go wrong you will be glad you did it!

Share this post


Link to post
Share on other sites
Fish-Owl-360

I still have a lot to learn.  Up until a week or two ago I was just a traditional hand coding HTML/CSS guy.  When I saw Pagelines I finally made the decision to get out of the 1990's.  heh!

 

I need to learn a lot, so my brain is hurting a little.  I can research and learn on my own, but any suggestions on where I should start?  Know of any great learning videos that cover all the standard Wordpress / MySQL practices?  To be honest I hate reading Docs, but I will if I have too.  I just can't stare at the screen for more than a few hours at a time.

Share this post


Link to post
Share on other sites
Danny

There are tons of awesome resources you can sign up to and start learning. I have listed a few below any with a * are highly recommended.

 

TreeHouse - http://teamtreehouse.com/ *

Codecademy - http://www.codecademy.com/

Code School - https://www.codeschool.com/ *

Thinkful - http://www.thinkful.com/

Learnable - https://learnable.com/

Lynda - http://www.lynda.com/


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Fish-Owl-360

Thanks!  That TreeHouse link was exactly what I was looking for.  It has a lot of Wordpress specific courses.

 

I'll resolve this thread since it's likely it was my inexperience that caused the data loss.

Share this post


Link to post
Share on other sites
Danny

Yeah TreeHouse is pretty awesome. Also, if you encounter this issue again, please reply to this topic with any information that may be useful.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×