Jump to content

Archived

This topic is now archived and is closed to further replies.

richardc

Top Menu Problem

Recommended Posts

richardc    0
richardc

Hi,

 

I'm just starting on my 1st MDS2 site and have run into the problem with the top nav. All I have is a small square graphic of three blue lines rather than the navigation itself.

 

Here is a screen short: http://screencast.com/t/M8wV1f2HuU

 

I have the latest version of DMS2 installed.

 

I'd be grateful if you would tell me how to resolve this.

 

Thanks in advance.

 

Richard

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Richard,

 

Go to your Navi sections settings panel and select your WordPress menu - https://cloudup.com/cVaHNiTGF3V


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
richardc    0
richardc

OK, thanks for that. I thought I had that set.

 

Now the menu is blue and vertical and I want it black and horizontal. How do I do that?

 

R

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Have you added any Custom CSS to your site? If so could you provide the code here http://forum.pagelines.com/pst/

 

Please provide the link to the paste in the reply


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
James B    436
James B

Thats the mobile menu icon which is showing, can you show us a screenshot of how you have the nav set up in the editor. From the source code it looks like the width of the actual nav links are in a very narrow column where the logo is in a full width column.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Richard,

 

From the looks of it, you must have some plugin installed which is causing a conflict with DMS styling. As your have a scroll bar in the left hand panel of your DMS visual editor and your NavBar section shouldn't be vertical.

 

Therefore, please disable all active plugins and see if this resolves your issue. If it doesn't, please provide a link to the site in question and enable DMS Debug mode ~ DMS Toolbar > Settings > Advanced.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
richardc    0
richardc

I deactivated all the plugins which cured the problem. I then reactivated them all a few at a time so they are now all active again but the problem has still been resolved.

 

So the issue has been resolved but I'm not sure how :o/

 

Thanks for your help.

 

R

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

I must say that is quite odd. If the issue returns, please let us know.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
    • Dave
      By Dave+
      1) Toggle menu on mobile devices does not work properly, combination Chrome 56.0.2924.87 with Android 6.0.1

      2) Mobile / Default Menu > Set the primary/default navigation for your site. This will be used in the pop out mobile menu and as the default in navigation sections. Does not work.
    • David
      By David+
      We are building a long-page scrolling site with Pagelines 5. Our menu is made with # links that go to a container's unique ID, e.g. container_ux7al6g
      This works, but it doesn't look great in the menu. Is it possible to assign a 'nice' # link, e.g. /#solutions ? 
      We used to do this in the DMS2 platform through a workaround, but that doesn't seem to be possible now. 
      Any suggestions? 
×