Jump to content

Archived

This topic is now archived and is closed to further replies.

sheilahoff

Mobile Menu duplicated

Recommended Posts

sheilahoff

Danny said this in response to someone else...

In DMS 2.x, the mobile menu should be pre-populated from the navigation menu you chose when adding the menu to the section using the Sections options.

 

So if my primary menu has 7 items as shown on this dev site http://sheila.wpstagecoach.com/

why is it when it goes to mobile mode I get those 7 items TWICE?!

 

I don't want it to repeat and can't see why it is. Is there any way to assign it a unique menu only for mobile? Is the secondary menu in Site Settings what is used for mobile?

 

Thanks,

Sheila


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
GetMeWebDesign

Sheila - that is because I was working on the site and installing another navbar to try and stop the li class rather than li id. I removed that extra nav bar, but can you try flushing your cache and see if that sorts the problem


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
nfp1900

Hi

 

I was having this same problem with one site where I was using the navi section but there was a secondary unwanted navigation showing for mobile view (the pop-out menu). 

 

Under site settings -> Layout and nav I created a specific mobile menu and selected that for primary navigation. I then created a menu called 'empty' with no links and used that for secondary navigation menu - this works fine.

 

I couldn't see how else to suppress this additional menu showing up in mobile view - maybe there's a better way?

Share this post


Link to post
Share on other sites
Danny

There is no issue, not one I can recreate anyway.

Basically, if you do not create any menu and assign it your navigation then WordPress will populate your navigation menu with pages you have created. When you assign a menu to your navigation section, then that menu appears, replacing the default pages menu that was created by WordPress.

 

The same thing happens to your mobile menu, which is why I said what I did "In DMS 2.x, the mobile menu should be pre-populated from the navigation menu you chose when adding the menu to the section using the Sections options.". In fact, I believe this also occurred in DMS 1.x. Either way, if you're seeing duplicate menus in your mobile menu, then you have used the Mobile menu options ~ DMS Toolbar > Settings > Layout & Nav and have selected the same menu twice in the Primary and Secondary options.

 

The mobile menu can display two menus at once, this has been like this since the launch of DMS 1.x. You have two options Primary which used generally used to display important menu items of your site such as Blog/News, Portfolio, About us, Contact us etc... Whereas, the Secondary option is used for less important menu items such as things from drop down menus.

 

You can also just use the Primary option to display the menu that you used throughout your site.

 

So to resolve the question, if you're seeing two menus the same, then you have used both Primary/Secondary to display the same menu.
 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
GetMeWebDesign

nfp1900 I have seen this before in early days of DMS2 but not in recent updates:

 

menu with no secondary menu (child pages) http://screencast.com/t/qlckaKeeh2

 

menu with secondary (child pages) http://screencast.com/t/ccoSwnh8RZ

 

Not quite sure about what you mean selecting for a secondary menu? I have just one menu set for mobile nav. The only menu option I have checked, is hide search


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
GetMeWebDesign

What Danny is saying, you need to use default as your primary and secondary menus and use wp admin menus to choose for mobile view, if you only want one menu, as in my screenshots above.

 

However, once you change the primary and secondary to anything else (in DMS live editor > site settings > layout and nav), then both of those will be displayed in your mobile menu

 

Great feature, I had never noticed before LOL

 

Post note. You may have seen images on mine. If you choose that menu for primary and secondary, then the secondary will not display the badge of the mighty QPR... or whatever image you choose ;)


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
sheilahoff

Morris it was definitely NOT because you had 2 nav bars there. I knew that. This was way after that. AND it was also before you ever got in there. I've been seeing two all along. At the moment I'm not willing to make any changes as I want to be sure I don't create any new issues. But I did go into Dashboard and remove any unused menus. I also unchecked all options under MenuSettings and Theme Location. I'll report back once I try these helpful suggestions. Thanks all.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×