Jump to content

Archived

This topic is now archived and is closed to further replies.

john7626

Header Section/Image Issues

Recommended Posts

john7626+    2
john7626

When I am previewing in DMS 2.0.6, and when the site is published live with me not logged in, my Header is not visible.  In preview mode, however, the image shows up partially (looks like the central part of the image vertically).  My website, a staging site, is jfspencer.staging.wpengine.com.  I have disabled all plugins except DMS and Pagelines (5 total - DMS Developer and Professional Tools, Pagelines Googlefonts, Sections and Updater.) I have cleared the cache and restarted the browser.  I am providing login information via a separate email with this topic title in the subject area.  Screenshots are attached.

 

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hello @john7626 

 

If you add some content to the canvas area with the blue background in your header this will show up. Currently this is only visible in preview as there is no content within the Canvas area. 

 

Add any content to the Canvas area - for example (and if you do not want anything to show, you can add a text box with the text   so that the default text does not show. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
john7626+    2
john7626

Thanks, Martin.  That solution made the image visible, but not at the full size of the image, which I need.  I understand that this may require a different kind of tweaking, but how do I make the entire image show up in the header?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

If you open the Header Area options via the Tool panel, you find a number of options available, you will see a option called Area Minimum Height (px), enter the value of your images height there, only enter the value for example, if you have an image that is 400pixels in height, enter only the numeric value such as 400, do not include px.

 

https://cloudup.com/cQlqWHSNZLY

 

https://cloudup.com/cZ6Wexo4xot

 

This should increase your header area height. However, because DMS is responsive and for areas such as background image, template area images etc... we use like most responsive frameworks, the CSS property background-size and value cover. What cover does is scales your background image to be as large as possible so that the background area is completely covered by the background image. However, some parts of the background image may not be in view within the background positioning area.

 

So try my suggestion above and see if this resolves your issue.

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
john7626+    2
john7626

Thanks, Danny.  That seemed to fix the problem.  I appreciate the information.

Share this post


Link to post
Share on other sites
James B    436
James B

Glad you managed to resolve, thank you for updating the thread.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • flourishdesignstudio
      By flourishdesignstudio
      Hello,
      I have an older site that was built using PageLines several years ago (prior to the release of DMS). I wanted to leverage some of the power of your new PL5 plugin but the theme prevents be from adding any generated custom sidebars to the theme (through the drag and drop interface) and does not allow me to add any PL5 sections/containers/etc to the header or footer. Is there any way to easily override that or am I stuck only using PL5 in the content areas of the site?
      Thanks so much for the help!
    • JP
      By JP+
      Hello,
      How can you set the translations with platform5, the parts that are not in pages or posts? Texts and images…
    • romanondrasek
      By romanondrasek
      hi all, I have some trouble using PL5 on my site. 
      I used plugins for event calendar (event on) and plugin (timetable responsive scheduler for WP) for schedule (classes) in the gym.
      The problem is, that post from this 2 plugins are shown without menu in header and footer. (I setup header and footer) in the page editor for all type of page. 
      When I create a lesson, it creates posts with slug (I have a slug "lekce" & event for events).
      I try to edit the post with PL editor, but editor is not opening on the post.

      Do you have some idea where should be some problem? Thanx so much.
      here are links for the sites :
      site with schedule :
      http://www.myfit.cz/rozvrh/
      site of one of the class (pilates)
      http://www.myfit.cz/lekce/pilates/
      site with calendar :
      http://www.myfit.cz/kalendar/
      7 side with one event from the calendar :
      http://www.myfit.cz/event/pilates-instruktor-akreditovana-licence/?ri=1
      when I have my site on DMS2 it was working :-(
       
       
    • Barnaby Skinner
      By Barnaby Skinner+
      Hey team,
      Really simple question: where would I add code to a specific page header? I can see in the settings I can add code to the global header, but can't see how to do it for a single specific page. It's related to facebook pixel tracking
      Cheers
    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
×