Jump to content

Archived

This topic is now archived and is closed to further replies.

travistsickle

Issue upgrading to 2.0.5 DMS2

Recommended Posts

travistsickle

The upgrade crashed my site.  I tried to uninstall and reinstall but didn't work.  I reinstalled the previous version of DMS2 and it worked.  I then tried to upgrade again and didn't work.  The issue seems to be the tools on the customization page are all messed up with repeated icons and really slow.  It crashed a few times and had to reopen the browser.  Finally i just put the old version back and it worked.  

 

I tried disabling all plugins too.  

Share this post


Link to post
Share on other sites
Danny

HI,

 

Did you manage to take any screenshots of the issue, as I have just updated 13 test sites and not one of them had the issue you mentioned.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
travistsickle

I didn't unfortunately.  I am almost done restoring.  On the same issue, when I did upgrade I always lose some of the formatting, like my logo disappears.  The process I use it just clicking on updating.  Is there a way to update so this doesn't happen?

Share this post


Link to post
Share on other sites
Simon

why are you on customize.php?

Share this post


Link to post
Share on other sites
Simon

I can tell you this, from watching you change themes, you have multiple dms installs, and simply uploading a new dms to a different folder and activating is NOT the way to upgrade a wp theme.

 

why? Because wordpress stores a lot of information in theme settings, menus widgits etc etc, and these settings are all saved under the theme slug which in turn is derived from the themes folder. So by creating new folders everytime you are creating new theme options.

 

if DMS was in a folder called /dms/ and you used the updater plugin non of that would happen.

Share this post


Link to post
Share on other sites
travistsickle

I did that the first time and the screen shot you see is the same as what I saw before.  I saw the update in the backend of wordpress and clicked update.  

 

 

When that didn't work I then tried to create the new folders in an attempt to rollback to the previous version that I had manually downloaded before.

 

I'm restoring again but not sure what to do after since I restored earlier today and then when through the same process of clicking update on the theme.

Share this post


Link to post
Share on other sites
travistsickle

I restored and the site is up again but not sure what to do so I can update.

Share this post


Link to post
Share on other sites
Simon

Why are you clicking customize?

 

What happens if you just go to the front page?

Is there any javascript errors in chrome dev tools?

Share this post


Link to post
Share on other sites
travistsickle

Isn't that how you edit the backend of a pagelines theme?  Clicking on customize?

 

The site didn't get messed up on the frontend.  I just can't edit the backend from what the video shows after the upgrade.

 

I also disabled all plugins to see if there was a conflict.

Share this post


Link to post
Share on other sites
Simon

1. click update

2. goto your front page NOT customize.php

3. if its still jumbled open chrome developer tools and check the console for any errors.

4. If still persists send me a login so i can see the error for myself.

 

The only way we can fix this is to see the actual error as it happens.

Share this post


Link to post
Share on other sites
Simon

Just noticed NONE of your css or js files have version numbers, is that intentional?

Share this post


Link to post
Share on other sites
travistsickle

no it's not intentional.  What might cause that and how to fix?  Are you thinking that could be the issue?

Share this post


Link to post
Share on other sites
Simon

Well yea, when wordpress, plugins and DMS updates, generally js and css gets updated but your site has no version numbers. 

 

Are they being stripped by a plugin? This is not the default behaviour.

Share this post


Link to post
Share on other sites
travistsickle

I wouldn't know. but I'll go ahead and disable all the plugins again.  Would that fix it maybe?

Share this post


Link to post
Share on other sites
travistsickle

Disabled all plugins except pagelines plugins and backend still does not work.

 

If I revert back to the previous version everything works, but why can't I upgrade to the 2.0.5 version?

Share this post


Link to post
Share on other sites
Danny

I am not sure what that video is supposed to show us, you do not edit your site via the Customize panel in the WordPress backend for two reasons.

 

1. There is no need, you do all the customizing, changes to your layout/style etc... via the front-end of your site using the DMS Visual Editor.

2. DMS uses LESS CSS for everything, then it gets compiled to CSS. However, WordPress doesn't support LESS CSS, so when you use a WordPress core feature or functionality such as the Customizer, then it will not be an accurate representation of your site, as there isn't any LESS CSS support.

 

So to resolve your issue, use DMS as it was mean't to be used via the front-end and not through the WordPress customizer.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon

 

If I revert back to the previous version everything works, but why can't I upgrade to the 2.0.5 version?

Simple, when you update, a lot of css and javascript files get updated, but on your install there are no, yes NO version numbers, so in your browser you are laoding the cached versions of these files and thus a broken editor.

 

Basically, as long as this is the case, you will never be able to update wordpress or any plugin or theme without running into similar issues.

Share this post


Link to post
Share on other sites
travistsickle

Okay.  That works.  I didn't realize that I was supposed to edit it that way.  Not that savvy but thanks for pointing it out.

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×