Jump to content

Archived

This topic is now archived and is closed to further replies.

allanlove

Featured Image showing in WP Content/Loop

Recommended Posts

allanlove+    1
allanlove

Hi

 

I am building my first site with DMS2 and have a bit of an issue with featured images. In DMS1 it was possible to either remove the featured image from the WP Content/Loop or control where it showed up. I can't seem to control it at all in DMS2?

 

I need to use the featured images for the 'Latest Blog Posts' section but don't want them to show on the actual blog post. I also want to control it to left justified in the excerpt of the main blog page but can't do any of this in the same way that I used to.

 

Can anyone help please??

 

Thanks

 

Allan 

 

Share this post


Link to post
Share on other sites
GetMeWebDesign+    115
GetMeWebDesign

Under the wp content/loop in DMS live editor, Enable legacy mode and you will see a full range of options you had in Framework DMS 1


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hello allanlove

 

In the Post loop settings you can enable the legacy options in order to edit this . 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Simon    247
Simon

or if you want to use the new loop...

 

https://gist.github.com/Pross/9984549

Share this post


Link to post
Share on other sites
allanlove+    1
allanlove

Thanks for your help! I don't really want to use the legacy options as they won't be supported in future releases.

 

I would like to use the code supplied by Simon but am not too confident! Do I need to update the functions.php file with the code supplied? 

 

Thanks again

 

Allan 

Share this post


Link to post
Share on other sites
Simon    247
Simon

you need to use a child theme, and add it to the function.php in there.

 

Or create a plugin...

 

Or add it to a file in wp-content/mu-plugins/ folder

 

choice is yours ;)

Share this post


Link to post
Share on other sites
allanlove+    1
allanlove

Oh dear, all sounds a bit technical. I guess the easiest way is to use a child theme but I'm not sure how to so I'll have to read up on it.

 

Thanks again Simon!

 

Allan 

Share this post


Link to post
Share on other sites
allanlove+    1
allanlove

Just a quick update, I used the code you supplied Simon in the Pagelines Customize Plugin and it's working just I how want it to now!

 

Cheers

 

Allan 

Share this post


Link to post
Share on other sites
allanlove+    1
allanlove

Ooops, looks like I was a bit hasty there!

 

The featured image has disappeared from the post itself which is great.

 

On the Archive, Category and main blog page, the image still shows very large and on top of the excerpt of the article. Is there a way of using the same function.php file to get the featured image on these pages to be 150px x 150px and be left aligned of the actual excerpt?

 

Your help is greatly appreciated.

 

Allan 

Share this post


Link to post
Share on other sites
alisamski+    8
alisamski

or if you want to use the new loop...

 

https://gist.github.com/Pross/9984549

 Simon_P I added this to the child theme function.php file.. and it gave me the white screen of death!

 

I added this css...

.pl-new-loop .hentry.single-post .metamedia {
    display: none;
}

but does not seem to hold throughout site. it will refresh and get rid of the feature image inside a full post... but show up again.

 

Please advise.

http://bit.ly/1o18X6N

Share this post


Link to post
Share on other sites
Simon    247
Simon

probably errored out because you already had <?php in the functions file.

Share this post


Link to post
Share on other sites
alisamski+    8
alisamski

geesh.....

 

I need more caffeine.

 

So I put inside the function file...

 

however, it did get rid of the thumbs inside the rapid tab area too...

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

allanlove - So you want to remove the post thumbs from everywhere including category, archives pages etc.. ?

 

alisamski - The snippet of code provided by Simon, strips the thumbnail from the Rapid Tabs section ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
allanlove+    1
allanlove

Hey Danny

 

Kind of. I need to use the featured image when creating the posts as some plugins that I use calls for them. I also want them to pull through to the category, archives pages etc but want them small and in line left justified with the excerpt. The code that Simon provided stripped the featured image from the actual post page itself which I also wanted so that bit works fine.

 

I am using the legacy options at the moment but would like to come away from that fix as it won't be supported in the future.

 

Thanks for your help.

 

Allan 

Share this post


Link to post
Share on other sites
alisamski+    8
alisamski

Danny

I want to have the thumbs show up in category sections and blog section... NOT on the full post page...

 

Never had that before on any of the past versions of Pagelines... I love the way the section looks and do not want to have the legacy layout on this site...

 

As for rapid tabs... you can see that the thumbs disappeared on the full post page... and re-appear on the category/blog page.

 

Thanks for the help.

 

A.

Share this post


Link to post
Share on other sites

  • Similar Content

    • globalnative
      By globalnative+
      Hi there!
      I'm trying to create a featured image for my new blog post. It has text in it, and when I add it as a featured image some of the text is cut off on the right.
      Could I get the ideal dimensions for featured images? Or, a way to customise the dimensions so that they are easier to fit in the way I need?
      Thank you kindly
      Nate
       


    • BlueSkyCreative
      By BlueSkyCreative+
      Hi there
      I have postgrid on a new site I am developing and want to try using png images as a featured image, but they are rendering on the page as a black square?
      Any ideas as to why? 
      the site example is here http://orionglobalms.com/ scroll down to our services section and the first one has a png image as a featured image
       
      Many thanks
      Paul

    • MissT
      By MissT+
      The featured images from the search results page seem to be missing - the featured images are there when you view the individual posts and on the Magazine section blog page but there are broken links on the Search Results page. See screen shot...
      WP - 4.4.2
      Platform5 - 5.0.132
      Can provide a link to the site privately.
      Many thanks in advance.

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
×