Jump to content

Archived

This topic is now archived and is closed to further replies.

mrlipa

DMS 2 - BuddyPress 2 User Profile 404 error

Recommended Posts

mrlipa    0
mrlipa

Hi

 

I'm trying to create a social website that can sell travel packages.

 

Website URL: guanaima.com
Framework Version: DMS 2

WordPress Version: 3.9
Plugins in Use: WooCommerce, Wordpress SEO by Yoast, Custom Sidebar 

 

The problem I'm having is that when I activate the BuddyPress plugin in the website I get a 404 error on the user relates pages. (The activity feed and the members page work fine). I tried to disable other plugins, but it didn't work. I also tried creating a buddypress.php file as mention in this post http://forum.pagelines.com/topic/31999-buddypress-19-no-content/?hl=buddypress but still nothing. Does anyone have any idea?

 

Thx

 

 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

HI,

 

Try adding the WP-Content/PostLoop section to your template.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
mrlipa    0
mrlipa

Ooooh that solved the problem!

 

Thank you!

 

I spent more than 3hours trying to understand the problem. It was just that it didnt charge the wp-content/postLoop section as you mention. 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Yeah, we apologise, it should be there by default so users don't get confused. When I first seen it, I was like "What the hell" ? So I have reported this to our tracker.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
roryeley    0
roryeley

Just wanted to add to this thread - I have recently set up the new DMS 2 theme

after installing buddypress the site had issues

 

after going over the plugin conflicts - the plugin that caused the conflict is in fact your own plugin DMS Professional Tools

 

I cant activate this plugin without breaking my site - could you guys check this out?

Share this post


Link to post
Share on other sites
solosails    1
solosails

Hi,

 

I have this problem too, however this only partly solves the problem for me.

 

I now no longer get the 404 page (I had to delete that) but the profile page is only appearing a blog summary (archive list type) and not formatted properly?

 

Strangely my admin user profile (for bbpress) has always displayed correctly, but non of the others (non admins) do. 

 

Any ideas?

 

Cheers, ANdrew

 

 

Share this post


Link to post
Share on other sites
solosails    1
solosails

OK, I have got the user data displaying ok by setting the content/loop settings to legacy mode, but still have a jumbled post summary in the top?

Share this post


Link to post
Share on other sites
solosails    1
solosails

OK, I can hide the post summary using css ...

section.bd.post-header.fix {display:none;}

But this ruins the post info on the blog pages,..

 

How to tailor the css so that it only affects the bbpress user profile pages?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

solosails - Can you create your won topic as the original question has been answered correctly. When creating a new topic can you include a link to the site/page in question so we can take closer look.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
solosails    1
solosails

Hi Danny,

 

Yep, will do, only problem is that the site I'm building is a private members site. I can give you guys an access login if needed?

 

I can confirm that the DMS professional tools plugin when deactivated appears not to make any difference to my set up.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Create a new topic regarding your issue and send me a PM with a link to the site in question. Along with your admin username/password.

 

In your topic, please include images so we can better understand your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • kdemming
      By kdemming+
      I have a podcast and all the links to the podcast are producing a 404 error. 
      Yesterday I had a problem with PHP and since uploading it still has not fixed the problem. Not sure what to do. 
      http://www.keitademming.com/disruptiveconversations/
    • petere21
      By petere21+
      DMS 2.1.9.2 with Accordions WP 4.1 last version BUDDYPRESS 2.2.0   All plugins except DMS professional tool, Pagelines updater and Buddy press are turned OFF.   after installing Buddypress I'm not able to create any Buddypress group.   1. problem (CANNOT VIEW PAGE GROUPS: 404 Not Found) conflict Accordions versus Buddypress       When Accordions are activated I am not able to view page GROUPS. After deactivating of Accordions I am able to see page Groups of Buddypress.      the same problems have pages MEMBERS and Activity   2. problem (I CAN SEE PAGE GROUPS, BUT I CANNOT CREATE ANY GROUP it doesn't work (404 Not Found)     just DMS without Accordions       2. problem solved by replacing sections still conflict with Accordions 
       
      Try replacing the 404 section with the WP-Content/PostLoop section.
    • Aires
      By Aires+
      I have been trying to use Buddypress with DMS for the past couple weeks with hope that I can wrap my head around it and build something with DMS for a potential client. Because I have never used Buddypress with dms before I wanted to do a test run.
       
       After countless style issues I finally thought I was making progress enough to follow up on the client. But something told me to try every link and page that BuddyPress produces automatically after install.
      Upon doing so all the pages gave me 404 errors I switch themes and the pages and links are there. But they don’t work in DMS.  
       
      Screencast here http://screencast.com/t/yRMbX4W1Rq
       
      Thanks in advance
    • Ron
      By Ron+
      (Correction - Update was to 1.9.1 not 1.1.9, but unable to correct in title above)
       
      I did the monthly update for my 2 sites - plugins, WP, theme - and when I was finished my site gave me a 404 error page with some info about needing a dms folder.  I looked in the themes folder and my child theme folder was there but instead of a dms folder there was a tmp folder.  When I changed the name of the tmp folder to dms my site came up, for both sites.
       
      However, when I tried to go to any page or post on the site I got a 404 error.  Fortunately I always backup just prior to doing updates so I just restored the backup and the sites both are totally fine now.  But I can't update the DMS theme.
       
      What could be causing this?
       
      I tested the site after updating all the plugins and it worked fine; I tested the site after updating WP to 4.0.1 and it worked fine.  It was only after doing both of those and then updating the DMS theme that it broke.
       
      Sites are clearwaterbeachcondosforsale.com and searchclearwaterhomes.com.  Both are now back to DMS 1.8 so they are not currently showing the 404 error issues.
       
      Thanks,
      Ron
    • travistsickle
      By travistsickle+
      My site is producing a 404 error when I look for my sitemap.  
       
      www.sicklehunter.com
       
       
×