Jump to content

Archived

This topic is now archived and is closed to further replies.

layasamadhi

Problem with Page{Less} and full-width Navi section in DMS2

Recommended Posts

layasamadhi
Basically I encountered this issue. Every time I refresh the page reappears the PageLines's logo and search box on navi(full). In practice I change the navi(full), hide the search box, replace the logo, public the changes and after page refreshing the disaster. PageLines's logo and search box reappear. 
 
I went crazy for two weeks. I tried to isolate the problem and in the end I found the accused plugin: Page{Less}.
 
When Page{Less} is off everything works. When active the problem persists.

Share this post


Link to post
Share on other sites
Guest

Greetings layasamadhi,

 

I'd be happy to look into this for you, however I need some more information to begin.

 

  • Installed versions of DMS and PageLESS
  • When you say "navi" are you referring to the core NavBar section?

Share this post


Link to post
Share on other sites
layasamadhi

Installed DMS 2.0.4 and PageLESS 1.2.3

 

With "navi" I mean the section Navi (Full) placed in the fixed bar.

Share this post


Link to post
Share on other sites
Guest

layasamadhi

 

Unfortunately, I have been unable to replicate this problem.  Can you provide some more details to your steps to recreate this?  How would I recreate your problem starting from scratch? Does this happen on every page? or only pages with PageLess styles?

 

I have reviewed the code for the navi section and I don't see anything there that would conflict with PageLess nor vice versa.  I understand that you are only having this problem with it enabled though so let's see if we can get to the bottom of it.

Share this post


Link to post
Share on other sites
layasamadhi

1) Place navi(full) section in the fixed bar.

2) Replace the logo

3) Hide the box search

4) Publish the customization

5) Edit the css with pageLESS (any element)

6) Refresh the page

 

The problem should arise. Sometimes it does not happen immediately, but after a several refreshes. I know, this is weird. In fact I went crazy for two weeks to look for what was to be incompatible.

Share this post


Link to post
Share on other sites
Guest

layasamadhi,

 

Good news,  I can see what you're talking about now.  I don't know exactly what the cause is yet but I'm leaning towards a possible bug with DMS.  I've found that even though the settings seem to be wiped out, they are in fact still saved!  For some reason they are just not taking effect.  It's very strange.  I will keep digging into this and let you know what I find.

Share this post


Link to post
Share on other sites
Guest

layasamadhi,

 

Hello again!  After doing some digging, I was unable to figure out exactly why things were breaking the way they were.  I don't really think my extension is to blame because my method of saving (which seems to be the culprit here) has not changed from older versions of DMS which had no problem before.  However, I believe I have resolved the issue now and I have just released an update (1.2.4) that should take care of it.

 

Please let me know if you continue to have any problems after the update.

Share this post


Link to post
Share on other sites
layasamadhi
Wow that speed! 
Now I try if there are other problem. I'll keep you updated.
 
Thanks. 

Share this post


Link to post
Share on other sites
layasamadhi
Now finding problems with the footer. 
The "social links" section disappears completely after the page refresh.
 
Even in this case is not recurrent. It's pretty random.
 

Share this post


Link to post
Share on other sites
Guest

layasamadhi,

 

Are you sure this is related to PageLess as was before?

Share this post


Link to post
Share on other sites
layasamadhi

Hi Evan.

 

No, I'm not sure. I'm trying to understand and isolate the problem. I'll keep you updated.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
×