Jump to content

Archived

This topic is now archived and is closed to further replies.

Umar Adil

Font Awesome Icons showing empty boxes

Recommended Posts

Umar Adil    2
Umar Adil
 
I have installed the DMS2 theme but the font awesome icons does not appear but showing rectangular empty boxes. I tried hard to figure it out, I found in /wp-content/uploads/pagelines/editor-draft.css  , the font awesome path starts with ///websitecsm/.... and if change it to //dev2.socrato.com/websitecms it works. When ever I modify something from admin, it replaces the css file again and I lose my font awesome icons . Please help. 
 
I have attached a ss.

--

Regards,

Umar Adil

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

First and forth most, please refrain from creating multiple topics regarding the same issue - http://forum.pagelines.com/topic/33961-font-awesome-icons-showing-blank-boxes/

 

Even if this is two different accounts, the private URL field contains the same web site URL. Also, never edit the core files, this is not recommended and voids all support.

 

If your file path is set to that, then its likely an issue with how your Wordpress is setup. How did you install it and is it installed in a sub directory ?

 

What I would suggest is for you to flush your LESS/CSS and see if this resolves your issue. Go to DMS Toolbar > Settings > Reset and hit the Flush button and see if this resolves your issue. If it doesn't please provide a link to your site and make sure DMS Debug mode is active (DMS Toolbar > Settings > Advanced).


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Umar Adil    2
Umar Adil

I tried cache flush no luck, my wordpress is installed in a sub directory    /public_html/websitecms/wp-content/themes/dms 

 

 

How can I fix this issue then? 

 

 

I am working on http://dev2.socrato.com/


--

Regards,

Umar Adil

Share this post


Link to post
Share on other sites
Umar Adil    2
Umar Adil

can u please check this issue on the above url?


--

Regards,

Umar Adil

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

As requested by Danny - please enable debug

 

Site Settings > advanced  and let us know when you have done this 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Umar Adil    2
Umar Adil

my debug mode is already enabled


--

Regards,

Umar Adil

Share this post


Link to post
Share on other sites
Simon    247
Simon

Your css urls are all 404. You have your site_urls wrong in wordrpess.

Share this post


Link to post
Share on other sites
Umar Adil    2
Umar Adil
<link rel='stylesheet' id='pagelines-less-core-css' href='/websitecms/wp-content/uploads/pagelines/compiled-css-core-1397242321.css' type='text/css' media='all' /> <link rel='stylesheetid='pagelines-less-sections-csshref='/websitecms/wp-content/uploads/pagelines/compiled-css-sections-1397242321.csstype='text/cssmedia='all' />  

 

Please check the source of home page, css files are correct


--

Regards,

Umar Adil

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

The issue is how you have set up your site, the URLs for your scripts/stylesheets are all like this:

href='/websitecms/wp-content/uploads/pagelines/compiled-css-core-1397373659.css'

Where as on my test site with WordPress installed in a subdirectory like you have they look like this:

href='http://wpdir.dev/test/wp-content/uploads/pagelines/compiled-css-core-1397389995.css'

 

See how mine contains http://, where as yours doesn't. So how have you have added your site url as Simon suggested above? The issue is most definitely caused by how you have setup your site.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Umar Adil    2
Umar Adil

My /public_html/websitecms/wp-content/uploads/pagelines/editor-draft.css

 

 

'PageLinesFont';src:url('///websitecms/wp-content/themes/dms/dms/fonts/fontawesome-webfont.eot?v=4.0.3');src:url('///websitecms/wp-content/themes/dms/dms/fonts/fontawesome-webfont.eot?#iefix&v=4.0.3') format('embedded-opentype'),url('///websitecms/wp-content/themes/dms/dms/fonts/fontawesome-webfont.woff?v=4.0.3') format('woff'),url('///websitecms/wp-content/themes/dms/dms/fonts/fontawesome-webfont.ttf?v=4.0.3') format('truetype'),url('///websitecms/wp-content/themes/dms/dms/fonts/fontawesome-webfont.svg?v=4.0.3#fontawesomeregular') format('svg');


--

Regards,

Umar Adil

Share this post


Link to post
Share on other sites
Umar Adil    2
Umar Adil

Thanks Danny I got it fixed,

 

I changed the path in admin settings, but now I have to fix the path every time I move the site from staging to production.


--

Regards,

Umar Adil

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Thanks for letting us know 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Umar Adil    2
Umar Adil

Welcome


--

Regards,

Umar Adil

Share this post


Link to post
Share on other sites
Simon    247
Simon

Fiskaz if you read the actual error:

HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

 

The PC is configured wrong, you need to add a mime type. Best to contact the person who set it up.

 

Apologies for the thread hijack..

Share this post


Link to post
Share on other sites
Fiskaz    0
Fiskaz

Hi Simon,

 

Could you please help me where i can get MIME map and how can i add handler?

Share this post


Link to post
Share on other sites
Fiskaz    0
Fiskaz

Thanks SImon for help i will try it and let you know.

Share this post


Link to post
Share on other sites
Simon    247
Simon

you can use icon in replace of fa if you want.

 

Apologies again to the original post author for unrelated replies.

Share this post


Link to post
Share on other sites
josh1178    10
josh1178

I just spent 40 minutes troubleshooting this trying to use the solution Danny posted, when in the end it was simply that the wrong icons are listed in the Pagelines documentation.  Thanks to Batman for pointing this out earlier. The solution by Danny should be updated and the online DMS documentation should be updated as well. Thanks

 

The working icon names are here:

http://fortawesome.github.io/Font-Awesome/icons/

 

The wrong non-working icon names are here:

http://docs.pagelines.com/tutorials/font-awesome

Share this post


Link to post
Share on other sites
Simon    247
Simon

Which one isnt working?

 

(Apologies again to the original post author for unrelated replies.)

Share this post


Link to post
Share on other sites
josh1178    10
josh1178

Sorry. I was experiencing the 'white box' problem the original post was discussing.  So, I tried to solve it by figuring out what Danny meant about URLs. Then I realized that the reason I was getting the white boxes is because the documentation uses what is apparently old font-awesome icon names. The ones listed on the documentation page result in a white box, the ones on the font awesome page seem to work. 

 

Thanks

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Which ones are you referring to ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • gregbroxton
      By gregbroxton+
      The Font Awesome 'Brand icons' do not render on the mobile version of this site.
      The other Font Awesome icons render fine, but the "Brand icons" do not render at all when viewed on mobile.
      Everything works normally when viewed on the PC.
      Any ideas why the brand icons will not render in the mobile version?
      The site is using DMS2 with all updates
      gregbroxton.com
    • bartoncollege
      By bartoncollege
      I was perusing the master list of Font Awesome icons at http://fortawesome.github.io/Font-Awesome/icons/ and noticed that there are many new ones that are not available in iBox's dropdown menu.  Will these be added in the next DMS update?
      Thanks.
      Ken.
    • abuzzelli
      By abuzzelli+
      Trying to display social icons in the footer of http://brkichdesign.com/NewSite/. All are working but yelp. It's right after the pinterest icon, it's there but not showing up. Any ideas why?
    • webmktco
      By webmktco+
      Website URL: http://www.schrumpfdds.com/
      Framework Version: DMS 1.1.9
      WordPress Version: 4.1.1
       
      I noticed that the Font Awesome version in my theme is 3.2.1.
       
      Can you tell me how I can update the FA version? Or is that not possible?
    • webmktco
      By webmktco+
      I can't get the Yelp icon to display.  It seems my development site has an older version of Font Awesome (according the FA developer).
       
      How can I update FA to the most recent version?
       
      WordPress Version
      4.0.1
      Framework Version
      2.1.9.1
      PHP Version
      5.4
      http://forsythdentalpartners.myddsdev.com/  

×