Jump to content

Archived

This topic is now archived and is closed to further replies.

dchetson

Change Font Color in NavBar

Recommended Posts

dchetson+    2
dchetson

I am trying to change the font color for the navbar to white. Can't seem to figure out the CSS to do it. The site is www.chetson.com. Any help would be greatly appreciated.

 

Thanks!

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

that would be 

.section-navbar .navbar .navline > li > a {
  color:#FFFFFF;
}

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
dchetson+    2
dchetson

Genius - thank you! RESOLVED.

  • Like 1

Share this post


Link to post
Share on other sites
dchetson+    2
dchetson

Actually Martin, I think when I did that it extended the background color of the nav bar across the entire page. How do I limit it again to just content width?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

In future can you refrain from asking multiple questions per topic, forum policy is one question per topic.

 

However, we may as well answer it here, so can you provide a link to the site in question please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dchetson+    2
dchetson

Sorry, it was a change that happened as a result to the answer of the first question.

 

The site is www.chetson.com

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Im not entirely sure what you want to achieve, as your site is full width ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
dchetson+    2
dchetson

Before I changed the text color, the nav bar only extended the width of the content.

Share this post


Link to post
Share on other sites
dchetson+    2
dchetson

I just figured it out. Issue resolved. Thanks!

Share this post


Link to post
Share on other sites
dchetson+    2
dchetson

Sorry to be a pain, but I changed the nav bar from a full width to content width. Now, the CSS code that was provided earlier to change the text to white is no longer working. Any ideas?

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

No need to apologise. :) 

 

it's the same code to achieve this 

 

.section-navbar .navbar .navline > li > a {
  color:#FFFFFF;
}
 
if this has stopped working entirely. Take all your Custom CSS code and paste it in here http://forum.pagelines.com/pst/
 
If you can provide the link to the paste i will take a look at this for you 
  • Like 1

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
dchetson+    2
dchetson

Of course now it works. I promise you it wasn't working before ;)

 

Thank you again for your patience!

Share this post


Link to post
Share on other sites
James B    436
James B

Glad you managed to resolve, thank you for updating the thread.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • Barnaby Skinner
      By Barnaby Skinner+
      Hey all, hope I worded the topic correctly!
      I just need to know if either 1) I'm making a mistake or 2) this could be set as a new feature?
      Using the global settings typography parameters, I have a global paragraph font type (set using googlefonts) and have set the style to align:justify. When laying out <p> text inside a simple TEXT module, the <p> text adheres to both the font type and justification. Perfect.
      Now, when I set <p> text inside the PARAGRAPH TEXT field within an ELEMENT module, the <p> text adheres to the font type, but not the justification. It's rather annoying as I like to fully justify para text across the board and tend to use Element modules instead of text boxes for various reasons. It also seems silly that some PARAGRAPH TEXT fields adopt global settings, whilst other don't.
      Or I'm doing it wrong :S
      Any help or advice is much appreciated!
      Cheers
    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • John Olsson
      By John Olsson+
      Hello,
      I wondering (and custumers) when does Font Awesome 4.7 comes with an update of Pagelines?
    • PierreFF
      By PierreFF+
      Hello, 
      I have an issue with NavPro on mobile when the link of the menue is on the same page. 
      Here is my website: http://foundersofthefuture.co
      The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 
      This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 
      I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 
      Thanks in advance for your help and let me know if I need to provide more information. 
      Best,
      Pierre
    • Queue-it
      By Queue-it+
      Hi,
      I have the primary font family set to Arial. If I add another font (Open Sans), how do I change it only on a specific page? 
      I want to have Open sans only on one of my landing pages, but by default it will fetch Arial. Is there a way to change it without a plugin?
       

×