Jump to content

Archived

This topic is now archived and is closed to further replies.

massmosaic

DMS 2 - Error updating with Child Theme

Recommended Posts

massmosaic    0
massmosaic

Hi Pagelines,

 

I have been using a child theme w/ DMS 1.xx and just updated to DMS 2.03. I'm getting the following error: http://massmosaic.com/wp-content/uploads/2014/04/Screen-Shot-2014-04-08-at-11.20.34-PM.png

 

Can you make a recommendation for how to fix or if there's a way to make DMS 2 work with our existing codebase?

 

I'm excited to explore DMS 2 once we get past this.

 

 

 

Share this post


Link to post
Share on other sites
massmosaic    0
massmosaic

I spoke to a developer friend who advised me to remove a line of code from the functions.php in the child theme:

 

require_once( get_template_directory() . '/includes/init.php' );
 
This is something that had been in the DMS 1.xx child theme, whose code I got from this site. Removing it fixed the issue.
 
Is this function something that is needed, or obsolete in DMS 2+??

Share this post


Link to post
Share on other sites
massmosaic    0
massmosaic

Spoke too soon. The error is still happening. 

Share this post


Link to post
Share on other sites
Simon    247
Simon

looks like your childtheme cant find the dms files. Did you install it correctly?

Share this post


Link to post
Share on other sites
massmosaic    0
massmosaic

Hmm, I had tried to upload DMS 2 via the WP backend and got an error saying directory already exists.

 

So then I used FTP and overwrote the DMS 1 folder in WP Content -> Themes with the new one.

 

Perhaps that's it? It's my understanding that this way works, but then again I usually add themes via the backend.

Share this post


Link to post
Share on other sites
Simon    247
Simon

you cnt update a theme by uploading it, you get the folder already exists error, thats always been the case with wordpress. Yea you can update the files via FTP, but it looks like you either uploaded them to the wrong folder, or you didnt upload all of them

Share this post


Link to post
Share on other sites
massmosaic    0
massmosaic

I've deleted the theme and re-uploaded via the WP backend. It installs correct. Then I go to activate the child theme and still get the error.

Share this post


Link to post
Share on other sites
Simon    247
Simon

Might help if i could see the site

Share this post


Link to post
Share on other sites
massmosaic    0
massmosaic

Cheers.. yes

 

The site is test.massmosaic.com

 

I'll pm you the password info...

Share this post


Link to post
Share on other sites
Simon    247
Simon

im guessing its an old child theme is it?

Share this post


Link to post
Share on other sites
massmosaic    0
massmosaic

Yes, exactly. Was using it w/ DMS 1.xx

Share this post


Link to post
Share on other sites
massmosaic    0
massmosaic

I've downloaded Skeleton and then just moved the edits I've done over to this folder. Uploaded the zip and everything works!

 

Thank you Danny.... appreciate it. Problem solved :)

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Awesome and no problem!


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • flourishdesignstudio
      By flourishdesignstudio
      I am working on a multisite installation and had some questions regarding the themeing options. All the sites will have the same structure but each individual site would need a different h1 font and link color. I had originally thought that I would program/edit the parent theme to have a certain set of templates, font sizes, etc. and then that would feed to all the individual sites where I could activate the child theme and use the child theme to define the individual sites' specific link color, heading fonts, etc. So, what I was shooting for was:
      Parent theme = shared by all sites
      Child theme = specific to the minor customizations on a per site basis.
      Is this possible? Am I misunderstanding how these would actually deploy to the different sites?
    • bnapoli
      By bnapoli+
      On my site www.modishmel.com I'm seeing the "blog post title" within the "pins" plugin section breaking words into multiple lines. See screenshot attached.
      Only seeing it in Firefox. Can you help?

    • jagipson
      By jagipson+
      Should be a simple answer but not sure why its not doing this.  I have a child theme installed on pagelines 5 that has a hook so it will write over the theme css. Strange is that when I am on the frontend the code works but in the dashboard your theme takes over my code and its no where to be found. See examples attachments
      @Andrew @Danny


    • TallTree
      By TallTree+
      Hi,
      I am trying to remove the sidebar areas from my child theme (pagelines.com) from the post pages on a site:
      https://staging4.talltreemusicfestival.com/2017/grand-analog/
      The content is all the way to the left and very small, and the two sidebar areas are taking up a lot of space.
      What I'm after is content to the left, taking up most of the space, and then a small sidebar width on the right for widgets.
      I've tried selecting 'read width content' and 'full width content' in the edit screen for the WP content section, but it doesn't change.  If I try to move the sidebars (1 or 2) to the left, it doesn't change.
      If I select the pagelines framework theme (not child), the two sidebars go away when not selecting them in the edit screen..
      Can someone please tell me what I'm doing wrong?
      Thanks in advance.
      -Matt
       
×