Jump to content

Archived

This topic is now archived and is closed to further replies.

KimAnn03

iPhone background image issue

Recommended Posts

KimAnn03

On my iPhone my site deosn't load the background image toward the bottom of the screen (on all pages). If you scroll all the way to the bottom the background image will then appear all the way to the bottom but then if you scroll back up again it disappears once more.

 

Here is a screenshot of what I mean:

http://dev.thecosmicpath.com/wp-content/uploads/IMG_5636.png

 

Kim

 

dev.thecosmicpath.com

 

Share this post


Link to post
Share on other sites
greenfly

Hi Kim - Could we have the dimensions of your background image pleasE? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
James B

Hi Kim, this seems to be a bug, I've reported on the bug tracker. From what i can see it seems to be related to the navigation panel being active/inactive at the bottom of the iphone browser, this affects the image being resized causing the gap.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
KimAnn03

Thanks James B I will wait for that bug fix in an upcoming release. And you are right, when the nav panel at the bottom is active there is no gap in the background image but when it is inactive there's a gap. good detective work.

 

Kim

Share this post


Link to post
Share on other sites
scientistsofmedia

any update on this bug?  I am experiencing the same issue with the background image on my site when viewing  from an iphone.

http://27f.2b6.myftpupload.com/

Share this post


Link to post
Share on other sites
Danny

@scientistsofmedia

Remove your Background image from the option and then add the following CSS and see if this resolves your issue.

body {
  background-image: url(http://27f.2b6.myftpupload.com/wp-content/uploads/2015/06/bkgr-retouch-photoshop2.jpg);
  background-size: cover;
}

 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
scientistsofmedia

that worked.  thanks danny.

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×