Jump to content


This topic is now archived and is closed to further replies.


Button gradients not rendering

Recommended Posts


Hi. I've got an issue where the shortcode button gradients aren't rendering properly. I've reverted to a fresh install of DMS without my child theme on two different hosts (both WPEngine and Media Temple GS) but still can't figure it out.
See a button at:
The gradients worked perfectly in DMS1, rendering out all the background-image gradients. Now, all I get is like the following when I take a peek at the compiled compile-CSS-core:

.btn-warning{background:#f6653c;border-color:#f6563c #f6563c #db270a;border-color:rgba(0,0,0,0.1) rgba(0,0,0,0.1) rgba(0,0,0,0.25);filter:progid:DXImageTransform.Microsoft.gradient(enabled=false)}

I tried several shortcode buttons, similar results. The color even is quite off from the orange in the Docs (although perhaps this is simply spec for your Bootstrap Docs site?)


Looking at the buttons.less file, it appears to be similar to the DMS1 file (and I've not monkeyed with it). It's as though the "vertical" gradient class isn't getting pulled in.


I did note that the class.shortcodes.php in the includes directory is missing most of the shortcodes (from about 18 to 40, which includes the buttons), but I'm probably barking up the wrong tree there.


Any ideas?


UPDATE: Only plug-ins running are DMS Updater and DMS Professional Tools, and this is on WP 3.8.1

Share this post

Link to post
Share on other sites
James B

Hi there, DMS V2 doesn't use the gradients that the V1 version did, it uses one flat color.

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post

Link to post
Share on other sites

ah, interesting. You may want to update the Docs to reflect that change.


Thanks for clarifying.

Share this post

Link to post
Share on other sites

Hello @mckdesign 


This has been noted and we are updating docs at the moment 

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 


Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?