Jump to content

Archived

This topic is now archived and is closed to further replies.

canadvo

Moving from dev. subdomain -- Is theme impacted by switch?

Recommended Posts

canadvo

Trying to switch from a development subdomain to a production www with the same IP address. Plugins turned off, etc.

 

Almost none of the URLs are being updated in the pages, and with another approach all of the widget/header/footer information was lost, the DMS pro tools account does not seem to recognize the URL, and the theme appears broken. It appears that the post URLs are updating, however.

 

We've tried WP Clone and a sed -ie command (brought the server support on board, too; no luck).

 

Yes, all of the URLs are absolute. We have a couple of specific reasons for keeping it that way, and can't really go another route. We're using Nicks Base Theme and DMS Pro Tools on the site.

 

Is there something obvious I'm missing?

Share this post


Link to post
Share on other sites
greenfly

Hello @zbiondo 

 

how did you redirect the URLs in your database after migrating your site? I usually use https://wordpress.org/plugins/velvet-blues-update-urls/


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
canadvo

We used a Linux script rename command and WP Clone. Will give this plugin a shot, thanks.

Share this post


Link to post
Share on other sites
greenfly

No Problem - make sure you remove the plugin when you are done using it. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

  • Similar Content

    • Kedark
      By Kedark+
      Hello, I need help. Can and how to do it. I need to add more page appearance templates (page attributes). At the moment it's default and FRAMEWORK A, FRAMEWORK B etc. I need to add two more. How can I do this.
      Unfortunately, I did not find such a thread on the forum.
      Regards
      Radoslaw
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • tuciudadenred
      By tuciudadenred+
      Hi everyone, what happens is that the web page metrosalarmas.com has a google tags which I have not attacked where I can look to remove those tags and be able to locate the correct ones.
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a week ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
×