Jump to content

Archived

This topic is now archived and is closed to further replies.

carletto0282

LESS/CSS not compiling correctly

Recommended Posts

carletto0282

Hi guys,

 

I'm creating a brand new site for a client and I'm using DMS.

I've updated the theme to the last version 2.0.1 but while I'm working on it I've noticed a strange thing:

 

the site displays diffently when I'm logged in an when I'm not.

 

Searching through with chrome dev tools I've noticed that when I'm logged out the site il loading the file

 

compiled-css-core-1396458836.css

 

but when I'm logged in the style are set in

 

http://mysite.com/?pagedraft=1

 

I have tried to flush caches and even empty chrome cache but it doesn't work.

Do you have any suggestion?

 

Thanks in advance

Best regards

Carlo

Share this post


Link to post
Share on other sites
Simon

Yea thats exactly whats its sypposed to do. the daft css is for just when the editor is active. When you are logged out you see the public changes and the proper css files.

Share this post


Link to post
Share on other sites
carletto0282

Ok I understand it's working right but there's still somenthing not good.

 

Actually I set "Asap" as heading font and "Open Sans" as body font.

Once set those options I click the "Publish" button and reload.

 

While I'm logged in everything is ok just as I set up.

I if I log out and refresh I get body text displayed with "Asap" font. 

Check tha css and it says the font-family is set in the body rule... login back and boom: the body rule set the font-family to "Open sans" font...

 

What I have to do to update the compiled css?!

Share this post


Link to post
Share on other sites
Simon

The hidden support url in your profile is does not seem to be DMS, can you provide the moderators a url

Share this post


Link to post
Share on other sites
carletto0282

Unfortunately I think this issue is caused by the child theme since when I switch to DMS everything works fine.

 

There is something I have to add to my functions.php or to my style.css?

 

Since it's a client site I prefer not to post the url. May I send it to you with a pm?

Share this post


Link to post
Share on other sites
Simon

If you want to keep it secret the email it to the support desk, and they will look into it for you hello at pagelines dot com

Share this post


Link to post
Share on other sites
Simon

Or you could add it to the private site field in your profile, as only the support team can see that, and that is what its for.

Share this post


Link to post
Share on other sites
carletto0282

I added the site to my profile. Thanks

Share this post


Link to post
Share on other sites
James B

Hi there, who are you hosted with? It could be that your host has some form of additional caching.

 

Try using the alternate css urls method in site settings > advanced to see if this helps - http://screencast.com/t/jTmDbL1y


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
carletto0282

I'm hosted with Thirdeye Consulting (http://www.thirdeye.it/) but I think if it was an hosting related issue it should behave the same way - and report the same issue - even with the DMS without child theme.

Am I right?

 

I'll try with alternative css urls.

Thanks

Share this post


Link to post
Share on other sites
carletto0282

No way.

 

I try to empty my child theme less file since I use some variables like @baseFontFamily to retrieve the font as set in the theme settings but it still doesn't work.

 

I think it's something related to the extended google font feature because if now I change the font family while I log out I still not able to see those changes.

 

Is there someone to send admin credentials?

Thanks

Share this post


Link to post
Share on other sites
carletto0282

Hi guys, just updated to the 2.0.2 version of DMS and the issue seems solved!

Thanks

 

Best regards

Carlo

Share this post


Link to post
Share on other sites
James B

Hi Carlo

 

Excellent, thank you for updating the thread and letting us know.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
×