Jump to content


This topic is now archived and is closed to further replies.


Unable to get New WP Content/Loop on one page

Recommended Posts


Sorry for all the post loop issues, but i think I'm nearly there. After getting some layout stuff resolved in a different thread I'm running into an issue where the post loop on my main blog page won't update to the new format. I've deleted and re-added the component a bunch of times. Tried checking and unchecking the "Legacy Mode" box (saving, publishing, doing a dance in between each selection) and still every time I refresh the old format is still there. I tried loading a different template and then reloading the one that's applied to the working pages. It's all very strange.


I've got the new post loop format on all of my other pages except this one, and I'm not sure why.


Here's where it's working correctly:



And the main blog page that uses the same template where it doesn't seem to want to update:



Thanks for any advice.


Share this post

Link to post
Share on other sites

Wouldnt it be simpler to change in your general settings for the /2014/03/ to be your blog page. Then delete the "/blog" and then rename /2014/03/ to /blog?

Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post

Link to post
Share on other sites

It seems nothing I do fixes the problem. Setting back to a static page. Renaming/deleting pages. No matter what I do, whatever page is set to the main Blog page always reverts back to the old style magazine layout with 2 full-width posts. Which isn't even a layout I've ever used. I only ever used the list style layout.


This is very confusing.

Share this post

Link to post
Share on other sites

I really need some help with this. I  am unable to get the new DMS2 post loop to appear any longer. The Legacy Mode box is unchecked. Checking and unchecking the box doesn't work. Deleting the WP Content/Loop component and re-adding it doesn't help. I can't really do (or don't know how) the suggestion of GetMeWebDesign above because 2013/04 page is just an autogenerated archive page. It's not something I can set my blog page to. 


Any help or suggestions for next steps are appreciated.

Share this post

Link to post
Share on other sites

Well I finally solved it but it was sort of drastic. And unfortunately I think it was the last thing that I did that fixed it.


I deactivated all my plugins except pagelines ones. - didn't work

I went to Site Setting -> Resets -> Reset Global Settings - didn't work

Flushed Caches - didn't work

Finally went to Site Settings -> Resets -> Reset Current Page Settings - WORKED! :)


But now my site is in shambles and I have to redo just about everything.


Don't really know if it was the last thing or a combination of the steps before. 



Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?