Jump to content


This topic is now archived and is closed to further replies.


Editor changes not saving on local set-up

Recommended Posts


I installed DMS 2 on my local set-up and everything works fine except the editor isn't saving any changes (ie: trying to add a styling class, updating the options- anything.)


Here's the error the logs is giving:


[Sat Mar 29 12:43:49 2014] [error] [client] WordPress database error Field 'live' doesn't have a default value for query INSERT INTO wp_9_pl_data_sections (uid, draft) \n\t\t\t\t\t\t\t\t\t\tVALUES ( 'u7ja2m3', '{\\"textbox_title\\":\\"\\",\\"textbox_content\\":\\"\\",\\"textbox_font_size\\":\\"\\",\\"textbox_align\\":\\"\\",\\"textbox_title_wrap\\":\\"strong\\",\\"pl_standard_title\\":\\"\\",\\"pl_area_class\\":\\"barfood\\",\\"pl_standard_styles\\":\\"\\",\\"pl_hide_on_page\\":\\"\\",\\"textbox_pad\\":\\"\\",\\"textbox_animation\\":\\"\\"}')\n\t\t\t\t\t\t\t\t\t\tON DUPLICATE KEY UPDATE\n\t\t\t\t\t\t\t\t\t\tdraft = VALUES(draft) made by do_action('wp_ajax_pl_editor_actions'), call_user_func_array, pl_editor_actions, apply_filters('pl_ajax_fast_save'), call_user_func_array, PageLinesSave->fast_save, PageLinesSave->save_form, PLSectionData->update_or_insert, referer: http://wordpress.dev/gena/


I'm running mySQL 5.6.17 (and we tried 5.6.14 as well- still didn't work.) If we change the "live" feed table in the database to allow null, saving works fine but obviously, I don't want to have to update the database to get it to work.


Ideas on what the problem is? 

Share this post

Link to post
Share on other sites



Would it be possible to record your issue please, so we can see first hand what is happening. Make sure that all plugins are disabled and see if this resolves your issue, if it doesn't use an such as Jing to record your screen.

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?