Jump to content

Archived

This topic is now archived and is closed to further replies.

trizerticus

JS/Ajax Problem

Recommended Posts

trizerticus

I submitted a previous post and the overall standing was that I must be having a JS/AJAX problem because nothing would change when you attempted to save the settings. I am still having this problem, and would like help with a solution.

 

website: http://crbs.ic2bm.com 

 

already went into the JS Console and it stated there was a AJAX Error but disappeared before I could read the Error

I am using chrome so any solutions on how to fix the ajax problem would be great.

 

thanks.

Share this post


Link to post
Share on other sites
greenfly

Can we have a link to your previous topic please? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
trizerticus

Here is the link:
 

http://forum.pagelines.com/topic/33629-help-dms2-problems/

 

also to note: I have used two different computers, both with the most current version of chrome installed and yet 

neither one will allow saving so it can't be on my computer side.

 

The Server is Windows 2008 w/ all current updates installed

 

Running: IIS

PHP Version: 5.3

MySQL Server 5.1

 

but if this is a JS/Ajax issue the webserver or PHP or MySQL should not be the source of the problem. Also DMS 1.1.8 is running on another site and JS/Ajax works fine there.

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Is there are a reason as to why you're running a Windows server ? That may be the cause of your issue, have you tried to so the same on a linux server ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
trizerticus

First of all the issue should not be a Server issue, whether its Windows or Linux, the issue here is a JS/AJAX which if I am correct (I could be wrong) is processed and interpreted by the Browser, and not by the server.

 

The other issue at hand is if JS/AJAX opperates with other programs/plugins in wordpress it would appear to me that the issues "might" lie within the program itself (i don't know, i am not a programmer).

 

in my previous article you asked the following question:

http://forum.pagelines.com/topic/33629-help-dms2-problems/

 

What is that themepunch error, that is not related to DMS?

and so I went and did a search for the file and it was located in

the jquery.themepunch.revolution.min.js is located in the "themes\dms\sections\revslider\rs-plugin\"

 

I use Windows Server because there are other programs (that are not connected with iis) that are running on the Server.

 

I am not trying to be a problem person, just trying to find a solution to my problem. Thanks

Anthony

Share this post


Link to post
Share on other sites
trizerticus

So, I am guessing by the lack of response to my request is that

 

#1 because I am using a Windows server EVEN THOUGH WORDPRESS WORKS AND UTILIZES JS/AJAX on Windows Server you are not going to provide technical support even though it is your theme that is the problem here. You cannot have JS/AJAX work in one program i.e. Wordpress, and then turn around and tell me that because i am not using Linux that is the reason that your THEME a.k.a DMS2 doesn't work.

 

#2 If DMS 1.1.8 works just fine in a Windows 2008 Server \ Wordpress \ PHP \ MySQL install, and then all of the sudden stops working in DMS 2.0  this cannot be a Server or even a Wordpress related programming issue, but rather some unknown bug in DMS2

The fact that DMS2 might have a bug is not an end all, bugs happen, but the issue here is are you willing to find where the bug is and try and find a solution.

 

I Like DMS I do not want to have to abandon it, and I shouldn't have to. If Wordpress can work on both a Linux and a Windows enviroment, then your program ought to be able to work also.
 

Share this post


Link to post
Share on other sites
James B

FYI for anyone following this thread, an update has been released which to fix the LESS/editor saving issues people were reporting on other threads. Please update to 2.02 to see if this resolves the issues you're experiencing.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using a plugin called Speed Booster Pack to speed up the load time of michaelkummer.com. One of the plugin settings, Minimize HTML and JavaScript causes an error that I only get with Pagelines. With other themes, such as WordPress' Twenty Seventeen, I do not get that error.
      I have reproduced the problem on my staging site and if you look at the JavaScript console, you will see the following error:
      SyntaxError: Unexpected end of script
      Any clue what PageLines may be doing differently to be contributing to this issue? I contacted the plugin developer and they, of course, pointed me to the theme developer
      Thanks
      Michael
    • flourishdesignstudio
      By flourishdesignstudio+
      Hello,
      We are working on a site and the customers are complaining that the site loads too slowly. They contacted their host who mentioned that the Java Script is all loading at the beginning. Is it possible to delay the load of the less important Java Script until after the initial load to speed up the site? The goal is to load the page faster by minimizing the initial javascript calls.
      Are there any preferred plugins that you would recommend or does this end up causing excessive problems with plugins, etc.?
      Thanks for the help!
    • chamois_blanc
      By chamois_blanc+
      I am trying to clone a container on a page. It throws the following javascript error:
      function l(b, c, e, f) { var g = m.a.f.get(b, p); if (!c) { if (g) throw Error("You cannot apply bindings multiple times to the same element."); m.a.f.set(b, p, !0) } I would appreciate guidance and a fix. Thank you
    • Jeremiah
      By Jeremiah+
      Error: editing.js?ver=930684:5 Uncaught TypeError: Cannot read property 'getData' of undefined
      I have all of the plugins disabled and I still receive the error.
      Page Editor will not load on page.
       
    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
×