Jump to content


This topic is now archived and is closed to further replies.


DMS2 support for Link Post Format

Recommended Posts


I saw that DMS2 suppports Post Formats now. However, I'm not seeing that it supports the Link format. Is that the case? If it doesn't support that particular format, does anyone know how I might add that support. I would like to be able to add a title and a link, set the post format to "Link" and then have that title URL go to the external page instead of the internal post.


sort of like what is described in the wordpress codex: 

  • link - A link to another site. Themes may wish to use the first <a href=””> tag in the post content as the external link for that post. An alternative approach could be if the post consists only of a URL, then that will be the URL and the title (post_title) will be the name attached to the anchor for it.


Share this post

Link to post
Share on other sites

I presume you mean that you want to have a link on you latest post page looking like the one on the DMS blog: PageLines DMS is changing the way people built websites.


In your Wordpress CMS, just choose the format and enter your URL in the "link settings" below the post content area

[attachment=2106:Post link Wordpress CMS.jpg]


This will result in this appearing wherever you display your latest posts and will open the link...

[attachment=2072:Post Link on Blog.png]

Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post

Link to post
Share on other sites

Thanks for your input GetMeWebDesign

Please search our forums, before posting!

Share this post

Link to post
Share on other sites

Thanks GetMeWebDesign after a bit more playing around I discovered that my problem was that I had switch back to the Legacy Mode for the post loop (per just about everyone here at Pageline's suggestion) so I wasn't seeing that new formatting because the legacy mode doesn't support what you showed.


So now I'm stuck between wanting the ability to configure my post loop display with any reasonable amount of flexibility or having the new post format support. 



Share this post

Link to post
Share on other sites

Hello @williamweber 


As per my previous update on your previous post regarding the post loop and what you want to see please be assured i have noted this and will pass on the concerns and suggestions to the core team. Anything else from yourself or anyone else please let me know. 


you are free to email FAO Martin on hello at pagelines dot com. 

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 


Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post

Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please?