Jump to content

Archived

This topic is now archived and is closed to further replies.

sheilahoff

No longer opening in Chrome

Recommended Posts

sheilahoff

I'm going crazy trying to troubleshoot this. I've tried a lot of different stuff. I've deactivated plugins, cleared caches and even tested the site on a staging server. It all works there but apparently they have different server configurations which I'm trying to get info on now.

 

I think I have two separate but possibly related issues going on. I don’t know what Pagelines DMS requires for the front end (jQuery or javascript of some such) but that seems to be blocking its use. I say this because I have a WooCommerce site that uses a multi-select drop down for choosing the product and when you choose the date the add to cart button is supposed to display but it does not. I was trying to troubleshoot that when I discovered I can't access the site in DMS. Then I tried another DMS site with the same plug-in configuration and the add-to-cart buttons work fine (but they're simple 1-item buttons not the drop down). But I cannot access that one in DMS either. I tell you all this because I think there's some connection.

 

Meanwhile, I captured the Chrome errors when DMS doesn't come up. It means nothing to me but I'm hoping it helps someone help me.

 

Consider using 'dppx' units instead of 'dpi', as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: (-webkit-min-device-pixel-ratio: 2), (min-resolution: 192dpi) (index):1
Failed to load resource: the server responded with a status of 404 (Not Found) http://www.solsara.net/wp-content/plugins/woocommerce/assets/js/jquery-cookie/jquery.cookie.min.js?ver=1.3.1
Uncaught TypeError: Object function (e,t){return new x.fn.init(e,t,r)} has no method 'cookie' cart-fragments.min.js?ver=2.1.6:1
event.returnValue is deprecated. Please use the standard event.preventDefault() instead.

What’s baffling me is that my DMS sites that do not have the Ai1EC and WooCommerce plug-ins configuration open up fine in Chrome with W3TC running. But even with it turned off it doesn't fix the issue on the sites that have Ai1EC and WooCommerce running.

 

Any insights other than to turn off the two plug-ins? These were all working fine until we started making a lot of server changes due to brute force attacks. We had to upgrade to a dedicated server then made htaccess changes and locked down htaccess, etc. So there are too many moving parts!

 

Thanks for any insights to help point us in the right direction as we sort this all out.

 

Sheila Hoffman

WP 3.8.1 & DMS 1.1.8

 

PS: just to be clear when I say won't open in Chrome, what I mean is that when logged in I can see the Dashboard but when I go to the front end DMS doesn't come up, it just spins and I found the above error. When not logged in... no issues coming up in Chrome. And DMS works in the staging environment with a clone of the site!


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
greenfly

Have you tried updating to DMS 2 in a dev environment to see if this fixes these issues? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
sheilahoff

I have not. However the dev environment I use is WPStageCoach and the site already works over there (different server environment). Also I've tried upgrading 3 of my 4 DMS sites in the dev environment and not one of them just "works". They each need custom work to fix the nav bar and/or other things. So Adding DMS2 upgrade this this puzzle seems like a bad idea at the moment. I noticed someone else also posted they can't get into DMS in Chrome today also. Makes me wonder if it's something in the last DMS upgrade within v1.

 

Can you address exactly what requires for the front end (jQuery or javascript of some such)? I somehow think that's related due to what's also happening with the WooCommerce drop downs.

 

Thanks,

Sheila


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
greenfly

The other poster had the preview button depressed. Not an 'issue' other than they had selected an option themselves. 

 

Does the front end come back when woo is disabled? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
sheilahoff

I foolishly had not yet tried that. But yes, indeed, DMS returns with WC disabled. But that is not an option so we need to figure out WHY...what happened in their last update!


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
greenfly

Best bet is to report this to Woo and i will mention this to the devs at the first opportunity for you - i will update you here if you could do the same for me :) 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
sheilahoff

I’ve found the solution here http://docs.woothemes.com/document/jquery-cookie-fails-to-load/ which is a mod-security fix. I’ve asked my host to remedy it. I’m looking forward to putting these sites right again that use both WC and DMS.

WHEW!!!!

Thanks for being an ear during my process.

 

Sheila


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
greenfly

Thanks for letting us know the fix, this will help in future. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
sheilahoff

You're welcome. My host hasn't made the change yet but I tried the WC plug-in fix available at the above link on a dev site on the same server and it DOES fix the problem. It's such a relief.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
greenfly

oh good news. it has been noted in my book of fixes for future reference


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

  • Similar Content

    • mundocaco
      By mundocaco+
      Hello, inexplicably few signs have appeared at the beginning of each excerpts, removing the option these signs disappear, but appear when I activate it again. You know why happen this?.
       
      Yo can see online here: http://www.latitudestudio.eu/press-news/ 
       
       
    • dherries
      By dherries
      I am trying to add a widgetizer to my page/post and the system does not let it drag. The system creates  large Widgetizer logo and nothing will happen. What am I doing wrong?  I am using DSM 1.1.9.  Website is www.moveincache.com
    • mundocaco
      By mundocaco+
      Hello everyone. :)   Is possible set a selected Section Area to height of window browser with custom CSS, just like DMS2 presets? Someone knows some best practice?   I know how to set to fixed footer, but i think this case of study is different.   Thanks!
    • webmktco
      By webmktco
      Website URL: http://www.schrumpfdds.com/
      Framework Version: DMS 1.1.9
      WordPress Version: 4.1.1
       
      I noticed that the Font Awesome version in my theme is 3.2.1.
       
      Can you tell me how I can update the FA version? Or is that not possible?
    • pazyluz
      By pazyluz+
      I have pages that display on phones and pages for desktops/laptops.  The ipad displays the mobile/phone pages but would look far better if they displayed the desktop version.  How/Can I display the desktop version on ipad?  If I cannot do that, can you advise me as to the best course of action?  Thank you.
       
      http://peggygreen.net
×