Jump to content

Archived

This topic is now archived and is closed to further replies.

mrmiyamoto

Themes don't apply to full-width NavBars

Recommended Posts

mrmiyamoto

Website URL: http://beta.animemovieguide.com
Framework Version: 2.0
WordPress Version: 3.8.1
Server/Host: Midphase

 

Details:

My full-width NavBar from 1.1.8 was replaced by a Navi when I switched to 2.0.  Now I have one placed back on top of the Navi, but no matter which theme I try to change it to it doesn't actually change the navbar's styling.  Navbar themes are still working on content-width navbars, but not on full-width ones.

Share this post


Link to post
Share on other sites
greenfly

The navbar on top with the green arrow pointing to it in the screenshot - is this the navbar you want to change the style of? this is the fixed navbar. http://screencast.com/t/0BxdUo56


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
mrmiyamoto

The navbar on top with the green arrow pointing to it in the screenshot - is this the navbar you want to change the style of? this is the fixed navbar. http://screencast.com/t/0BxdUo56

 

Yes, the theme of it is currently set to "Blue" to no avail.

Share this post


Link to post
Share on other sites
Danny

Would it be possible for you to record the issue please using the free application Jing.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon
Known issue it's already fixed ;)


Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites
mrmiyamoto

Known issue it's already fixed ;)


Sent from my iPad using Tapatalk

 

Alright, cool.  So are there nightly builds of DMS somewhere or am I just going to have to wait around for 2.0.1?

Share this post


Link to post
Share on other sites
Danny

There are, but they're no longer public I'm afraid.

 

Below is the commit that resolves the issue, if you wish to include the fix please follow the instructions below:

 

1. Using an FTP client, navigate to /sections/navbar

2. Open up the sections.php file in a code editor

3. Navigate to line 138, you should see the following line of code:

$theme = ( $this->opt( 'navbar_theme' ) ) ? $this->opt( 'navbar_theme' ) : false;

4. After that add the following:

 

if( is_array( $theme ) )
$theme = reset( $theme );

5. You should end with it looking like this:

 

$theme = ( $this->opt( 'navbar_theme' ) ) ? $this->opt( 'navbar_theme' ) : false;


if( is_array( $theme ) )
$theme = reset( $theme );


$align = ( $this->opt('navbar_alignment' ) ) ? $this->opt( 'navbar_alignment' ) : false;

once added, save the file and this should resolve your issue. Please before a backup before proceeding just as a precaution.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
mrmiyamoto

Thanks Danny that did the trick.

Share this post


Link to post
Share on other sites
Danny

Cool and no problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Lisa Haran
      By Lisa Haran+
      Hi 
      I have a map here http://www.iloveoffset.com/maps/
      I want to add several pointer locations to the map, but when I do they do not appear.
      On this map there are 2 pointer locations and as you can there is only one visible.
      Earlier today I added 7 and could only see 4 so there is something odd going on.
      My theme is up to date
    • clj182
      By clj182+
      Hello,
      I've been having trouble unlocking the template section for past couple of weeks. When I try clicking nothing happens. 
      I've deleted my custom css and removed plugins. Im down to having only the following plugins:
      Akismet
      Contact Form 7
      DMS Professional Tools
      Pagelines Updater
      WooCommerce
      It was working fine before i have no idea what's going on with it.
    • flourishdesignstudio
      By flourishdesignstudio+
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio+
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • nizami
      By nizami+
      Using navbar section with correctly configured WP menu to display main navigation at https://elenaangel.com. 
      All fine in desktop viewport. Menu displays twice in hamburger mode. How to fix this please? 

×