Jump to content

Archived

This topic is now archived and is closed to further replies.

webmktco

Google Authorship issue- showing up on every page

Recommended Posts

webmktco

http://www.prosthodonticassociates.com/

Debug: http://www.prosthodonticassociates.com/?pldebug=1

DMS 1.1.8

WP 3.8.1

 

HostGator
======

 

I'm trying to figure out why each page of the website has authorship enabled.  I'm using Yoast SEO, but the authorship is coming from outside of the Yoast code. 

 

See line 70: http://paste.pagelines.com/xV1gnFBV

 

2014-03-23_18-09-25.png

 

In the Yoast SEO plugin I've designated that I only want authorship on the home page and all posts, not every page.  As you probably know, we're not supposed to have authorship on every page- according to Google.

 

 

Share this post


Link to post
Share on other sites
Simon

http://www.prosthodonticassociates.com/
Debug: http://www.prosthodonticassociates.com/?pldebug=1
DMS 1.1.8
WP 3.8.1
 
HostGator
======
 
I'm trying to figure out why each page of the website has authorship enabled.  I'm using Yoast SEO, but the authorship is coming from outside of the Yoast code. 
 
See line 70: http://paste.pagelines.com/xV1gnFBV
 
2014-03-23_18-09-25.png
 
In the Yoast SEO plugin I've designated that I only want authorship on the home page and all posts, not every page.  As you probably know, we're not supposed to have authorship on every page- according to Google.


Did you add your google ID to your WordPress user profile? If so thats why its in the pages.

It only displays on pages and posts if the page/post author has his google id set in wordpress profile.

Share this post


Link to post
Share on other sites
webmktco

Yes, I added the link to the Google+ profile in the user settings- but that's the correct way to do it.  

 

When I enable the 2014 theme, this issue goes away.  It only happens when the DMS (child theme) is active.

Share this post


Link to post
Share on other sites
Danny

Well that code is your Author link, so its not part of DMS. Have you added your Author details anywhere else ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon
No Danny, DMS adds the google author area o your WordPress profile, then adds the snippet to any page or post that you have authored.
If you dont want the code there, then remove the author url from your profile.

Share this post


Link to post
Share on other sites
webmktco

If this is the case, I strongly urge PL to remove this feature.  

 

This is not how Google Authorship is supposed to be used.  

 

I've committed my agency to use DMS 100%, but these little things will make us look in a different direction.

 

Can we get this resolved ASAP?
 

Share this post


Link to post
Share on other sites
Simon
You keep saying that it is not how it is supposed to be done. How is it supposed to be done then?

I was under the impression when we added this feature ( about 3 years ago ) that if a page is by an author, you show the author meta so google knows who wrote the page.

Share this post


Link to post
Share on other sites
myuntangledmedia

Jumping in here as I've also been trying to solve this issue for a couple of clients. In terms of this not being the way it should be done, the explanation is that Google will penalize sites that serve up authorship this way. Authorship should only ever be served on blog pages or perhaps some other particular pages the author has written. Home pages with authorship enabled will suffer greatly so having DMS take over control of this feature in this manner is going to cause every site built on it to lose ranks in Google and I'm sure that was not the intention! The best course of action would be to take all of that code of out DMS and let us handle authorship ourselves.

 

Hope that helps!


Jacob Clayton

Chief Geek and PageLines Lover @ MyUntangledTM Media, LLC

Bloggin' @ MyUntangedLife.com

Share this post


Link to post
Share on other sites
Danny

Where is this information that you will be penalised if it is active on all pages ? 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Simon

Jumping in here as I've also been trying to solve this issue for a couple of clients. In terms of this not being the way it should be done, the explanation is that Google will penalize sites that serve up authorship this way. Authorship should only ever be served on blog pages or perhaps some other particular pages the author has written. Home pages with authorship enabled will suffer greatly so having DMS take over control of this feature in this manner is going to cause every site built on it to lose ranks in Google and I'm sure that was not the intention! The best course of action would be to take all of that code of out DMS and let us handle authorship ourselves.
 
Hope that helps!


Not really. As I have already said twice now in this thread. The authorship meta is only displayed if the page/post has an author and that author has set his google url in his profile.

Here is the block of code that adds the link, as you can see if it isnt a page, or a post or an author archive, nothing is displayed. It then takes the google profile link from the page/post author meta..

 

https://gist.github.com/Pross/9739870

Share this post


Link to post
Share on other sites
Simon

OK a quote from that blog:

In short, Google+ authorship should be used only on blog posts and other individually-authored content on websites -- and not on home pages, product pages, informational pages, contact pages, and so on.

And a quote from me 2 minutes ago.

The authorship meta is only displayed if the page/post has an author

Please explain the difference here.

 

(ps I have no idea what a dental vertical is, but it sounds painful)

Share this post


Link to post
Share on other sites
webmktco

SImon,

 

Short answer- for sites with 1 author, Google doesn't want you to include authorship across the board on all pages/posts.

 

My method is to only have authorship setup on the home page and posts.  No authorship on the About Us, Contact, etc pages.  

 

(PS- I was trying to state that I specialize in SEO for the dental industry.  Sorry for the jargon ;-)

Share this post


Link to post
Share on other sites
Simon

Ok but that blog said not to have it on the home page, i'm no seo expert either ;)

 

If you want the authorship on specific pages then id suggest removing the url you put in the wordpress profile and using a plugin to insert it where you need it.

Share this post


Link to post
Share on other sites
Simon

Short answer- for sites with 1 author, Google doesn't want you to include authorship across the board on all pages/posts.

Can you provide your source of this information, for other users?

Share this post


Link to post
Share on other sites

  • Similar Content

    • souleclipse
      By souleclipse
      Remember to include as much information about your technical issue as possible for example:
      Website URL: http://bit.ly/18XqeEh
      Framework Version: Latest
      WordPress Version: Latest
      Plugins in Use: Akismet, Authorsure, broken link checker, dms tools, google xml, login lockdown, seo friendly images, seo search tagging, sharethis, slick social share, w3 total cache, wordpress seo by yeost.
       
      After i successfully link in the google authorship.
      I went to test on http://www.google.com/webmasters/tools/richsnippets 
      It show all verficiation is success. 
       
      http://imgur.com/Zd7nTdX
       
      hatom-entry:   Error: At least one field must be set for HatomEntry. Error: Missing required field "entry-title". Error: Missing required field "updated". Error: Missing required hCard "author"     Kindly advice on the error.

      Thanks! 
×