Jump to content

Archived

This topic is now archived and is closed to further replies.

sticktrix1

DMS Doesn't work with FORCE_SSL_ADMIN', true

Recommended Posts

sticktrix1

Hi guys, whenever i enable in wp-config.php the line       define('FORCE_SSL_ADMIN', true);       pagelines ceases to work.. It will load the page, but i can't drag n drop anything?

Turning this off fixes it instantly. What's goin on and how do i/you fix this?

Cheers guys

Share this post


Link to post
Share on other sites
James B

Hi Casey

 

Have you tried the solution with the filter offer on Clifford Paulicks site - http://www.pagelinestheme.com/pagelines-dms-ssl-https/ its available as a plugin which might be able to resolve the issue you're having.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
sticktrix1

Yes i tried this but  didn't resolve the issue unfortunately.

Share this post


Link to post
Share on other sites
sticktrix1

Okay i added this line in and it's now working.... 

Is this line okay to use? What does this actually do?

add_action('wp_ajax_nopriv_pl_editor_actions', 'pl_editor_actions');

Share this post


Link to post
Share on other sites
James B

In the comments of that plugin it says that if PL DMS Editor won't save changes on a site with SSL to use that code. Looking up wp_ajax_nopriv in the wp codex it seems to be related to forcing the editor to load on the front end. See http://codex.wordpress.org/AJAX_in_Plugins the section call 'ajax on the viewer-facing side'.

 

I've copied in Clifford P who made the plugin in case he can advise further on the above.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
sticktrix1

It's not working again.... 

Shouldn't the Pagelines editor be able to work with Basic Wordpress SSL functions? 

Could you guys make a native fix for this for the next release?

SSL and security is a really important thing.. and if i can't enforce that on the admin panel OR login it spells BIG troubles.

Share this post


Link to post
Share on other sites
Danny

How have you setup your SSL ? We have a number of users as far as I know, who use SSL and have no issue with DMS.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sticktrix1

I'm running a wildcard ssl installed on the server. It's on a multisite setup. Everything else works fine as well. Tried it with and without the wordpress https plugin and still no go.

Share this post


Link to post
Share on other sites
Guest

sticktrix1, you can solve the problem by switching to just SSL login instead of SSL admin, but if you really want SSL admin, then I'd recommend reading the plugin's code. You might want to uncomment some of the commented parts, or you may need to modify it to work for your setup. Run that CURL code at the bottom of the link to test. If you can't get it figured out, you can try to get more help from PageLines for your specific setup, or you can send me a PM if you're interested in hourly services to debug and resolve. Hopefully you get it figured out very soon on your own. Best to you.

Share this post


Link to post
Share on other sites
sticktrix1

This problem is still on DMS 2.0

Even with all plugins deactivated on the subsite and network, SSL doesn't work.. Sections aren't saving?

Share this post


Link to post
Share on other sites
Danny

Can you contact our helpdesk with following please:

 

Your sites admin username and password.

A link to your site.

DMS Debug mode enabled ~ DMS Toolbar > Settings > Advanced.

A link to this topic, so our staff have a reference.

 

hello at pagelines dot com


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
MrFent

I'm having the same issue. was this ever resolved?

Share this post


Link to post
Share on other sites

  • Similar Content

    • Bleuy
      By Bleuy+
      How can I get support on pagelines DMS? The product isn't that old and my skeleton themes aren't working and I can't get support in the same way? 
    • Bleuy
      By Bleuy+
      I have a number of legacy websites that are running on the above version of Pagelines DMS, where the template has stopped working. I am using a skeleton theme to all of them. What do I need to do to rectify this.
       
       
    • Anthony King
      By Anthony King+
      It is with much sorrow that I have to say goodbye to a product that had such great potential.
      There has been no acknowledgement from anybody as to whether or not Pagelines will continue
      or even if they are going to hand it over to someone that would keep the project going. I can't
      keep shelling out money every month to a company that either no longer exists or has chosen to 
      abandoned their customer base. Well it has been a nice 5 years.

       
×