Jump to content

Archived

This topic is now archived and is closed to further replies.

Gonchar

My custom css disappear

Recommended Posts

Gonchar    1
Gonchar

Hi!

 

My custom css disappear

 

What should i do?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

Css will disappear if it was incorrect or not saved properly. You'll need to provide us with some more information, what css did you have in place? Where was the css added, to the custom panel or via the base theme etc?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
Gonchar    1
Gonchar

Hi, James!

 

"what css did you have in place?"

 

.page-id-2 {

  #header,#footer {

    position:absolute;

    left:-10000px;

    height:0;

  }

  &.drag-drop-editing {

    #header,#footer {

          position:static;

          left:0;

          height:auto;

    }

  }

}

 

.page-id-1899 {

  #header,#footer {

    position:absolute;

    left:-10000px;

    height:0;

  }

  &.drag-drop-editing {

    #header,#footer {

          position:static;

          left:0;

          height:auto;

    }

  }

}

 

.page-id-1926 {

  #header,#footer {

    position:absolute;

    left:-10000px;

    height:0;

  }

  &.drag-drop-editing {

    #header,#footer {

          position:static;

          left:0;

          height:auto;

    }

  }

}

 

.page-id-1929 {

  #header,#footer {

    position:absolute;

    left:-10000px;

    height:0;

  }

  &.drag-drop-editing {

    #header,#footer {

          position:static;

          left:0;

          height:auto;

    }

  }

}

 

.jgBackgroundColour-grey { background-color: #F2F2F2; }

.jgBackgroundColour-maroon { background-color: #005eff; }

.TextColour-maroon { color: #005eff; }

.TextColour-444444 { color: #444444; }

.TextStyle-555555 { face="Trebuchet MS"; color=#555555 }

.TextStyle-White { face="Trebuchet MS"; color=white }

Share this post


Link to post
Share on other sites
Gonchar    1
Gonchar

the css was added, to the custom panel

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

As far as I am aware the following isn't going to work.

 

.TextStyle-555555 { face="Trebuchet MS"; color=#555555 }
.TextStyle-White { face="Trebuchet MS"; color=white }
 
face=
color=
 
Why do you have that ?

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Gonchar    1
Gonchar
What's wrong exactly, and what should i do?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

well you can't use face= or color= thats not valid CSS.

 

http://www.w3schools.com/cssref/pr_font_font-family.asp

http://www.w3schools.com/cssref/pr_text_color.asp

 

Those are the correct way to add color and font family values. In regards to font family you could use a mixin, to make life a little easier.

 

http://www.sitepoint.com/a-comprehensive-introduction-to-less-mixins/


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Gonchar    1
Gonchar

Hi, Danny!

 

Thanks for useful information!

 

I've deleted incorrect css

 

but css disappear persists unfortunately

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Can you record your issue please, using an app such as Jing.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Could you create an admin logon for your site and send the credentials to hello at pagelines dot com and we will jump on and take a look for you. Please include a link tot this topic


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
John Olsson+    8
John Olsson

I have the same problem, and even with just small code in the custum css, it sometimes dissapear, sometimes it coming bland, sometimes it's blank. Don't get, must be som kind of bug?

Share this post


Link to post
Share on other sites
John Olsson+    8
John Olsson

I can't open the link?

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Danny was referring to the issue currently recorded on the issue tracker for DMS 2 in GitHub that is currently being investigated, 

 

Basically, changes to CSS are not being saved or not updating. 

 

Is this the same issue? 

 

Could you please provide more information regarding what happens for yourself. Also can you provide the steps to recreate this and a link to your site. 

 

Could you activate the PageLines Debug in Site Settings > advanced. 

 

Also if you could provide a link to your Custom CSS code via the pastebin system at the top of this post and provide a link - alternatively the link to the pastebin is here http://forum.pagelines.com/pst/


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
John Olsson+    8
John Olsson

I'll come back to you hopefully during the next day with more info, and it also not just saving the custum css, it also saves it sometimes, and after a while, an old version of the css shows up again, even when i've cleared the custum css, both from back-end and front-end.

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

John Olsson

 

Sounds like the same issue - thank you for letting us know. No more need for any other other just the other steps int he last post would help us out :)

 

a link to your site. 

 

Could you activate the PageLines Debug in Site Settings > advanced. 

 

Also if you could provide a link to your Custom CSS code via the pastebin system at the top of this post and provide a link - alternatively the link to the pastebin is here http://forum.pagelines.com/pst/


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
GetMeWebDesign+    115
GetMeWebDesign

John Olsson. Cant guarantee this will work, but I had the same issue. If any page was not allocated a template then wouldnt save CSS or clear old or save changes. Once I made sure all pages had a template assigned (and that included some of those like "tags", "categories" "404", "Search" etc) then it all sorted itself out. 

 

Hope that might be of some help?


Chrome Developer tools - please use them. If you are not sure how, then it is easy to learn

Be inventive in your keyword search of the forum ie Navi > Navbar > menu > tabs > font > color. Your answer lies there somewhere!

Share this post


Link to post
Share on other sites
Gonchar    1
Gonchar

My custom css disappear agan from front-end editor and even from section and modul css area cleared. ((((((

 

Can i save my css at special file? and how to do it?

 

i mean tell me please secure and 100% safe method of css formatting!

Share this post


Link to post
Share on other sites
John Olsson+    8
John Olsson

Gonchar, you just save the css in your custum css-file, "style.css" in you dms-child-theme, then it's safe.. But you can't work in the front-end at the same thing.. Och just work in the front-end, and copy-paste the code into style.css. Ok?

Share this post


Link to post
Share on other sites
John Olsson+    8
John Olsson

Martin Davies"], its just like @[member="GetMeWebDesign says, as long as you have an assigned template to you page, there's no problem, but for example, if you have the start-page set to "my latest post" and have no template assigned, then it seems to fetch som old css-files.. Some kind of bug, clearly! :)

Share this post


Link to post
Share on other sites
Simon    247
Simon

Martin Davies"], its just like @[member="GetMeWebDesign says, as long as you have an assigned template to you page, there's no problem, but for example, if you have the start-page set to "my latest post" and have no template assigned, then it seems to fetch som old css-files.. Some kind of bug, clearly! :)

This was fixed, upgrade to latest version.

Share this post


Link to post
Share on other sites
John Olsson+    8
John Olsson

I have the latest one.. Tried on another site.. But didn't help there, same problem, often de old css is stuck on the startpage and reveled on a sub-page, but you still can't edit it.. It goes back to the old css-code..

Share this post


Link to post
Share on other sites
Simon    247
Simon

Your private support url isnt even a PageLines product, unless you provide some kind of url we are helpless.

Share this post


Link to post
Share on other sites
John Olsson+    8
John Olsson

No ofc, only having the sites local right know, but still I can mention the problem, just as I did, as soon as get the time i'll put a site online that have the problem.

Share this post


Link to post
Share on other sites

  • Similar Content

    • sfmstudios
      By sfmstudios+
      I'm using the boxes section on a local development site to play around with some options, and running into an issue.  
      Have the following settings for the boxes:
      Type: Images/SVC Media on Top Image Appearance: Standard/Default Image/Icon Width: 280px Image Opacity: 100% Each of my box images is 280x150 in size, but the result of the image on the box is a strange zoomed-in, cropped square (see attached).  I looked to adjust border properties via CSS, but couldn't find a fix.  What solutions are out there?

    • paoloimperiale
      By paoloimperiale+
      Hi, 
      I was wondering if there's a way to modify the slider container size? My client would like it skinner- not as tall. How would you suggest doing that?
      Thank you.
      (this is for the paoloimperiale.com slider on the homepage) 
    • flourishdesignstudio
      By flourishdesignstudio
      My DMS 2 site http://www.heart-stone.com/ will not save any new custom css... I can still edit templates and publish those but any custom css that I enter never saves.
      All WP files, themes, and plugins are up to date. 
      Any thought about what might be causing this?
    • flourishdesignstudio
      By flourishdesignstudio
      Is there a way to edit the custom CSS via FTP? I know I can edit the custom code in the Chrome editor but is there a file path I can use to find and edit the CSS directly from our FTP?
      Thanks in advance for the help!
    • jeomiland
      By jeomiland+
      What am I missing?
      at cassclayton.com/dev I have the main  area set as 2 column format in the content-width main area. When I drag a 2-columns section onto the page under the stuff in the main left column area I get that familiar "section added, refresh page to view..." message on the screen, but refreshing the page (cmd-r or browser refresh button) makes the newly added section disappear to I can't get to it to continue.  Have just tried several time today with no success.  Have had this sort of issue before. I don't consider the page layout to be that complex, so why is DMS not remembering the new columns section on refresh?  Is there some strange, exotic setting in my browser I need to tweak? (chrome 46.0.2490.80 Macbook pro)
      Also, I have this Alzheimer issue often when adding custom CSS code - I learned from Pagelines academy to click edit in an existing section, then click in 2 different text option boxes, which eventually causes the refresh icon in the DMS options panel to appear) but even then, sometime my css code is ignored and I have to add it again and eventually it gets updated. I know, I know - blame it on all the script that makes the interface work, but this really slows down my development time. Someone please tell me I'm missing some simple thing that makes all this refresh stuff work like a champ!
      1) what is best way to Refresh after adding something if the Refresh icon does not appear (as it hardly ever does when adding CSS code)?
      2) why does my new section disappear on refresh?
      3) what's the best way to create a 2-column content area within another column area?
      Site: cassclayton.com/dev
      Thanks
×