Jump to content

Archived

This topic is now archived and is closed to further replies.

reidwalley

How do I get Sharebar social media icons to be HTTPS secure?

Recommended Posts

reidwalley

Hi,

 

Our whole site is HTTPS secure. The Sharebar displays as non-secure under HTTPS.

 

Is there a way to make the Sharebar social media icons secure? Maybe something I can put in functions.php? Or something I can add to a Child Theme Sharebar section?

 

Thanks.

 

 

WordPress: 3.8.1

PageLines Framework: 2.4.4

URL: https://www.metrosonic.net

Share this post


Link to post
Share on other sites
Danny

Hi,

 

How have you setup your SSL ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
reidwalley

Hi Danny,

 

1. SSL is set up through RapidSSL on our host's server.

2. WordPress admin General Settings is set to HTTPS for the site's WordPress Address and Site Address.

3. So the whole site is HTTPS.

 

4. To functions.php, I added the below code, which comes from: "PageLines SSL: Force LESS CSS and Other Assets to Load via HTTPS"

(From http://v2.pagelinestheme.com/161; and the original article is from: http://forum.pagelines.com/topic/20593-https-issue/?p=120071)

add_action( 'pl_force_ssl', '__return_true' );

add_filter( 'pless_vars', 'make_ssl_vars' );
   function make_ssl_vars( $vars ) {
       $vars['plSectionsRoot'] = str_replace( 'http://', 'https://', $vars['plSectionsRoot'] );
       $vars['plRoot'] = str_replace( 'http://', 'https://', $vars['plRoot'] );
       return $vars;
   }

Thanks.

Share this post


Link to post
Share on other sites
James B

Hi there, we checked this with our Developer who said that the url's for the buttons in that section is hardcoded, at the time of writing the section there were not https versions. This will be correct in version 2.0 which is coming soon, in the meantime they've advised copying the sharebar section into your child theme and editing the urls directly inside the section code.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • israelgenealogy
      By israelgenealogy
      I have an old PageLines site that I recently got working with SSL, but there are mixed content errors. There are two problems I've found. One is the search button icon called from forms.less:
      url(@{plRoot}/images/search-btn@2x.png)
      The second is when PageLines loads FontAwesome from icons.less:

      url('@{iconFont}.eot?v=3.0.1');

      Where is similarly loads the font using http. Any idea why these are loading using http instead of https, and is there a simple way to fix these? I know I need to upgrade the theme, but it's a major project, so for the moment I'd just like to get these secured before taking on switching themes/frameworks.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • arno
      By arno+
      The counter next to the icon in the Sharebar extension adds more mess than value for us. 
      Is there an easy way/code to hide the counter? (so that the icons line up closer?)
    • bnapoli
      By bnapoli+
      Is there an easy CSS fix to change the social media icons in Sharebar so they are colored, not just on hover?
×