Jump to content

Archived

This topic is now archived and is closed to further replies.

reidwalley

How do I get Sharebar social media icons to be HTTPS secure?

Recommended Posts

reidwalley    1
reidwalley

Hi,

 

Our whole site is HTTPS secure. The Sharebar displays as non-secure under HTTPS.

 

Is there a way to make the Sharebar social media icons secure? Maybe something I can put in functions.php? Or something I can add to a Child Theme Sharebar section?

 

Thanks.

 

 

WordPress: 3.8.1

PageLines Framework: 2.4.4

URL: https://www.metrosonic.net

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

How have you setup your SSL ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
reidwalley    1
reidwalley

Hi Danny,

 

1. SSL is set up through RapidSSL on our host's server.

2. WordPress admin General Settings is set to HTTPS for the site's WordPress Address and Site Address.

3. So the whole site is HTTPS.

 

4. To functions.php, I added the below code, which comes from: "PageLines SSL: Force LESS CSS and Other Assets to Load via HTTPS"

(From http://v2.pagelinestheme.com/161; and the original article is from: http://forum.pagelines.com/topic/20593-https-issue/?p=120071)

add_action( 'pl_force_ssl', '__return_true' );

add_filter( 'pless_vars', 'make_ssl_vars' );
   function make_ssl_vars( $vars ) {
       $vars['plSectionsRoot'] = str_replace( 'http://', 'https://', $vars['plSectionsRoot'] );
       $vars['plRoot'] = str_replace( 'http://', 'https://', $vars['plRoot'] );
       return $vars;
   }

Thanks.

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, we checked this with our Developer who said that the url's for the buttons in that section is hardcoded, at the time of writing the section there were not https versions. This will be correct in version 2.0 which is coming soon, in the meantime they've advised copying the sharebar section into your child theme and editing the urls directly inside the section code.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • arno
      By arno+
      The counter next to the icon in the Sharebar extension adds more mess than value for us. 
      Is there an easy way/code to hide the counter? (so that the icons line up closer?)
    • bnapoli
      By bnapoli+
      Is there an easy CSS fix to change the social media icons in Sharebar so they are colored, not just on hover?
    • MissT
      By MissT+
      Regarding the 'global option' mentioned by Simon in this previous post (to turn off the facebook opengraph data if you are using another plugin that provides it) ...where is this option? I don't seem to be able to find it.
      Many thanks in advance.
       
    • indesco
      By indesco
      Hi,  I have just switched the site shockwatch.co.nz over to SSL.  I have one remaining mixed content error to solve, but cannot find this link anywhere when I look at the page source so struggling to figure out how to resolve it.  Can you assist at all?
      Mixed Content: The page at 'https://shockwatch.co.nz/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Droid+Sans:regular,bold&v1'. This request has been blocked; the content must be served over HTTPS.
      (index):1 Mixed Content: The page at 'https://shockwatch.co.nz/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?family=Droid+Sans:regular,bold&v1'. This request has been blocked; the content must be served over HTTPS.
×