Jump to content

Archived

This topic is now archived and is closed to further replies.

JasonLA

Upgrading From 1.0.4 to 1.1.8

Recommended Posts

JasonLA

Hey guys,

 

I'm wanting to upgrade to the latest version of DMS but we built our site without using a child theme which has really come back to bite us. Whenever I upgrade DMS our entire site goes blank which I'm assuming is because we didn't use a child theme. Basically all I need to know is this: is there an easy way to move all my customizations over to my Child Theme or am I going to need to hit up our developer to have him help me move it all over? 

 

Thanks,

Brandon

Share this post


Link to post
Share on other sites
Simon

Blank usually indicates a PHP error.

 

Make a full backup, including your database 1st.

 

Then enable WP_DEBUG in wp-config.php and then try the upgrade, the php error will now be revealed.

Share this post


Link to post
Share on other sites
JasonLA

Hey Simon,

 

I've updated to 2.0 now since I wasn't able to get 1.1.8 to work for me with WooCommerce. After installing DMS 2 there were a few slight changes I needed to make such as centering text but the biggest issue seems to be the Shop page is broken. It worked fine on 1.0.4 but for some reason I can't seem to get it working again. I turned on WP debug and deactivated all of the plugins that were causing issues and I was able to get some of the page to display but the products still don't show up. I've been getting this error message from the debug:

 

Notice: ploption is deprecated since version 1.1 of PageLines DMS! Use pl_setting() instead. in /www/wp-content/themes/dms/dms/includes/deprecated.php on line 272 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /www/wp-includes/functions.php on line 3006 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /www/wp-includes/functions.php on line 3006

 

Do you have any idea what I could do to fix that? I tried searching in that file but it doesn't even have the code it's talking about on those lines. 

 

Thanks,

Brandon

Share this post


Link to post
Share on other sites
Danny

Hi Brandon,

 

That error message means you have something that is using deprecated functions. Therefore, you will need to disable all active plugins and see if this resolves the issue.

 

The error is either caused by an out of date plugin or section for DMS. 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
JasonLA

Interesting. So I've been going through each plugin and seeing what ones are causing errors and it seems a majority of them are up to date so I'm not sure what to do to actually fix them. For example, here's an error that I'm getting when I have BuddyPress 1.9.2 activated: Notice: bp_is_page is deprecated since version 1.7 with no alternative available. in /www/wp-includes/functions.php on line 2910

 

I'm not quite sure why I'm receiving all of these errors just from upgrading from DMS 1.0.4. I tried upgrading to 1.1.6 and up and I had the same error messages coming up every time. 

Share this post


Link to post
Share on other sites
Simon

That function bp_is_page() is not included with any version of DMS past or present.

Share this post


Link to post
Share on other sites
JasonLA

Do you have any idea why upgrading DMS would be causing that error to trigger then? I wasn't getting any errors before and as soon as I upgraded I had about 10 plugins causing issues for me.

Share this post


Link to post
Share on other sites
Simon

Well, i assuming you upgraded buddypress? And a plugin you are using is using an out of date function called 'bp_is_page'.

Share this post


Link to post
Share on other sites
JasonLA

Yeah I had everything upgraded. 

 

I had some more time today so I've went through and installed DMS 2.0.2 and I've been slowly figuring out where the errors that I'm getting are coming from. This is the current error I'm getting right now on the front and it seems to be coming from Pagelines:

 

Notice: ploption is deprecated since version 1.1 of PageLines DMS! Use pl_setting() instead. in /www/wp-content/themes/dms/dms/includes/deprecated.php on line 272

 

I'm also getting this error on the backend:

 

Notice: ploption is deprecated since version 1.1 of PageLines DMS! Use pl_setting() instead. in /www/wp-content/themes/dms/dms/includes/deprecated.php on line 272 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /www/wp-includes/functions.php on line 3006 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /www/wp-includes/functions.php on line 3006

 

Any idea what I can do to fix this?

 

I'm also having issues with WooCommerce. The WooCommerce for Pagelines plugin is up to date as is WooCommerce but when it's active it makes the page blank and when it's off I can't add products to my shop page. Has anyone else had this issue or not? 

Share this post


Link to post
Share on other sites
Simon

Looks like a plugin or section or theme you have installed is using ploption() and as the error states it was retired with version 1.1 of DMS.

 

As for the user roles error, could be a plugin causing that.

Share this post


Link to post
Share on other sites
JasonLA

Alright, so I figured out what plugins were causing the other errors. As for the WooCommerce for Pagelines, when only WooCommerce and Woo for Pagelines is activated I'm getting this error from it: Notice: ploption is deprecated since version 1.1 of PageLines DMS! Use pl_setting() instead. in /www/wp-content/themes/dms/dms/includes/deprecated.php on line 272

 

Does that just mean that the developer of that plugin needs to update the plugin? 

Share this post


Link to post
Share on other sites
Danny

WooCommerce for PageLines is a PageLines Framework only plugin, it is not required for DMS, as DMS is fully compatible with WooCommerce.

 

Therefore, you can simply uninstall it as its no-longer required.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
JasonLA

Awesome, so that helps a bit, but I ran into a few more issues with our products and they way they are being displayed on the product pages now. In the past there was a ProductLoop Section in DMS that made everything super clean and professional looking, in the new DMS, I no longer have that option and it's throwing everything way off on the product pages. It appears that that option was coming from the Pagelines for DMS plugin, is there any way to keep that type of option available so I don't have to have our dev go through and recode everything to work again? 

Share this post


Link to post
Share on other sites
JasonLA

So I've been experimenting again and it turns out that for some reason, the way that it's set up now with the Contest Post/Loop section showing the product, the custom CSS isn't effecting it like it did when it was using the sections made available by the Pagelines for DMS plugin. Any idea why that would be happening? I checked our live site and removed all the custom CSS and it looked identical to the product page on our DMS 2 site. 

Share this post


Link to post
Share on other sites

×