Jump to content

Archived

This topic is now archived and is closed to further replies.

itarsenal

Featured Image Shows Twice [thumbnail stays in title on post]

Recommended Posts

itarsenal

I'm trying to configure the blog section of DMS as I migrate from Pagelines Framework to DMS, so far, the process has been okay, but long.

 

I'm trying to get thumbnails to show up on the blog page, but not show up twice on the post page. I'd also like thumbnails to pull automatically from posts, not be the featured image so I don't have to remember to set another thing up.

 

Here's the blog page: http://itarsenal.staging.wpengine.com/blog/

 

Here's the post page, with the image showing twice, once in the title which I'd prefer to remove, and once where I inserted it into the post http://itarsenal.staging.wpengine.com/iphone-video-lighting-cheatsheet-download/

 

I tried this blip of CSS to remove the image from displaying in the title, but then it also removes it from the blog page, which doesn't work.

 

.fpost .media .img img {
display: none;
}

Robert Granholm

http://itarsenal.com | Technical Support for Online Entrepreneurs

Share this post


Link to post
Share on other sites
James B

Hi there,

 

In the single post page do you have the image added again within the content? By default the postloop will automatically putthe featured image at the top of the post page or to the left. If you already have the image inside the post itself then you won't need to display the featured image, use the option to hide thumbs (inside the postloop section options) on the single post page. http://screencast.com/t/VgLa10HQXj

 

The core is set to pull in featured images only, it won't pull images in from the content into the featured thumbnail box unfortunately.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
itarsenal

I see that's how it works, but it doesn't make sense to do it that way.

 

If I have an image that I want to feature, I am locked to putting it at the top of the post page or to the left as you said...so I can then NOT put the featured image, which I'd like to feature, elsewhere on the page, or it looks like it will show up twice on the blog page.

 

As it seems, that's how it is coded to function so I'll have to figure my way around it either manually placing or disabling thumbs or what not, either way I have a handle on it now.


Robert Granholm

http://itarsenal.com | Technical Support for Online Entrepreneurs

Share this post


Link to post
Share on other sites
James B

If you disable the thumb inside a single post page it won't affect the main blog page. The thumbs will still display there.

 

So if you want to feature the image elsewhere inside the post on the single blog page, just make sure it's inserted in the content of the post, and then use the option to hide the thumb on the single post page That way the image will only display once, inside your post content.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
jsfbay

I'm looking in DMS2 and don't see the hide thumbs option.

Share this post


Link to post
Share on other sites
Danny

jaymasunaga, In DMS 2.0, enable the Legacy PostLoop options and a whole host of options will be available.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
scientistsofmedia

Hey Danny.  is there another option to hide the thumbs besides using the legacy post loop in DMS2?  says the legacy will not be supported in future releases.

Share this post


Link to post
Share on other sites
greenfly

There will be future functionality available to handle this - more details to be released soon. For now the legacy options are the way to do this. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
jsfbay

Thanks so much for the quick fix...and quick reply.

Share this post


Link to post
Share on other sites
greenfly

no problem :) 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

×