Jump to content

Archived

This topic is now archived and is closed to further replies.

Ron

Recent problems with columns and refreshing

Recommended Posts

Ron+    2
Ron

I did a complete redesign of my site clearwaterbeachcondosforsale.com in DMS with no problems but partway through doing a redesign of another site I started running into a lot of issues with columns and when refreshing.

 

I am using DMS 1.1.7 with PageLines Academy child theme 1.0 and DMS Pro Tools plugin 1.51 on the current site I'm trying to redesign.  WP version is 3.8.1 and Chrome version 33.0.1750.146 m

 

During the past week while attempting to make changes to my homepage, I started running into problems anytime I tried to add columns.  Whether I added 2 columns or 3 columns, they would add in as 2 or 3 full width columns stacked above each other rather than next to each other.  There was 1 or 2 times it would go in correctly, then I'd add some content and then I'd save, publish and then when I refreshed to see the changes either they would disappear or they'd show up as full width one above the other again.

 

I went to my other site which was still version 1.1.6 DMS and I had created that site with columns, pages with sidebars, etc. and had saved several templates with sidebars.  I tried adding a page using the default template which is a content column and then a sidebar column and when I added this page and used the default template it put the sidebar column as a full width column below the content (even though the content column was only 8/12 and the sidebar column is usually 4/12).

 

I can't resize these full width columns because there is no 12/12 showing and when I click on the arrows nothing changes.  So this is now happening on 2 different sites on 2 different hosts and including one that I had worked on only a few weeks ago without any of this happening.

 

I did already try deactivating every plugin except the DMS related ones so it isn't that.

 

I have given up on redesigning the 2nd site using DMS for now as I was spending hours trying to just get columns and can't do anything more until it functions as it should.

 

I even had my footer content disappear after doing a refresh (was not editing it at all) and when I went into the text box the code was there but it just wasn't showing on the page.  I was able to get this resolved.

 

There is also a spacing issue in the right textbox on http://housesforsaleinpasadenaca.com/ that keeps coming and going.  I have the spacing correct and then I make a change elsewhere on the page and save and refresh and then I have extra spacing between lines.  I go into the content box for that text box, click in the content box and then click outside the box and suddenly the spacing is correct.  But when I refresh again the spacing is wrong.

 

I don't know what happened in the last few weeks but there is definitely something going on that wasn't before and is making DMS unusable for me. Is there some way we can get this fixed?

 

Thanks,

Ron

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi Ron,

 

I am unable to replicate your issue, can you please disable all active plugins including DMS Pro Tools and see if this issue persists. If that is the case, then provide a link to the site in question and make sure DMS debug mode is active (DMS Toolbar > Settings > Advanced).

Again make sure all plugins are disabled.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Ron+    2
Ron

Hi Danny,

 

I disabled all plugins including DMS Pro Tools for http://housesforsaleinpasadenaca.com/ and then tried to add a 3 column layout within the Templated section on the front page just below the 2 current TextBoxes and they were laid out full width (rather than the width I set for that section) one above each other.  All I have been trying to do is to add a 3 column layout below the current TextBoxes so I can have 3 TextBoxes below the 2 but have not been able to get that to happen.  I did enable the debug mode after doing the above.

 

I then try approaching another way - I added a 3 column layout above the 2 current TextBoxes and they were laid out next to each other correctly and it stayed that way when I published and refreshed.

 

I added TextBoxes to each of the 3 columns at the top, then adjusted the sizes of all the columns (3 on top and 2 below) so I would have the layout I was trying for (2 on top and 3 below) and was able to get this to work and it stayed that way even after publishing and refreshing.

 

Now I had 2 columns with 2 blank text boxes on top and 3 columns below with a blank textbox on the left, and then the 2 textboxes with content that were originally all that was in this section now being the middle and right columns of the bottom row.

 

I copied and pasted the title, content and styling class for the first textbox and from where it was now (middle box in bottom row) to where it was supposed to be (left column of top row) and then saved, published and refreshed and everything was still as it should be.  

 

Then I did the same thing for the other textbox (copy and paste from right box of bottom row of 3 columns to right box of top row of 2 columns) then saved, published and refreshed and now I have 2 columns on top with textboxes with content and the 3 columns below are now no longer laid out next to each other (3 in a row) but rather one above each other.  These 3 columns are now full width rather than being within the margins of the Template section and do not show 12/12 by the arrows for adjusting width and cannot be adjusted in width.

 

Hopefully that will give you more specifics on what is going on with this situation to help in debugging.  I've left all plugins off, debug mode on and the site's homepage as I described in the last paragraph.

 

Thanks,

Ron

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Ron, I apologise but I am still not entirely sure what it is you're trying to do. I have viewed your site and your current layout is set to 2 columns and then 3 columns, the first column on the three column layout is there, but your background is black and your text is also black. If you view my screenshot below you can see the text which I changed to white via Chrome dev tools.

 

http://cl.ly/image/2U3i3J163B2l

 

If I have still misunderstood your question/issue, can you provide a concept image of how you want your layout to look and we will get a better understanding.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Ron+    2
Ron

Hi Danny,

 

Sorry if I'm not clearly explaining.  I'm trying to add 3 text boxes in a row below the 2 current text boxes ("Buying..." and "Successfully Selling...") that are there (2 columns in top row then 3 columns side by side in the row below).

 

The text should be black and the background in the columns/textboxes white (the styling I set up adds the white background so the black text shows, and was showing that way already).  I've done a screenshot on how it is showing on my screen so you can see the 2 top columns with textboxes and then the column below with blank text box and then the column below that with textbox with content (those 2 columns are part of a 3 column layout that should be all on one row, left to right, but are one above each other).:

 

http://housesforsaleinpasadenaca.com/wp-content/uploads/2014/03/screenshot-danny-1.jpg

 

If you look at the "Buying Homes..." textbox at the top you'll see a blue dotted line along its left side and then going down from there - that is the left margin I set up so that the content has a little space from the side of the monitor/screen.  I did that on both sides with my mouse and set this up for both the Template and Footer sections.  

 

However, you'll notice the Column and TextBox below the 2 content filled textboxes at the top, and the bottom textbox "Buying Home..." stretch beyond that.  Also, you should be able to see how that same Column about does not show the 12/12 by its arrows like the textbox within it does - and the arrows for reducing the width of that Column do not have any effect.

 

So the basic problem is that I can't add a 3 column layout below the 2 top columns with textboxes ("Buying..." and "Successfully Selling...") without it shifting the layout of the 3 columns to where the columns are one above each other instead of 3 next to each other in one row.

 

Hopefully with this description and the screenshot it will help you understand what I'm trying to describe a little better.

 

Thanks,

Ron

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

OK, so what you want is something like this:

 

http://cl.ly/image/0a0B43152Q2b ?

 

I think the best thing to do is for you to use a free application called Jing and record what you're doing so we can see your issue. As I have no issue in using multiple columns and adding sections to them, to create different layouts.

 

Just add a Column section to your site, then populate it with your sections, then add another Column section and populate with section(s) again, then rinse/repeat.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • dbrowne02
      By dbrowne02+
      Hi, I am trying to figure out how to create columns where the text flows into the next column, like the attached, and am flummoxed. Does anyone have any ideas? 

    • tkpagelines
      By tkpagelines+
      Hi there,
      how to make the corners of boxed columns round ?
      Any suggestions ?
      Thanks
    • JawDesigns
      By JawDesigns
      Hi to all,
      I always have this problem and I'm unhappy with the fix I usually apply for aligning columns at the bottom (see attached).
      For example: I use two text boxes side by side. Both text columns have a background colour. Text column 1 has 200 words and text column 2 has 300 words.
      How do I easily get them to align at the bottom without using a min-height declaration? I want to get text column 1 with 200 words to fit the height of text column 2 if that makes sense?
      Thanks for any help on this!
      Cheers,
      James

    • jeomiland
      By jeomiland+
      For quite a while I have worked around a refresh issue but it seems quite convoluted and near impossible to explain to clients. According to a lesson in PagelinesAcademy, it is because of javascript but there must be a more elegant way to deal with this. Here are 2 scenarios:
      1) Custom CSS: I add a css style to custom css, then have to select Edit in a component, then click in 2 text boxes to get the Refresh icon in the tools pallet to show. I click Publish a couple times then Refresh and hope that the new CSS code is still there - half the time it is not, so I have to redo a couple times till the system keeps it. Your "Tip: Hit [Cmd⌘+Return] or [Ctrl+Return] to Preview Live" at top of CSS window does nothing on my Macbook Pro.
      2) Home page at: http://199.119.180.102/~harmhill/newsite/ has 2 columns for main template area. In larger right column, I need to add a 3 column above the WPloop and below the image, which are both in that right column. I can drag the 3col section to the right place and it says "Section Added! Refresh page to view." Have tried several ways to get the section to stay and refresh but nothing works! Using cmd-r (refresh) in Mac Chrome, not my trick above... can't get the 3col section to stay on refresh, so no way to add the 3 text boxes required next.
      So 2 questions:  1) what is best way to refresh a page and preserve CSS and sections added and 2) can you put a 3-col inside 1col of a 2-col?
      thanks
    • nandorj78
      By nandorj78+
      Hi, I'd like to know if there is way to put the Hero box right under the column above it. The way it is now (see attached picture) has a lot of blank space. I can't seem to move it up a bit fo fill in this empty space.
×