Jump to content

Archived

This topic is now archived and is closed to further replies.

nfp1900

iphone menu unresponsive

Recommended Posts

nfp1900    29
nfp1900

The iphone menu on this site http://buryfields.co.uk/ appears but doesn't respond to anything.  Menu appears full size on ipad and is fine. Anything to suggest about this?

Share this post


Link to post
Share on other sites
James B    436
James B

From what I can see in the script debugger it looks like there is a conflict with something called player.js. Any kind of jquery error could stop the drop down for the mobile menu working. Are you just embedding the veimo vids or are they in place through a plugin? Also the there's a js error on the facebook widget saying 'Invalid App Id: Must be a number or numeric string representing the application id'


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
nfp1900    29
nfp1900

The vimeos are just embedded I'm not using a plugin. And the Facebook app is fine (I just verified the ID again in the FB dev centre) - it's always displayed correctly.  Not sure what would throw up this error if there isn't one?

 

The revolution slider is being used, does it make sense to suppress that for mobile view?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

You have something causing a JS error, I recommend you disable all active plugins and remove any custom scripts and see if this resolves your issue. 


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nfp1900    29
nfp1900

It was the countdown clock causing this - isn't there a way of excluding this from the mobile view? 

 

BTW, what is generating this mobile menu? I only have one menu but the mobile menu isn't one that I have setup  in the WP admin. It was an older menu when the site was first setup but has since been deleted. 

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

The navbar menu you select via the navbar tab in the global options settings. The mobile menu is selected in the layout and nav tab in the global options settings.

 

You can hide the time on the mobile layout using css to display:none, but I think the script will still load though. Worth a try though. Otherwise you could use a plugin, somethink like http://heatmaptheme.com/deactivate-wordpress-plugins/ which claims to deactivate plugins depending on whether a mobile browser is detected, I've not used anything like that before though so I'm not sure if it would work 100%.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
nfp1900    29
nfp1900

I changed the countdown plugin to an HTML 5 version which is now no longer interfering with the mobile menu. 

  • Like 1

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Awesome, thanks for informing us the issue has been resolved.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • jdubdigi
      By jdubdigi+
      Onepage plugin is not working on an iphone. The page does not scroll properly and sections are partially missing, any ideas what the problem could be?
    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • ivaemer
      By ivaemer+
      I've got the problem with Onepage plugin ..
      First two sections - Intro and Gallery Module are not showing on iPhone and iPad...help asap please
       
       
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
    • Dave
      By Dave+
      1) Toggle menu on mobile devices does not work properly, combination Chrome 56.0.2924.87 with Android 6.0.1

      2) Mobile / Default Menu > Set the primary/default navigation for your site. This will be used in the pop out mobile menu and as the default in navigation sections. Does not work.
×