Jump to content

Archived

This topic is now archived and is closed to further replies.

balfred1345

Shortcode in TextBox - How to Set Background for Form only, Remove Extra lines

Recommended Posts

balfred1345    5
balfred1345

Hi,

I'd like to be able to put a shortcode for Gravity Forms plus HTML in a Text Box to I can write media queries to call a smaller version of the Gravity Forms form for mobile. 

 

When I get this working, I'll want to use another textbox with different sizes of an image called by media queiries.

 

The problems I need help with:

1) How do I set the background-size of the form I've placed in the text box to match the size of the form fields. I tried using a class within html in the textbox to set background color, but it still effected the entire area of the text box, not just the background of the form. When I set background-size to smaller than auto or 100%, the form fields get reduced commensurately. Please see the form in the ORANGE full width section at http://whub34.webhostinghub.com/~videoh6/cidev2.com/

 

2) I am getting extra blank lines (see under "Move Date" and under "Free Quote Now" button), and figure that they are getting thrown by the shortcode in a bad interaction with WP. Nonetheless, I need to know how to get rid of them. I understand that I can't use [pl_raw] in a text box. I know that [pl_raw] can be used in a page or post, but I don't know how to bring a particular new post or page into an existing page such as at the above url.

 

Thanks!

 

-Bruce

Share this post


Link to post
Share on other sites
balfred1345    5
balfred1345

Updating above post:

I figured out how to deal with the background (number 1 above)

 

But, I still need help with number 2 above.

 

Thanks,

Bruce

Share this post


Link to post
Share on other sites
James B    436
James B

Hi Bruce

 

The form has a <p> tag which is adding the additional spacing on the move date etc.

 

Try adding the following to your custom css to remove

 

.gform_body p {
    margin: 0 !important;
}

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • John Olsson
      By John Olsson+
      We're often working with ACF (https://www.advancedcustomfields.com/) that's great for user experience in the backend, 'cause we don't want out clients to be in the editor to much.
      So we want to be able to use shortcodes in the editor fields, regardless of section, THIS WOULD BE SO GREAT. Is there a way to fix this, it should open up som much more functionality.
      In ACF, the shortcode is for example: 
      [acf field="field_name"] ...for example, I want to att field_names value to display in a section, i understand I can make it in embed and so, but I want it in titles and options, the whole range.
      I know I can build my own sections, that we've done, but it's not very effective, and thats what PL5 is about.
      Any ideas on this, can Pagelines take this in the core? I guessing there are more than just ACF out there who can use this.

    • jojoking
      By jojoking+
      I have to admit to being baffled.
      I'm trying to embed a video (from my WP media library) within a WP post using the videobox section shortcode.
      The shortcode section popup only allows two items to be configured - the section type, in this case videobox - and a unique id. There's no URL or other parameters such as autoplay or loop which are available within the Pagelines editor.
      Whatever I put in the unique ID makes no difference to what is shown which seems to be a default video with stars or white noise on a black background.
      I assume I need to define this ID somewhere else, or maybe WP has done it for me?
      HELP!
       
      PS This is the page source generated when a shortcode is added within the WP post editor
      <!-- VideoBox | Section --> <section id="videobox_1675853156" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="1675853156" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="280414138" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/plugins/pl-section-videobox/default.mp4?r=280414138" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#280414138')[0].load(); </script> </div> </div></div></section> </div>  
      If I add a videobox section using the Pagelines page editor the page source generated includes my video:
      <!-- VideoBox | Section --> <section id="videobox_udvu4uz" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="udvu4uz" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="429558737" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/uploads/2017/04/HIHWelcome.mp4?r=429558737" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#429558737')[0].load(); </script> </div> </div></div></section>  
    • bnapoli
      By bnapoli+
      On my site www.anewbeginning.com the "toggle" function mysteriously stopped working.  I have tried all browsers, tried disabling plugins, removing all the relevant CSS but still cant understand why it isn't working.
      The toggle is placed on this page: http://anewbeginning.com/?page_id=15965 and http://anewbeginning.com/?page_id=10779 but it does not display.
      On my other Platform5 websites, that exact code works fine: see here http://4aa.d11.myftpupload.com/?page_id=123
      Code is the same. Please help, thank you!
    • Samuel Costa - UDF
      By Samuel Costa - UDF+
      Hi.
      I need a shortcode activate a popup windows with contact form. It is possible without code?
      Link: https://www.udf.org.br/lancamentos/curso-mulher-que-prospera/
      Button: FAÇA SUA INSCRIÇÃO.
      Tks
    • flourishdesignstudio
      By flourishdesignstudio
      Hello, 
      I am having a problem with shortcode not working properly with the PL5 theme. I have been trying to insert shortcode for a specific plugin (Map List Pro) and it has worked when I am using DMS but not with PL5. When I insert the shortcode into the page content then none of the content (text, images, or map) will load on that page. Thinking that maybe a widget or straight HTML code would work better made me try inserting the shortcode into a widget (didn't work) as well as an embed section within PL5. The embed section worked in that I can look at the code and see that the map is there but nothing is actually displaying on the page.
      I am also unable to edit the embed code section (added through PL shortcode into the content of the page) once I have put in the Map List Pro shortcode. Any thought as to a workaround or if the codes are somehow interfering with one another? You can see the page (and gap where the map is supposed to be loading) here: http://new.fingerlakesdistilling.com/where-to-buy
      Thanks so much for any insight you are able to provide!
×