Jump to content

Archived

This topic is now archived and is closed to further replies.

entronauten

Custom Post Types

Recommended Posts

entronauten    0
entronauten

Hi@all,

 

we are building up a site with custom post types. We created one for like a contact form with adress, phone, etc. Normally we have to create a new template to tell the theme how to display the new post type. What way we have to go to enable this form of template within Pagelines?

 

Thankyou for your help!

 

Chris

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

The easiest way would be to use a plugin like types and views - http://wp-types.com/


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
entronauten    0
entronauten

Hi James, nice to meet you :-)

thanks for your tip! I have now both plugins - the "types" and the "views" and like them very much! So I deleted the former custom field types and taxonomies and builded all up with these two plugins. Everything is working fine - but the pagelines does not use the template. Other themes like the twentyfourteen do. So it seems to be a pagelines-issue. What do you think?

 

regards, Chris

Share this post


Link to post
Share on other sites
James B    436
James B

Hi Chris,

 

Please see the thread by Ellen on this post, hopefully this will be able to resolve the template issue for you - http://forum.pagelines.com/topic/23206-views-and-types-custom-types-fields-compatibility/


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
entronauten    0
entronauten

This was exactly what I needed. Thank you for your kind help, James! regards, Chris

Share this post


Link to post
Share on other sites
James B    436
James B

You're welcome Chris, thank you for updating the thread.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • Jared Smith
      By Jared Smith+
      I haven't figured out how to get the "Sync Loaded Item" option in templates menu of Platform 5 to stay checked. It doesn't give me an option to save settings when I select it, and when I select it then click off the editor, it unselects. Also if I select it before loading a template, it doesn't stay checked there either.  Whats going on?
    • Queue-it
      By Queue-it+
      Hi,
      I created a Pagelines template for a "Post type" post. Whenever creating a new post page it firstly display that template post and I have to manually change it in the scope from "All of type posts " to "Current page". 
      Is there a way to fix that? 
       
       

    • richardjacruz
      By richardjacruz+
      I'm building a website in a dev environment at http://162.144.182.17/~uescocra.
      I want to import a bunch of products, and then have the products have a different template than the default template. 
      I also want to change the default template for blog posts.
      Before I go making changes, can I do this where the post type of "products" has its own global template, and the same with blog posts?
      For instance, in a product I might want to have a widget for categories, similar products, etc., and in the blog I may want list of the latest posts, blog categories, link to an email sign-up landing page, etc.
      Thanks.
      Rich
    • abuzzelli
      By abuzzelli+
      Is there a shortcode or a way to automatically pull the site name into the footer or elsewhere?
    • seanocaside21
      By seanocaside21+
      An old client of mine has come across an issue with their website. 
      The site is fine on the front end but when you log into the DMS editor the 'About' page template isnt available instead the template for the 'Print Services' page appears
      Here is the live About page http://www.digicom.ie/about/. And see attached file for what i see in the back end.
      In the page settings i can see that the wrong page template is active but I'm not sure how this is the case if the live page is correct. The client assures me they didnt activate the template. 
      Any help at all? 

×