Jump to content

Archived

This topic is now archived and is closed to further replies.

rockytop

DMS Template Problems

Recommended Posts

rockytop

I am using a template "alpha-default", created in DMS and set as default, with a 9 column content area and a 3 column sidebar. Wordpress generated pages correctly inherit this default template.

 

However, I am using bbPress forum plugin. bbPress generated pages do not correctly inherit the template. The body of bbPress pages is correctly assigned the class "last-imported-aplha-default" but is not assigned the class "page-template-default" which appears on pages where the template is working.

 

I was able to use javascript to add the class "page-template-default" to the body of all pages, but it created more problems than it solved.

 

Any idea how I could get the bbPress generated pages to adopt the DMS template? Where could I find the DMS template's CSS to force it on bbPress?

 

As an aside, this is my first project using Pagelines DMS and I am impressed with the quality of the product so far.

Share this post


Link to post
Share on other sites
rockytop

To expound a bit, if a page is individually assigned a template, for example the forum index, it uses the 9/3 layout. When new pages are generated (e.g. posts or forums) they are created with an 8/4 layout. Obviously, applying the template to every post on a forum is not practical. Here are screenshots of working (above) and broken (below):

 

Screen2.png

Screen1.png

Share this post


Link to post
Share on other sites
James B

Hi there, did you have the bbPress pages setup before you created the alpha template? I don't use bbPress but as far as I know if the original default was set when those pages were created then it will continue to use that until the pages are re-saved/published.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
rockytop

Interesting. I will try to uninstall and wipe bbPress, toggle DMS, and try again. Will update with results.

 

Thanks for the quick reply.

Share this post


Link to post
Share on other sites
rockytop

I completely removed bbPress and all pages, deactivated and reactivated DMS theme, then reinstalled bbPress. Here's what I noticed: in DMS editor, editing a fresh bbPress page, it does not show any template as being the global default (no icon beside any of the templates).

 

The body of the bbPress pages is being assigned a class of "last-imported-custom" until I manually assign a template using DMS editor. Wordpress pages, on the other hand, are created with the correct body class "last-imported-alpha-default", the assigned global default template.

Share this post


Link to post
Share on other sites
rockytop

Looks like I posted too soon. Global default template is now appearing on all pages, including those generated by bbPress.

 

Thank you, James B

Share this post


Link to post
Share on other sites
James B

You're welcome, glad all is working.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

×