Jump to content

Archived

This topic is now archived and is closed to further replies.

Alex S

CSS/Less is Gone?

Recommended Posts

Alex S

Hi everyone,

 

I'm not sure how it could have happened, but all of my custom CSS and Scripts have disappeared.

After dealing with the loss of several months of work and development, I started to re-do the CSS.

 

And the second I save, it's all gone. Everything is gone, no matter what I do. 

 

This is a serious problem. This site is live, I have clients that access it, and it's completely falling apart with Pagelines.

 

Am I the only one getting major Pagelines glitches? How can I resolve this??

Share this post


Link to post
Share on other sites
Simon

Do you have a backup? I'm guessing you must have some sort of backup if you are editing a clients site live right?

 

I was reading you're other post, you were experimenting with element titles or something?

 

Id say the preferred method for ANY custom code is a real file, be it css or javascript.

 

style.less in a child theme is always rendered into the main css the same way as the custom css box is.

 

 

 

Am I the only one getting major Pagelines glitches? How can I resolve this??

 

You can resolve it by getting your css from a backup and adding it to a style.less file then clicking publish.

Share this post


Link to post
Share on other sites
Alex S

Simon_P It's my own site, not a clients (thankfully) 

Where in a backup would the css be? I can't find anything with a specific css title.

Share this post


Link to post
Share on other sites
Simon

Well if you have a SQL backup... its in wp_options table, row is called pl-settings.

 

Its a serialized array and the setting is called custom_less

 

If you want me to extract it you can PM me an extract of the db dump.

Share this post


Link to post
Share on other sites
Alex S

Simon_P I have the backup as an SQL file, should I just copy and paste that in a PM?

Share this post


Link to post
Share on other sites
Simon

GOD NOOOO lol zip it and attach it to a pm ;)

Share this post


Link to post
Share on other sites
Alex S

Simon_P Haha okay. Sorry if this is a dumb question, but where is the attach button in the message area? 

Share this post


Link to post
Share on other sites
Simon

click 'use full editor'

Share this post


Link to post
Share on other sites
Alex S

Simon_P Haha yeah, got that, but what button? There's nothing that indicates an attach option.

Share this post


Link to post
Share on other sites
Simon

Email then?

[attachment=1967:bb7cf65fb0528f8fa39fb6fbe0e25af4.png]

 

Share this post


Link to post
Share on other sites
atcdomainsolutions

Simon_P Haha yeah, got that, but what button? There's nothing that indicates an attach option.

Just an fyi for future sites but I got in the habit of backing up my CSS  since I have had a few sites where the CSS would not stick in the LESS box...even after multiple save attempts. I use the same plugins for all sites I have built (have built over 40 sites with DMS so far) so what I started doing was going through the Wordpress Admin area and using the Pagelines DMS backup CSS LESS box to add new code, save it and then switch to another window and hit refresh and that ALWAYS makes the changes stick.

 

I know it's not the preferred method but it does work when you can't get some CSS that you KNOW is correct to stick/save.

 

You may also want to check there to see if the CSS you lost was backed up...most times it will be.

 

James

Share this post


Link to post
Share on other sites
Simon

atcdomainsolutions Alex did send me a backup, it was nearly 1 year old and did not have any PageLines settings :/

Share this post


Link to post
Share on other sites
Alex S

atcdomainsolutions Good advice James, thanks.

 

Simon_P Yeah... but that's the weird aspect of it, because I did back up last week with my host. I feel like there are some major internal errors with my host that really need to be resolved, because I've been doing weekly backups for the last year.

Share this post


Link to post
Share on other sites
Alex S

Does anyone know why this happened? I can't even re-do the site because the CSS/LESS keeps erasing itself. I could really use some assistance here. 

Share this post


Link to post
Share on other sites
Alex S

Bump? I need someone to help fix this. I'm paying for a service that's failing on my site. Can someone take a look at what's going on?

Share this post


Link to post
Share on other sites
Danny

If your CSS/LESS is removing itself, then this isn't something related to DMS, it has to be caused by either a plugin you have installed or an issue with your web host provider.

Can you provide a link to the site in question and make sure DMS debug mode is active please ~ DMS Toolbar > Settings > Advanced.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Alex S

Danny the link is here, and I've now enabled debug. Thanks for taking a look.

Share this post


Link to post
Share on other sites
Danny

OK, you will want to disable all active plugins, make sure DMS Pro Tools section cache is disabled and get your host to upgrade your PHP version to 5.4 or greater.

 

Then add some custom CSS and see if this saves and doesn't get removed. If this is the case, then its likely a plugin or your server. Now, start enabling your plugins and see if this causes your custom CSS remove, if this is the case, then its a plugin for certain. You will need to begin the long and irritating process of enabling your plugins one by one, until you find the culprit.

However, if your CSS is still being stripped, when all plugins are disabled, then it's likely your server configuration.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×