Jump to content

Archived

This topic is now archived and is closed to further replies.

thebastion

What version of WooCommerce are you guys running?

Recommended Posts

thebastion
Hi there,

Can I ask what version of woocommerce you are running on Pagelines?

I updated to 2.1.2 and they have removed certain pages and replaced them with 'ENDPOINTS', which are throwing up 404 errors.

In true woocommerce style the woo support team are blaming everything else rather than address the issue.

Despite me installing the 2014 theme and deactivating every plugin it still isn't working, I just wanted to see if you had 2.1.0 or higher working with DMS yet so I could tell woo support.

Any light you could shed would be helpful.

Cheers

Stuart

Share this post


Link to post
Share on other sites
James B

Just checked on the core site and we're using Version 2.0.20 currently. I've not heard anyone mention anything yet regarding Woo but they've probably not looked into the upgrade yet.

 

Checking with Woo, they issued the following. Copy/pasted below, sounds like flushing the permalinks should get everything back up and running.

 

If you need to roll back you can download the older version from http://wordpress.org/plugins/woocommerce/developers/

Lots of pages 404 error after WooCommerce 2.1 update

This issue is now resolved in the WooCommerce 2.1.1 fix release.

Because we have changed a couple static pages to endpoints in the WooCommerce 2.1 release, the permalinks need to be flushed. This wasn’t done properly in the WooCommerce 2.1 update, therefore you should do this manually in case you have a lot of 404 errors after updating. The upcoming 2.1.1 patch release will fix this issue and no longer requires a manual flush.

Pages included in possible 404 errors are: main shop page, category or tag archives and all of the new endpoints. This also affects conditional functions like is_shop() and that causes plugins relying on that function to no longer function properly.

You can flush the permalinks manually by saving the Settings > Permalinks page, to be found in your WordPress administration panel. After doing this, your pages will work as expected.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
thebastion
Yeah, I wouldn't advise you upgrade, I've been through 2.1, 2.1.1 and 2.1.2, flushed my permalinks and switched themes and turned off every plugin, no joy.

Just wanted to see if anyone had 2.1+ working with DMS so I can be sure it's not the theme. I don't think it is.

Woo support still mysteriously quiet!

Share this post


Link to post
Share on other sites
thebastion

Haha, I found the problem.  Just in case anyone else comes across this i'll add it here.

 

Disable all plugins THEN reset Permalinks, I just went to Permalinks and resaved them.  Get the 404 page on another tab ready to refresh, once plugins are off and permalinks are reset, refresh your page, it should work.

 

Reactivate plugins one by one and refresh the page with the endpoint until you get the 404.  That's your plugin causing the issues.

 

Remember, reset permalinks AFTER deactivating your plugins otherwise you'll just get the 404's keep rolling.

 

My plugin was Nick Haskins and Co Projects Part Deux.  The second time this month it has caused me a headache...

 

Hopefully that will help someone in the future.

Share this post


Link to post
Share on other sites
Danny

Thanks for sharing.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
bsaul

Mid update here and having problems too - will post them in a separate post for future reference. Have rolled back but still affected - worst issue is the product category pages showing in one column.

Share this post


Link to post
Share on other sites
thebastion

Have you tried a quick theme change, that and switching off your plugins are the two quick checks.  Just remember to resave your permalinks once you've changed the theme and deactivated your plugins.

 

It would seem a lot of people are having theme issues, I have seen issues with Projects Part Deux, WP Videos and 404 Redirect plugins.

 

Good luck getting it sorted, it has been a nightmare.  WooThemes have not dealt with this upgrade well in my opinion.

Share this post


Link to post
Share on other sites
bsaul

I will try that but think I'm confusing things - I'm still using the Framework, not DMS - had arrived on your thread via another and did not check. Sorry about that. 

Share this post


Link to post
Share on other sites

  • Similar Content

    • Jessica McCabe Lawson
      By Jessica McCabe Lawson+
      I'm building a product catalog site. The featured image is set correctly, but the woocommerce placeholder image is displaying instead. If I click on the placeholder image, the featured image appears, and the featured image works fine as a thumbnail.
      Please view the site here: http://www.directmat.net/product/power-lock-logo-mat/
      Note: I deleted the placeholder image via FTP to see if that would inspire Quick Shop to look for the featured image. No such luck. Please help!
    • mtaus
      By mtaus+
      I'm using Woocommerce in a Pagelines framework. When I build out a product, I'm able to add images in the admin panel and the
      Product Image will display on Shop page, but neither the Product Image nor the Product Gallery will display on the product's dedicated page.
      Shop: https://bendbotanics.com/shop/
      Product Example: https://bendbotanics.com/product/500mg-full-spectrum-hemp-oil-fsho/
      Any help would be greatly appreciated!
    • cdracos
      By cdracos+
      Hello everyone,
      I face a common problem as I can see on relevant topics with quickshop plugin. 
      On Product Single page of woocommerce, i use quickshop as layout. The primary photo of my product doesn't appear on the thumb slider, but the first image is the default placeholder. 
      Need some help not with custom script in the product description for each product. 
      Have a look on my website: http://lillyandsid.gr/shop/camp-things-top/
    • bnapoli
      By bnapoli+
      I have Quickshop installed on my WooCommerce section of this website: http://a04.125.myftpupload.com/
      Main Shop: http://a04.125.myftpupload.com/?page_id=1198
      I've having what appears to be CSS issues on the individual product pages. After cleaning up any code accessible from the wp-admin, the page still appears broken. I never tried to customize it, it just came broken like this right out of the box.
      You can see examples of it broken on every single product page, see here:
      http://a04.125.myftpupload.com/?product=futaba-14sg-14-channel-2-4-ghz-radio-system
      http://a04.125.myftpupload.com/?product=gremsy-gstabi-h7-brushless-3-axis-gimbal
      http://a04.125.myftpupload.com/?product=dji-inspire-1-zenmuse-x5-gimbal-and-camera-unit
      http://a04.125.myftpupload.com/?product=dji-wookong-m-flight-controller
      Can somebody help?
    • King Creative Design
      By King Creative Design+
      I am setting up a Woocommerce site using PL Framework and Platform 5. I added a hook so the category description appears under the category page titles (on archive pages). However, it also appears under the title on the main "shop" page (which I have renamed "Catelog" page). There is a default description here and I can't figure out for the life of me where it is being generated from so I can change it. Any ideas how to change it or delete it on the main shop page ONLY? The staging site is here - http://16e.117.myftpupload.com/ and the page in question is http://16e.117.myftpupload.com/catalog/
      I have hit up Woocommerce support and they weren't familiar with Platform 5 and recommended I contact you.
      Your help would be appreciated, thanks!
      Michele

×