Jump to content

Archived

This topic is now archived and is closed to further replies.

MobileParity

Custom CSS Not working

Recommended Posts

MobileParity

Hello there,

 

I am using a DMS Child Theme to customize my site and the CSS that has been added via the custom LESS/CSS editor on the front end. The CSS loads fine when I press ctrl+enter (PC) however when I visit the live site none of the custom LESS/CSS shows up. Not sure what I am doing wrong here so a bit of help to get my over would be awesome. I have included screen shots of what the site is supposed to look like. http://screencast.com/t/cL9Vx4Gv

The live site location is on my profile.

Share this post


Link to post
Share on other sites
Danny

HI,

 

If your custom CSS isn't working upon refresh, its likely you have some errors, you will need to review your CSS and rectify any mistakes.

If that doesn't work, provide a link to your site, with DMS debug enabled (DMS Toolbar > Settings > Advanced) and also add your custom CSS to our pastie service then link it in your reply.

 

http://forum.pagelines.com/pst/


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
MobileParity

The CSS is now working because I am using the Wordpress CSS feature. I believe this overrides any theme CSS however i am not sure if this is the correct method to have the CSS showing. Any thoughts?

Share this post


Link to post
Share on other sites
James B

Hi there, in DMS you'll need to use the Css/LESS editor inside the DMS control panel. http://screencast.com/t/9FFmKAXsID5g

 

Once you've entered your css, click elsewhere inside the admin panel so you see the spinning saving icon in the top right hand corner of the DMS control panel. Once its finished saving then click publish. Then you can check the page again for the changes.

 

Full details of the different methods of making css changes can be found at http://docs.pagelines.com/customize/how-to-customize


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • stebac
      By stebac+
      Hello!

      Since i recently updated to WordPress 4.9.4 there have been some unusual behaviours with Platform 5 (version 5.1.8).

      I am unable to edit the colour pickers for the backgrounds (the boxes do not show up anymore) and when i activate a plugin from the extend menu it does not show up in my page editor tools.
      Is this a problem for everyone else?
      Thank you in advance for your time.
      Ste.
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
×