Jump to content

Archived

This topic is now archived and is closed to further replies.

MobileParity

Custom CSS Not working

Recommended Posts

MobileParity+    0
MobileParity

Hello there,

 

I am using a DMS Child Theme to customize my site and the CSS that has been added via the custom LESS/CSS editor on the front end. The CSS loads fine when I press ctrl+enter (PC) however when I visit the live site none of the custom LESS/CSS shows up. Not sure what I am doing wrong here so a bit of help to get my over would be awesome. I have included screen shots of what the site is supposed to look like. http://screencast.com/t/cL9Vx4Gv

The live site location is on my profile.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

HI,

 

If your custom CSS isn't working upon refresh, its likely you have some errors, you will need to review your CSS and rectify any mistakes.

If that doesn't work, provide a link to your site, with DMS debug enabled (DMS Toolbar > Settings > Advanced) and also add your custom CSS to our pastie service then link it in your reply.

 

http://forum.pagelines.com/pst/


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
MobileParity+    0
MobileParity

The CSS is now working because I am using the Wordpress CSS feature. I believe this overrides any theme CSS however i am not sure if this is the correct method to have the CSS showing. Any thoughts?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, in DMS you'll need to use the Css/LESS editor inside the DMS control panel. http://screencast.com/t/9FFmKAXsID5g

 

Once you've entered your css, click elsewhere inside the admin panel so you see the spinning saving icon in the top right hand corner of the DMS control panel. Once its finished saving then click publish. Then you can check the page again for the changes.

 

Full details of the different methods of making css changes can be found at http://docs.pagelines.com/customize/how-to-customize


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • jeomiland
      By jeomiland+
      Hi
      I found this topic
      which talks about a similar issue I am having, but a little different. Hope someone can help me out.
      Best way to see the problem is to view http://cassclayton.com/ on Safari (Mac) compared to Firefox or Chrome. You will see the banner just under the fixed menubar has a gap between the menubar and top of the banner. Looking at Inspector, I found:
      <div class="fixed-top-pusher" style="height: 62px;"></div>
      <script> jQuery('.fixed-top-pusher').height( jQuery('.pl-fixed-top').height() ) </script>
      and indeed it seems the jquery is not always working consistently. For instance, if you simply refresh the page in Safari, it will loose the gap and all looks fine, so is it a browser cache issue that is interacting with the jquery? I do have W3 Total Cache installed. There must be a way to tell the code to make sure jquery is up and running and available to do it's majic?
      And perhaps there is just a better way to do this banner? Originally I tried several DMS sections and used the banner image as background, etc... Kept running into problems with resizing and the left/right parts of the image were getting chopped off. It is important the whole image show, so currently I just use a NextBox section with this code:
      <img src="[pl_site_url]/wp-content/uploads/2015/12/CassClayton-blues-tribute-banner.jpg" width="100%" />
      and it looks the way it should. Is there a better way to place a banner graphic under a fixed navbar and make sure the whole banner graphic displays regardless of screensize?
       
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
×