Jump to content

Archived

This topic is now archived and is closed to further replies.

caspersjan

DMS Editor not loading - Javascript Error?

Recommended Posts

caspersjan

Dear Pagelines team,

 

I am in a bit of a panic or at least I would be if I were not sure that you can help me out of a tight spot as you've done in the past! Last night I entered a piece of custom JQuery yesterday - Ellen Moore had given it to me to make an adjustment in the Filtering section.

 

<script>
jQuery(document).ready(function(){
jQuery('.section-filtering .filtering .item .post-info').html(jQuery('.section-filtering .filtering .item .post-info').html().replace("By",""));
jQuery('.section-filtering .filtering .item .post-info a').css('display' , 'none');
});

</script>

 

This worked perfectly (it hides the author and byline from the meta info below posts). I closed down everything happy and content but since then am unable to open the DMS Editor. The wheel is spinning and spinning and spinning but nothing happens. The "Common Issues and Solutions" document suggested a Javascript error, which could well be the case as it coincided with the first time I entered any custom script (though last night it was working alright). I'd like to remove the script but cannot because I cannot open the DMS Editor. What shall I do? This is my site: 

 

http://www.animatinghebron.com/wordpress/

 

I can access the Dashboard and open the site when I'm logged out. Is there a way to delete the JQuery script without the DMS Editor? I disabled all plugins to see if that would help but it did not. I logged in in different locations, it did not make a difference either. All this may point to the JQuery. I hope very much that this is not as serious as the spinning wheel makes it appear and that you can help me - I'm a little worried because I had worked hard to work out all major tasks on this site (perhaps narrowing this little gap between post title and meta info broke the camel's back...). I'm happy to send you credentials if it would help.

 

Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
caspersjan

All clear, all clear! I discovered the Pagelines tab in the Dashboard with its DMS Header Scripts Fallback field. This contained the JQuery code in question and once this was deleted all went back to where it was (apart from the author/byline issue which I am glad to postpone if it saves the overall site! Perhaps you could include a reference to this in the Support and Troubleshooting document - it may save someone else moments of worry! If you can see what is wrong with the script (or know another way to edit the meta info so that author and "by" can be hidden) please let me know. Thank you for your patience - I try to work out problems myself where I can because I know support staffers are always overworked, but sometime despair gets the better of me... It's good to know that if needs be you'd always be there to jump in!

Yours faithfully, Jan.

Share this post


Link to post
Share on other sites
greenfly

Hello Caspersjan

 

good to hear you got this resolved :)


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
caspersjan

Dear Martin, if at first you don't succeed... Always glad to know where to go to for help. I lost sight of an older problem: DMS Editor and RTL languages. We corresponded just before the new year. Tomorrow I set up a page demonstrating how the Editor gets turned around. In a new topic... Thanks again and good night. Jan.

Share this post


Link to post
Share on other sites

  • Similar Content

    • TJ Bawa
      By TJ Bawa+
      DMS Editor is not loading. I have tried using different browsers and also have cleared my browser cache, but still no luck. 
      Please find screenshotattached. 
      Thanks in advance! 

    • Toolshed
      By Toolshed+
      Hello - I'm a registered Pagelines user. I tried to load my website today (toolshed.biz) in the DMS editor and received a message that the page was having trouble loading. I rarely make changes to my website so this was unexpected. I followed your support suggestions and checked for javascript errors using Chrome - when trying to load the page, it showed the following
      jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
      pl.editor.js?ver=16e8ee:740 Uncaught TypeError: Cannot read property 'lang' of undefined
          at Object.reloadConfig (pl.editor.js?ver=16e8ee:740)
          at Object.startUp (pl.editor.js?ver=16e8ee:72)
          at HTMLDocument.<anonymous> (pl.editor.js?ver=16e8ee:10)
          at i (jquery.js:2)
          at Object.fireWith [as resolveWith] (jquery.js:2)
          at Function.ready (jquery.js:2)
          at HTMLDocument.K (jquery.js:2)
      303toolshed.biz/:1 Error in event handler for (unknown): TypeError: Cannot read property 'tab' of undefined
          at chrome-extension://kamiaabbnpncbobdiblhfogafnoefkae/contentscript.js:38:28
      I deactivated all my plug-ins prior to doing this except for:
      Pagelines Platform 5 v5.0.126
      Pagelines updater v. 1.2.9
      I'm not an expert coder or web developer, not really sure what this all means. Not sure what JQMIGRATE is (a plug-in? I don't see that in my plug-in list). Can you point me in the right direction?
      Thanks,
      Dick Huey
    • dbrowne02
      By dbrowne02+
      Hi, the DMS editor is not loading on landing page. It is working on all other pages. How do I fix this? the website is selborneproperties.com I have logged in and logged out, have disabled plugins. Thanks,
      David
    • jeomiland
      By jeomiland+
      Greetings
      Was on the phone with client yesterday reviewing the site and the server slowed way down. Did a couple updates that may not have taken. Now cannot get back into the DMS editor for http://cassclayton.com/dev/  I can see the site in chrome and firefox but the background image is no longer there. Can get into dashboard in chrome and firefox. Cannot get into DMS editor in chrome - get "Oops, There may be an issue loading." error no matter how many times I try.  My internet connection is not the fastest, but I can access other sites I've built in DMS - just not http://cassclayton.com/dev/
      My question is,
      1) is there a safe way to reinstall DMS that will not trash the work done on the site? 
      2) Is there a way to see if something in the database got corrupted and how to fix? Since I can't get into DMS editor, can't get to the Flush Cache page to try that.
      Just turned on
      define('WP_DEBUG', true);
      Help!
      Thanks
    • CjrMotley
      By CjrMotley+
      My DMS editor isn't working on my landing page, all other pages can be edited using the DMS editor. 
      Is there a fix for this???
×