Jump to content

Archived

This topic is now archived and is closed to further replies.

JawDesigns

Problems with the Gallery Section

Recommended Posts

JawDesigns    11
JawDesigns

Hi,

 

Today downloaded the pretty photo theme. I then copied over the gallery sections into my child themes section folder so that I can use the gallery section within my DMS theme. However, I have noticed that when I make the gallery smaller using the decrease width buttons it does not effect the size of the gallery images below but only the text above. I then tried to centralize the text above the gallery images below by shifting over the text using the arrow buttons to 'offset right' but it starts to move the gallery images off of the page. The behavior is very weird so I am wondering if it's actually advisable to copy sections into my child themes sections folder?

 

Please see the image attached:

 

a - I decreased the width but the gallery images don't decrease in size

 

b - When I offset the gallery it then moves everything off of the page

 

Also, how do the sections in my child themes folder get updated? Will they be updated like the sections inside the DMS themes sections folder or is there a manual way I will have to do this?

 

Thanks, J


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Hello @jamew 

 

yes there should be no problems copying sections from themes or creating your own custom sections and using them in your child theme. 

 

Could we have a link to your site please? 

 

Also could you enable PageLines Debug for us and let us know when you have done this. 

  • Like 1

The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
JawDesigns    11
JawDesigns

Hi Martin,

 

You can take a look at the page: http://jawdesigns.co.uk/test-test-page/

 

Also, I have noticed that the 'Lists' section bg and text colours sometimes do not work (for example now the colours are white and not their default) and the lists are not displayed symmetrically under the 'list heading'. I can fix this with some CSS but it would be good if there was even padding at both sides of the list box if possible?

 

Thanks you for you help with this. Debug is also enabled.

 

Cheers, James


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, after changing the width using the alignment options did you publish and refresh the page? Some sections need to be reloaded in order for the new options to be rendered in the layout. Looking at the live site its displaying ok and acting responsive when resized. http://screencast.com/t/1zVzJhIRaRV

 

I can't see the list section on the page at current but by default the list text will appear white. List content will try and appear symetrically depending on the options you have selected in the section options, if there's not enough room (depending on the site width) to fit the amount of columns displayed it will move one to the next room and then the positioning in the line above will adjust to fit.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
JawDesigns    11
JawDesigns

Hi James,

 

Thanks for your reply. The gallery still doesn't seem to be working properly. For example if you do the following:

 

1) Add a gallery section as default

2) Click edit and add a 'Gallery Title'

3) Add a Gallery Description

4) Press Publish

5) Refresh page

7) Decrease width to 6 (note gallery image stays the same size and only the text gets smaller)

8) Offset Right to 3 (note gallery image moves completely off of the page)

 

This is what happens to me when using the section inside of my child themes sections folder. This to me seems wrong as when you decrease the width surely the gallery images should also get smaller allowing you to have two gallerys side my side (like two columns).

 

More than happy to provide you a login acc if you would like to test on my site.

 

Thanks, James


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites
James B    436
James B

Hi James

 

I get the same effect until the page is published. The image is bigger than the container even once the image is resized, only once the page is published and refreshed it resizes etc.

 

When eidting - http://screencast.com/t/L7B4QlbOW1b

 

Once refreshed and published - http://screencast.com/t/T8nMxY1fCGc

 

If you're looking to place the gallery next to each other in the layout, add the two column layout into the drag and drop, then add the gallery section into each of the columns. http://screencast.com/t/nJPZqD8cPH


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
JawDesigns    11
JawDesigns

Great ok thanks James,

 

Just one more thing, will the sections get updated now they have been copied into the child themes folder?

 

Cheers, James


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, no unfortunately they won't get updated automatically if removed from the original child theme, that just gets issued with the theme updates. Best thing to do would be keep the theme in the theme screen inactive and if you see there's an update available download it manually and then update the sections in your custom child theme.

  • Like 1

Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
JawDesigns    11
JawDesigns

Ok cool, thanks for the advice James. You have been very helpful :-)


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites
James B    436
James B

You're very welcome :-)


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • jojoking
      By jojoking+
      I have to admit to being baffled.
      I'm trying to embed a video (from my WP media library) within a WP post using the videobox section shortcode.
      The shortcode section popup only allows two items to be configured - the section type, in this case videobox - and a unique id. There's no URL or other parameters such as autoplay or loop which are available within the Pagelines editor.
      Whatever I put in the unique ID makes no difference to what is shown which seems to be a default video with stars or white noise on a black background.
      I assume I need to define this ID somewhere else, or maybe WP has done it for me?
      HELP!
       
      PS This is the page source generated when a shortcode is added within the WP post editor
      <!-- VideoBox | Section --> <section id="videobox_1675853156" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="1675853156" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="280414138" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/plugins/pl-section-videobox/default.mp4?r=280414138" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#280414138')[0].load(); </script> </div> </div></div></section> </div>  
      If I add a videobox section using the Pagelines page editor the page source generated includes my video:
      <!-- VideoBox | Section --> <section id="videobox_udvu4uz" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="udvu4uz" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="429558737" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/uploads/2017/04/HIHWelcome.mp4?r=429558737" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#429558737')[0].load(); </script> </div> </div></div></section>  
    • cstudio
      By cstudio
      How do I control the lightbox effect on the plugin "popthumbs"?  On mobile, it opens up much to small then when expanded it opens to large.  I would like to control the the lightbox to like 90% of the viewer window but I can't figure out how/where to control that.
      Site example

       
      Thx
    • flourishdesignstudio
      By flourishdesignstudio
      Hi,
      I am having an issue with the Lax sections on Platform 5. I can embed a widget or text box into a Lax section which is really neat, but the image in the background (the parallax image) seems to get stretched and doesn't scale in an attractive way.  For example, the page http://ed6.61e.myftpupload.com/#clients has a parallax section with a woman's face  and I thought is would scale as the browser window gets smaller but the zoom-level never changes. Also, the amount of parallax shift seems more dramatic than what we want. I thought that if I uploaded a shorter image it would scan/scroll less since the height from the image's top to bottom would be less. However, that doesn't seem to have any effect and I am at a loss of how to properly control the way the image is displayed within that box. Any thoughts, tips, or suggestions to get me pointed in the right direction?
      Thanks so much for the help!
    • PierreFF
      By PierreFF+
      Hello Everyone, 
      I think this one is for the pagelines team. 
      I have some trouble with the Adventure section plugin https://www.pagelines.com/product/pl-section-adventure/ that doesn't seem to load in any of the three websites I run using pagelines. 
      I do the setup via the extend platform as usual. It tells me that the plugin is installed and activated but unfortunately it doesn't appear on the page editor.
      I have just tried it consecutively with three websites I own with the same result.
      My intention was to use it with this website: http://launchpadweekend.foundersofthefuture.co/ (free version)
      And I also tried with this website http://foundersofthefuture.co/ (pro license) and this one http://ffactor.me/ (free version). And I have the same problem with each. 
      I would love to see how I could solve this issue. 
      Thanks a lot. 
      Pierre
       
    • chamois_blanc
      By chamois_blanc+
      What is the right/best way to make a one-page website with PL5? The framework seems to hardcode section IDs without any possibility of changing them. Scrolling to a page section requires the link to use the section ID, ie <a href="#<section_ID>">...</a>. I don't see myself hardcoding weird section IDs in there as this will show up in the address bar.
      Please advise, thanks!
×