Jump to content

Archived

This topic is now archived and is closed to further replies.

toddlo

Urgent; comments disappearing...

Recommended Posts

toddlo

When I am logged in, I can make and see comments. When I log out, the comments that I have made are not displayed. The site is at http://thesnowballeffect.com. What am I missing?!?!?!

Share this post


Link to post
Share on other sites
Danny

Hi,

 

From what I've just tested, it appears to be a bug with JetPack comments, if that is what you're using. If you can confirm you're using JetPack comments, I will add this to the tracker.

If that is the case, you will probably want to disable JetPack comments for the meantime.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
toddlo

Jetpack comments are disabled. I tried installing disqus. Disqus disappear in the same way...

Share this post


Link to post
Share on other sites
toddlo

When I try to place comments in the single post page column, I get Blog token not found...

Share this post


Link to post
Share on other sites
toddlo

Any more thoughts? This client is an author with a new book and I'm going to lose her if I don't get comments working now!!!

Share this post


Link to post
Share on other sites
Simon

Firstly it looks like you dont even have the comments section in the blog post template areas.

 

Secondly if you 'view source' in your browser and tke a look at the top, you have 7 blank lines. This is probably caused by some blank lines in a php file somewhere that you have edited.

This WILL break ajax and is probably why no comments appear when you do have the comments section in place.

Share this post


Link to post
Share on other sites
toddlo

As you can see, the comments are installed; https://www.evernote.com/shard/s3/sh/2afa40f0-68a4-4a8b-978f-9e0f87f5f7e8/2b6c2720b6eeac40df43efe923ae660c

 

When I switch out the layout mode or whatever you call it, it's still there; https://www.evernote.com/shard/s3/sh/70b2b6e6-8c42-411b-a599-b7aa46af6aa1/392785870ee1fa8640969d572d191ffc

 

btw, I have not edited any php files...

Share this post


Link to post
Share on other sites
Simon

Ah its wpengine, go in and clear their caches.

Share this post


Link to post
Share on other sites
toddlo

No, it's actually the ManageWP - Worker plugin that was adding the lines...

Share this post


Link to post
Share on other sites
Simon

Well you still have the 7 extra lines.

 

When you make edits to a production site on WPEngine you HAVE to click the cache clar button in the WPEngine control panel every time to see the changes.

 

Unless you use their staging area which has no caching whatsoever.

Share this post


Link to post
Share on other sites
toddlo
Congratulations!

valid-rss-rogers.png This is a valid RSS feed.

Share this post


Link to post
Share on other sites
James B

Glad you've resolved, thank you for updating the thread.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • werdnags
      By werdnags+
      I know this does not have anything to do with Pagelines directly but this is happening on my PL5 site.  At the bottom of my blog posts I have put the Facebook Comments Plugin and it works well but when people are leaving comments they are the same for every post.  Does anyone have any idea on how to solve this so the comments are for the post they are on.  Does that make sense? Ha!
      Thanks for any ideas folks.
    • MissT
      By MissT+
      Does the magazine section not support comments?  I have comments allowed but they aren't showing on post pages and there doesn't seem to be a way to add a comments section in either.
      Many thanks in advance.
    • photomom86
      By photomom86+
      I have installed and activated the disqus comments plugin and no matter what I do the comments will not show up on my posts. Is this a know glitch with disqus and pagelines?
    • Jason J
      By Jason J
      Hello all,
      I realize there's a chance that this super-basic question is going to make me look foolish, but I can't find a setting for it.
      Most blogs I come around allow people to reply to a specific comment (there's a reply link for each comment as opposed to just one reply at the bottom of the comment list).
      On a blog I manage that's using Pagelines (and foolishly not a child theme), there's no such reply link for each comment, only one at the bottom of the page.  I thought maybe there was a comments setting somewhere that would enable "in-line" commenting, but I couldn't find one.
      Am I overlooking something very basic, or is it a matter of adjusting the theme code to allow this?
      Thanks in advance,
      -jason
    • rrosewarne
      By rrosewarne
      Hi
      The comments on blog posts isn't working? it used to but now if you click the 'leave comment' link it goes to the bottom of the page and there is no comment box
      http://www.rosewarnegardens.com/the-joys-of-a-qualified-horticulturalist/
×