Jump to content

Archived

This topic is now archived and is closed to further replies.

decarlocarolis

Search form error 502 Bad Gateway

Recommended Posts

decarlocarolis    0
decarlocarolis

Hello, when I try to search, either through navbar and widget, the result produces an error: 502 Bad Gateway. it is the fault of wordpress or dms?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

HI,

 

A 502 bad gateway is most likely caused by your server. To remove the fact that its a DMS error (which I highly doubt, just tested the search on my test site), disable DMS as your active theme and enable Twenty Twelve, Thirteen etc.. and then do a search again. If the issue persists, its likely a server error.

However, I would disable all active plugins prior to testing the suggestions above, to rule out the possibility of a plugin causing the problem.

 

If none of the above, resolves your issue, you will need to contact your web host provider.

Also, make sure that Wordpress, DMS and all plugins are up to date.

  • Like 1

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • John Olsson
      By John Olsson+
      Hello, i'm working on a webshop, and got this code to really boost the search within WP. But when adding this code to functions.php the front end media library search flipped totally, and not working at all, any ideas what's the problem?
      function atom_search_where($where){ global $wpdb; if (is_search()) $where .= "OR (t.name LIKE '%".get_search_query()."%' AND {$wpdb->posts}.post_status = 'publish')"; return $where; } function atom_search_join($join){ global $wpdb; if (is_search()) $join .= "LEFT JOIN {$wpdb->term_relationships} tr ON {$wpdb->posts}.ID = tr.object_id INNER JOIN {$wpdb->term_taxonomy} tt ON tt.term_taxonomy_id=tr.term_taxonomy_id INNER JOIN {$wpdb->terms} t ON t.term_id = tt.term_id"; return $join; } function atom_search_groupby($groupby){ global $wpdb; // we need to group on post ID $groupby_id = "{$wpdb->posts}.ID"; if(!is_search() || strpos($groupby, $groupby_id) !== false) return $groupby; // groupby was empty, use ours if(!strlen(trim($groupby))) return $groupby_id; // wasn't empty, append ours return $groupby.", ".$groupby_id; } add_filter('posts_where','atom_search_where'); add_filter('posts_join', 'atom_search_join'); add_filter('posts_groupby', 'atom_search_groupby');  
    • Queue-it
      By Queue-it+
      HI,
      Search function doesn't seem to work. 
      When ever searching for something it redirect to the home page and add the search string to the url.
      For example searching for "cases" it would display https://queue-it.com/?s=cases
      Do you know how to solve that? 
    • MissT
      By MissT+
      Would be great to have the ability to include a search option within menus and within Splashup - is this possible?
    • balfred1345
      By balfred1345
      null When I tested Search using the search field in Navi, it throws the error as shown in pastebin: http://pastebin.com/DJ079bmy
      Is there a fix for this? If there is no fix, can you please tell me how to disable search in Navi?
      Thanks,
      Bruce
    • MissT
      By MissT+
      Hi there,
      Just wondering if there is a reason why there is no search option within Multimenu as there is with Navi - would be good if it did have it and it worked in a similar way and you could switch it off when you need to.
      Many thanks.
×