Jump to content

Archived

This topic is now archived and is closed to further replies.

massmosaic

Masthead video show up underneath heading

Recommended Posts

massmosaic    0
massmosaic

Hi Pagelines,

 

I'm trying to get a local masthead section to display the video (i.e. the contents from the "masthead splash options") underneath the masthead title. Currently the video is on top.

 

Is there a simple way to do this using the CSS editor (w/o changing the section core files)?? 

 

Thank you very much!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi.

 

It is not possible to reposition the Image or Video to underneath the Masthead title with CSS. To reposition the image/video option, you will need to edit the section.php file and reposition it yourself. If you wish to make changes such as these, we recommend creating a child of that section by using a child theme.

 

You can find more info about how to do this here - http://docs.pagelines.com/advanced/override-sections

 

Alternatively, you could probably use a hook to add your own image/video beneath the Masthead Section or just use a MediaBox section, this should display as though they're part of the same section.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
massmosaic    0
massmosaic

Very good, I will create a child section.

 

You all have made it very simple.

 

Thx Danny

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • StuLeeUK
      By StuLeeUK+
      Good morning,
      I have set up my homepage using the Elements sections, a Masthead at the top and then a selection of Heroes lower down.
      I only just realised that the Heroes set a H1, as does the Masthead.
      Is there an easy way I can change the Heroes to an H2/H3 etc so as to improve the structure of my headers, whilst keeping the Masthead as H1?
      I really don't know much at all about CSS, which is why I use Pagelines because it's just so easy to create good looking pages without too much confusion.
       
      page for reference is https://www.avangocouriers.co.uk
      Thanks,
      Stu
    • pehja
      By pehja+
      https://pehjaproduction.se/webbdesign/  Video is not showing up in Journey section. Why? I have entered this in the settings 
       
    • dougalperman
      By dougalperman+
      Hi there,
      I'm a big fan of Pagelines, and have been for years.
      I'm trying to control the size of video embeds and having some difficulty. I see that I can just paste the Vimeo video URL into the post and an embed widget will automatically appear, which is great. But the embed box created is much taller that the video (689 x 1000 pixels) so the content sits in the middle of a tall black box, which looks awkward.
      I tried using the full iFrame embed code from Vimeo, which solved the disproportionate embed frame size (or aspect ratio) issue, but despite specifying the dimensions I want (690 x 388), the videos displayed on the post are sized at 300 x 150 pixels.
      I can't work out how to change either.
      I'm using the latest version of Pagelines Framework (Pro) with the Agency them.
      Any help or advice very much appreciated.
      Thanks,
      Dougal
    • janpeeters
      By janpeeters+
      Hi all,
      I was totally excited to find out about 'CSS Hero' (http://www.csshero.org) I read about it in the compatible plugins section of the PL5 docs (http://www.pagelines.com/resources/compatible-plugins) For me it's a great way to more easily customize my sites because I'm not a CSS pro.
      I'm wondering about one thing though… Does anyone know if using this will result in a heavy penalty on page loading speeds? Would love to start using it but only if it doesn't cost too much in terms of speed.
      Thanks, Jan
    • crose
      By crose+
      Hi,
      I am using the Canvas Area section at the top of my site. I have a video playing in the background, which works really well on desktop. But on mobile video doesn't play without user interaction, so I have a static image in place as an alternate image. However when viewed on a mobile device there is now a play button over the static image that does nothing. This didn't use to happen so I imaging it is due to an upgrade. But this is really bad UX. Is there a way to remove it?
      Here is the site:
      http://gator4088.hostgator.com/~asif/
      Thanks in advance.
      Chuck
×